Scrolling in the view-source window

Bug #45836 reported by Vladimír Lapáček on 2006-05-21
4
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Confirmed
Low
firefox (Ubuntu)
Medium
Unassigned

Bug Description

Using the latest Dapper (05/21/06), I have problems with the view-source window. When the source window is maximized and I want to select text by mouse going from right to left the window does not scroll when hitting the left edge. Going from left to right works well. Also Unmaximized window works in both directions.

To recreate:

1) Open a view-source window by View > Page Source.
2) Maximize the view-source window.
3) Check that there is a line wider then the actual view-source window and go to the end of this line.
4) Select text from the end of this line going far left.
5) Window does not scroll.

Err... WFM: Win2k/2003053108.
-> ViewSource

Confirming on WinXP 2003053108.

It seems to only happen on some pages. In the reporter's page, I can't scroll
right, but in THIS page, I can.

Created attachment 125004
Can't scroll on this one.

Created attachment 125005
Can scroll on this one.

When the source is more than one screen high, you can highlight-scroll to the
right. Otherwise, you can't.

(In reply to comment #4)
> When the source is more than one screen high, you can highlight-scroll to the
> right. Otherwise, you can't.

I reasoning I have discovered: You cannot scroll to the left when the View
Source window is maximized on screen. You can scroll left when the window is
not maximized.

You cannot scroll to the right when the View Source window is maximized on
screen and the page source is too short to have scrollbars. If the page source
is long enough to have scrollbars (see the "Can scroll on this one." attachment
introduced in comment #4), then scrolling can occur. You can scroll right when
the view source window is not maximized.

It would appear (without looking into the code) that scrolling occurs only when
the mouse leaves the "frame" of the view source window actually being viewed.
With the window maximized, the mouse cannot leave that frame to the left because
no more screen real-estate exists. If the page source is long enough to have a
vertical scrollbar, then scrolling to the right will work as the mouse seems to
leave the visible view source frame.

Vladimír Lapáček (vil) wrote :

Using the latest Dapper (05/21/06), I have problems with the view-source window. When the source window is maximized and I want to select text by mouse going from right to left the window does not scroll when hitting the left edge. Going from left to right works well. Also Unmaximized window works in both directions.

To recreate:

1) Open a view-source window by View > Page Source.
2) Maximize the view-source window.
3) Check that there is a line wider then the actual view-source window and go to the end of this line.
4) Select text from the end of this line going far left.
5) Window does not scroll.

Changed in firefox:
status: Unconfirmed → Confirmed

I would like to confirm this behavior from a issue report at https://bugs.launchpad.net/products/firefox/+bug/45836

Tanks David

Changed in firefox:
status: Unknown → Confirmed
Alexander Sack (asac) wrote :

upstream confirmed bugs are 'In Progress' for us. Setting status accordingly.

Changed in firefox:
assignee: nobody → mozillateam
status: Confirmed → In Progress
David Farning (dfarning) on 2007-02-24
Changed in firefox:
assignee: mozillateam → mozilla-bugs
Alexander Sack (asac) on 2008-10-31
Changed in firefox:
assignee: mozilla-bugs → nobody
status: In Progress → Triaged
Changed in firefox-3.0:
importance: Undecided → Medium
status: New → Triaged
Micah Gersten (micahg) wrote :

No more fixes for Firefox 2.

Changed in firefox (Ubuntu):
status: Triaged → Won't Fix

SeaMonkey trunk is now using toolkit viewsource.

Changed in firefox:
importance: Unknown → Low
Adolfo Jayme (fitojb) on 2013-01-30
Changed in firefox (Ubuntu):
status: Won't Fix → Triaged
no longer affects: firefox-3.0 (Ubuntu)
madbiologist (me-again) wrote :

Official support for Dapper, and for Firefox 2 and 3, has ended. If this bug is still occurring on Ubuntu 17.04 "Zesty Zapus" please run ubuntu-bug to file a new bug report so that we can get a fresh set of log files and system info.

tags: added: dapper
Changed in firefox (Ubuntu):
status: Triaged → Invalid
Changed in firefox:
status: Confirmed → Unknown
Changed in firefox:
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.