repeated crash BadIDChoice on hardy

Bug #255195 reported by Robert Collins on 2008-08-06
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Unknown
firefox-3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.0

This is happening repeatedly; I ran ff from console to get more data:

        ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot
        be preloaded: ignored.
        ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be
        preloaded: ignored.
        ** Message: GetValue variable 1 (1)
        ** Message: GetValue variable 2 (2)
        ** Message: GetValue variable 1 (1)
        ** Message: GetValue variable 2 (2)
        ** Message: GetValue variable 1 (1)
        ** Message: GetValue variable 2 (2)
        ** Message: GetValue variable 1 (1)
        ** Message: GetValue variable 2 (2)
        ** Message: GetValue variable 1 (1)
        ** Message: GetValue variable 2 (2)
        ** Message: GetValue variable 1 (1)
        ** Message: GetValue variable 2 (2)
        GCJ PLUGIN: thread 0x622990: NP_GetMIMEDescription
        GCJ PLUGIN: thread 0x622990: NP_GetMIMEDescription return
        GCJ PLUGIN: thread 0x622990: NP_GetValue
        GCJ PLUGIN: thread 0x622990: NP_GetValue: returning plugin name.
        GCJ PLUGIN: thread 0x622990: NP_GetValue return
        GCJ PLUGIN: thread 0x622990: NP_GetValue
        GCJ PLUGIN: thread 0x622990: NP_GetValue: returning plugin description.
        GCJ PLUGIN: thread 0x622990: NP_GetValue return
        ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot
        be preloaded: ignored.
        ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be
        preloaded: ignored.
        The program 'firefox' received an X Window System error.
        This probably reflects a bug in the program.
        The error was 'BadIDChoice (invalid resource ID chosen for this
        connection)'.
          (Details: serial 18898088 error_code 14 request_code 53 minor_code 0)
          (Note to programmers: normally, X errors are reported asynchronously;
           that is, you will receive the error a while after causing it.
           To debug your program, run it with the --sync command line
           option to change this behavior. You can then get a meaningful
           backtrace from your debugger if you break on the gdk_x_error()
        function.)

Marcus Asshauer (mcas) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you please try to obtain a backtrace by following the instructions on [WWW] https://wiki.ubuntu.com/MozillaTeam/Bugs, or upload (as an attachment) the crash report from /var/crash/.

Also, please answer these questions:
Is this crash reproducible? If so, which are the steps that lead to it?
Which flash package do you have installed?
Which Java package do you have installed?
Which Firefox extensions do you have installed?

This will greatly aid us in tracking down your problem.

Changed in firefox-3.0:
status: New → Incomplete

On Wed, 2008-08-06 at 06:18 +0000, mcas wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. Could you please try to obtain a backtrace by following
> the instructions on [WWW] https://wiki.ubuntu.com/MozillaTeam/Bugs, or
> upload (as an attachment) the crash report from /var/crash/.

Its not segfaulting, so there is no SIGSEGV and no crashdump to be
retraced.

> Also, please answer these questions:
> Is this crash reproducible? If so, which are the steps that lead to it?

It seems to be at the moment: open up my browser and wait for about 5
minutes;

> Which flash package do you have installed?

flashplugin-nonfree 9.0.124.0ubuntu2

> Which Java package do you have installed?

icedtea-java7-plugin 7~b24-1.6-0ubuntu5 ? I don't know if thats the
right thing to report on...

> Which Firefox extensions do you have installed?

just those, and stumbleupon and downloadhelper (and the ubuntu stock
thing too)

Cheers,
Rob
--
GPG key available at: <http://www.robertcollins.net/keys.txt>.

For what it is worth, I've been experiencing this for some time on 64-bit Fedora 9. And I don't have any plugin for Flash.

It isn't reproducible. It happens every few days. I'm having trouble using gdb on Firefox so I don't have much diagnostic information to add. GDB keeps stopping the program and going into command mode with the message:

  Cannot get thread event message: debugger service failed

Eventually this locks up X.

Changed in firefox:
status: Unknown → Confirmed
Changed in firefox:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.