Firefox moves to current desktop when opening a link from an external app

Bug #204927 reported by Manuel McLure on 2008-03-22
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Metacity
Fix Released
Unknown
Mozilla Firefox
Confirmed
Unknown
firefox-3.0 (Ubuntu)
Undecided
Unassigned
metacity (Ubuntu)
Undecided
Ubuntu Desktop Bugs

Bug Description

Binary package hint: firefox-3.0

Kubuntu Hardy Heron Beta (upgraded from Gutsy Gibbon)

I have a 3x3 desktop set up, with Firefox 3 maximized on desktop 4 (second row, first column) and Kontact maximized on desktop 2 (first row, second column.) When I click on a link in Kontact, Firefox 3 opens a new tab for it, but it also moves from desktop 4 to desktop 2, covering my Kontact window. In Gutsy Firefox 2 would remain on desktop 4 which is where I want it to stay.

Manuel McLure (manuel-mclure) wrote :

I tested with Firefox-2 on Hardy and it works as it did in Gutsy. This seems to be a Firefox 3 bug.

Manuel McLure (manuel-mclure) wrote :

Further information - if I start Firefox 3, but tell Kontact to use firefox-2 as its browser, links will be opened in new tabs in the Firefox 3 window and the Firefox 3 window will NOT move to the current desktop.

I still have this same issue on a fresh install of hardy beta.

one user reported solving this issue by doing:

rm -rf .mozilla/

this did not work for me. firefox 3b4 still moves to the current desktop when opening a link from any external application.

Changed in firefox-3.0:
status: New → Confirmed

I've also tried downloading and manually installing Firefox 3b4 from mozilla (/opt/firefox with symlink to /usr/local/bin/firefox). I have the same issue with a manual installed copy and having removed .mozilla/ for any previous settings..

breaking news.. this bug does *not* happen if compiz is active (default settings). I had turned this off because it is a bit much for my EeePC, but toggling it on & off seems to reproduce/solve the issue consistently.

Joe Smith (yasumoto7) wrote :

This has been an issue in the Firefox3 nightlies for a while (at least 7.10), take a look at the discussion upstream.

Mogens Isager (misager) wrote :

Maybe it is a problem in the window manager. For Metacity it seems to be the case. Via

http://christopher.aillon.org/blog/dev/gnome/20080303-metacity.html

I found

http://bugzilla.gnome.org/show_bug.cgi?id=482354

Try to toggle browser.tabs.loadDivertedInBackground in about:config?

devilspie ftw. It stops a lot of these shenanigans.

Changed in firefox:
status: Unknown → Confirmed
x (xk2c-deactivatedaccount) wrote :

For the record:
happens with kde (hardy) also

James Westby (james-w) wrote :

Hi all,

Setting

  browser.tabs.loadDivertedInBackground = true

in about:config is reported to work.

Also the upstream bug confirms what Christer found,
that this is a metacity issue, see

  http://bugzilla.gnome.org/show_bug.cgi?id=482354

I'm adding a metacity task so that this can be tracked
appropriately in launchpad.

Thanks,

James

Changed in metacity:
assignee: nobody → desktop-bugs
status: New → Triaged
Lars Ljung (larslj) wrote :

Isn't this a duplicate of bug #197761?

Manuel McLure (manuel-mclure) wrote :

Note that if this is a bug in metacity, it is also a bug in kwin. I use KDE and was the bug reporter.

Manuel McLure (manuel-mclure) wrote :

browser.tabs.loadDivertedInBackground does NOT fix this under kwin. The only difference in the behavior is that FF doesn't change desktops until you make the desktop that has FF on it current:

- Place FF on desktop 2, Kontact on desktop 1.
- Click on a link in Kontact. FF will not move to desktop 1.
- Make desktop 2 current - now FF will jump to desktop 1.

This behavior is *WORSE* than it is without browser.tabs.loadDivertedInBackground set.

Honestly, this makes FF3 unusable on KDE.

Changed in metacity:
status: Unknown → Confirmed
Changed in metacity:
status: Confirmed → In Progress
Bruno Beaufils (beaufils) wrote :

Note that if this is a bug in metacity, it is also a bug in Openbox.

Changed in metacity:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.