Comment 6 for bug 175904

What did you use as "Command" ? (in Preferred Applications)

Try "firefox-3.0 %s", works for me.