Firefox Search Engine is Broken

Bug #1096286 reported by Leo H on 2013-01-05
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Medium
firefox (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned
Oneiric
Low
Unassigned
Precise
Low
Unassigned
Quantal
Low
Unassigned

Bug Description

Firefox (package: firefox 17.0.1+build1-0ubuntu0.12.10.1) has several search engines pre-installed. One is labelled "Chambers (UK)". This search link is broken:

When, for example, putting in the search term "Test", then Firefox goes to the following URL

www.chambersharrap.co.uk/chambers/chref/chref.py/main?query=Test&title=21st&sourceid=Mozilla-search

This results in the display of an error page ("HTTP Error 404 - File or directory not found").

This error has been persistent for the past four weeks, suggesting a fundamentally broken search link.

Using the Chambers search from the search bar results in a 404 error, eg, a search for "Test" gives the following URL:

http://www.chambersharrap.co.uk/chambers/chref/chref.py/main?query=Test&title=21st&sourceid=Mozilla-search

Note that the following URL template does work:

http://www.chambers.co.uk/search.php?query={searchTerms}&title=21st&sourceid=Mozilla-search

This was originally reported at https://launchpad.net/bugs/1096286

Changed in firefox (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Chris Coulson (chrisccoulson) wrote :

Thanks, I've forwarded this upstream

Changed in firefox:
importance: Unknown → Medium
status: Unknown → Confirmed

Created attachment 698337
Temporarily remove chambers search plugin [Checked into beta: Comment 3]

As the next release is only days away, there won't be time to fix and get approval for the change.

Created attachment 698339
Fix chambers search plugin

I will also need to find the correct person at Chambers (UK) to confirm they are happy this is correct and Mozilla can use the search engine.

Comment on attachment 698337
Temporarily remove chambers search plugin [Checked into beta: Comment 3]

http://hg.mozilla.org/releases/l10n/mozilla-beta/en-GB/rev/16601cf57598
This should make it into the upcoming Firefox 18

Heads-up to release-mgmt...

This is not going to be in Firefox 18, as I've posted to .l10n, the last change date for that was back in December 24th.

I'm personally inclined to review a patch that removes chambers alltogether from aurora and then beta for 19. I'm not sure if we should keep a plugin that is either not used in any significant way, so chambers doesn't notice they're breaking something, or that chambers doesn't mind breaking without saying so upfront.

Changed in firefox:
status: Confirmed → In Progress

Guys, just one note: for any productization[1] changes, you'll need to ask for review from either me or Axel, and make sure not to push any changes upstream before you get an r+.

Anyhow, post-commit r+ on removing Chambers.

[1] https://wiki.mozilla.org/L10n:Firefox/Productization

(In reply to Axel Hecht [:Pike] from comment #5)
>
> I'm personally inclined to review a patch that removes chambers alltogether
> from aurora and then beta for 19. I'm not sure if we should keep a plugin
> that is either not used in any significant way, so chambers doesn't notice
> they're breaking something, or that chambers doesn't mind breaking without
> saying so upfront.

Indeed, after doing a quick Google search I found this SUMO article from 4 months ago, so it looks like it has been broken for quite a long time already with hardly anybody noticing:

http://support.mozilla.org/en-US/questions/936287

(In reply to Chris Coulson from comment #7)
> (In reply to Axel Hecht [:Pike] from comment #5)
> >
> > I'm personally inclined to review a patch that removes chambers alltogether
> > from aurora and then beta for 19. I'm not sure if we should keep a plugin
> > that is either not used in any significant way, so chambers doesn't notice
> > they're breaking something, or that chambers doesn't mind breaking without
> > saying so upfront.
>
> Indeed, after doing a quick Google search I found this SUMO article from 4
> months ago, so it looks like it has been broken for quite a long time
> already with hardly anybody noticing:
>
> http://support.mozilla.org/en-US/questions/936287

Depends what the en-GB user base is, I have no visibility of those figures, or how many people have been using the chambers' searchplugin (historically / currently).

en-GB is not offered automatically from IE or any other browser with OS/browser both being en-GB locale, so, if a user wants to switch from the shipped default, they get given Firefox en-US unless they know to click on "Systems & Languages". This will probably reduce the user base but not sure by how much.

Linux distributions do ship localised versions so, if the user updates the distribution, they do get the correct localised update.

Not sure what happens with Windows/OS X for en-GB on the release channel, but will see for Windows after next release.

The link in the article gives some working searchplugins:
http://mycroft.mozdev.org/search-engines.html?name=chambers
Should one of those be used? Is there a history available?

My main concern is that chambers didn't bother telling anyone that they changed their site.

I'm not concerned that en-GB users would be scarse per se (they're not, en-GB is one of our top-10 localizations), or that they wouldn't use non-default plugins as much as others (nobody but my mom does. honestly, my mom does.)

(In reply to Axel Hecht [:Pike] from comment #9)
> My main concern is that chambers didn't bother telling anyone that they
> changed their site.
I'd like to try and find out what contacts we have on both sides, as I guess there have been changes since the original plugin was created - would there have even been any sort of agreement and, if so, where/who would have had copies?

bug 348023 has some pointers to that.

Leo H (leo-h-hildebrandt) wrote :

As regards the idea of dropping Chambers from Firefox Search:

I feel that a reputable UK-English dictionary search engine such as Chambers is a valuable feature of Firefox.

Also, it is not only relevant to UK users of Firefox. In many other countries where English is a second language, the interest in UK English, its spelling and usage, remains quite strong. And many English language educational programmes worldwide require that students use a quality UK-English dictionary.

Changed in firefox (Ubuntu):
status: Triaged → Fix Committed
Changed in firefox (Ubuntu Lucid):
importance: Undecided → Low
Changed in firefox (Ubuntu Oneiric):
importance: Undecided → Low
Changed in firefox (Ubuntu Precise):
importance: Undecided → Low
Changed in firefox (Ubuntu Quantal):
importance: Undecided → Low
Changed in firefox (Ubuntu Lucid):
status: New → Fix Committed
Changed in firefox (Ubuntu Oneiric):
status: New → Fix Committed
Changed in firefox (Ubuntu Precise):
status: New → Fix Committed
Changed in firefox (Ubuntu Quantal):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 19.0~b1+build2-0ubuntu1

---------------
firefox (19.0~b1+build2-0ubuntu1) raring; urgency=low

  * New upstream release from the beta channel (FIREFOX_19_0b1_BUILD2)
 -- Chris Coulson <email address hidden> Tue, 08 Jan 2013 21:19:54 +0000

Changed in firefox (Ubuntu):
status: Fix Committed → Fix Released

From bug 348023, it was Mic who last dealt with this, ccing in case Mic knows updated contact details.

Mic's not with mozilla for a while, any contacts she might have had are lost by now.

Created attachment 712244
Add back Chambers for en-GB

I have been in contact with Chambers (part of Hodder Education now). I have confirmed with them that we are allowed to make use of their search engine through the search plugin and we are using the correct URL.
The current contact is:
Laura Vile
Marketing Executive
Hodder Consumer Learning
Tel: 0207 053 6766
Her email is of the form firstname.lastname at hoddereducation.co.uk

Comment on attachment 698339
Fix chambers search plugin

This is the patch for aurora, the other is for beta

If this is left unfixed for FF19 release, we'll be in the same position as FF18 release correct?

(In reply to Alex Keybl [:akeybl] from comment #17)
> If this is left unfixed for FF19 release, we'll be in the same position as
> FF18 release correct?

I don't believe anything landed in time for FF18, so FF18 had the 404, at the moment FF19 will have no Chambers search plugin.

(In reply to Ian Neal from comment #18)
> I don't believe anything landed in time for FF18, so FF18 had the 404, at
> the moment FF19 will have no Chambers search plugin.

No need to track in that case. Thanks for the context.

Comment on attachment 698339
Fix chambers search plugin for FF19 and above

This is for FF20 and above.

Comment on attachment 712244
Add back Chambers for en-GB

This is for FF19

Comment on attachment 712244
Add back Chambers for en-GB

Sorry for the bugspam

(In reply to Alex Keybl [:akeybl] from comment #19)
> (In reply to Ian Neal from comment #18)
> > I don't believe anything landed in time for FF18, so FF18 had the 404, at
> > the moment FF19 will have no Chambers search plugin.
>
> No need to track in that case. Thanks for the context.

Sorry, I got confused. FF19 and above will have the 404

(In reply to Ian Neal from comment #23)
> (In reply to Alex Keybl [:akeybl] from comment #19)
> > (In reply to Ian Neal from comment #18)
> > > I don't believe anything landed in time for FF18, so FF18 had the 404, at
> > > the moment FF19 will have no Chambers search plugin.
> >
> > No need to track in that case. Thanks for the context.
>
> Sorry, I got confused. FF19 and above will have the 404

This is much too late to take a fix in FF19, unless absolutely critical. Can somebody please clarify:

* Expected behavior (search works)
* FF18's behavior (?)
* FF19's current behavior (sounds like 404)

If we are matching FF18's behavior (at least similarly), no action in FF19 will be taken at all.

(In reply to Alex Keybl [:akeybl] from comment #24)
> (In reply to Ian Neal from comment #23)
> > (In reply to Alex Keybl [:akeybl] from comment #19)
> > > (In reply to Ian Neal from comment #18)
> > > > I don't believe anything landed in time for FF18, so FF18 had the 404, at
> > > > the moment FF19 will have no Chambers search plugin.
> > >
> > > No need to track in that case. Thanks for the context.
> >
> > Sorry, I got confused. FF19 and above will have the 404
>
> This is much too late to take a fix in FF19, unless absolutely critical. Can
> somebody please clarify:
>
> * Expected behavior (search works)
Correct
> * FF18's behavior (?)
404
> * FF19's current behavior (sounds like 404)
404
>
> If we are matching FF18's behavior (at least similarly), no action in FF19
> will be taken at all.
Marking as wont fix for FF19 then, and setting tracking? for FF20 - I don't want to miss another boat.

Comment on attachment 698339
Fix chambers search plugin for FF19 and above [Checked in: Comment 27]

Review of attachment 698339:
-----------------------------------------------------------------

r=me.

Please land on aurora with a check-in comment referencing this bug and my review, like "bug 827019, fix url in chambers search, <email address hidden>".

Comment on attachment 698339
Fix chambers search plugin for FF19 and above [Checked in: Comment 27]

http://hg.mozilla.org/releases/l10n/mozilla-aurora/en-GB/rev/26664edf2f65

Thanks

Changed in firefox:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 19.0+build1-0ubuntu0.12.04.1

---------------
firefox (19.0+build1-0ubuntu0.12.04.1) precise-security; urgency=low

  * New upstream stable release (FIREFOX_19_0_BUILD1)
    - see LP: #1128883 for USN information
    - Fix LP: #1096286 - 404 error when using Chambers (UK) search.
      Temporarily remove the plugin

  * Update globalmenu-extension to 3.7.1
    - Update for imagelib changes in Firefox 19 and 20
    - Update for nsCAutoString removal in Firefox 19
    - Don't #include mozilla/dom/Element.h anywhere, as that now pulls
      in a lot of internal headers since Firefox 19
  * Fix LP: #1064423 - "Submitting your report..." shows missing-icon icon.
    Install the throbber icon in the package
    - update debian/firefox.install.in
  * Refresh patches
    - update debian/patches/allow-lockPref-everywhere.patch
    - update debian/patches/ionmonkey-hardfp-support.patch
    - update debian/patches/fix-broken-langpack-install-manifests.patch
  * Switch to encrypted search for Google
    - update debian/searchplugins/en-GB/google.xml
    - update debian/searchplugins/en-US/google.xml
    - update debian/searchplugins/en-ZA/google.xml
    - update debian/searchplugins/ja/google-jp.xml
    - update debian/searchplugins/ku/google-ku.xml
 -- Chris Coulson <email address hidden> Fri, 15 Feb 2013 22:24:53 +0000

Changed in firefox (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 19.0+build1-0ubuntu0.11.10.1

---------------
firefox (19.0+build1-0ubuntu0.11.10.1) oneiric-security; urgency=low

  * New upstream stable release (FIREFOX_19_0_BUILD1)
    - see LP: #1128883 for USN information
    - Fix LP: #1096286 - 404 error when using Chambers (UK) search.
      Temporarily remove the plugin

  * Update globalmenu-extension to 3.7.1
    - Update for imagelib changes in Firefox 19 and 20
    - Update for nsCAutoString removal in Firefox 19
    - Don't #include mozilla/dom/Element.h anywhere, as that now pulls
      in a lot of internal headers since Firefox 19
  * Fix LP: #1064423 - "Submitting your report..." shows missing-icon icon.
    Install the throbber icon in the package
    - update debian/firefox.install.in
  * Refresh patches
    - update debian/patches/mozilla-kde.patch
    - update debian/patches/allow-lockPref-everywhere.patch
    - update debian/patches/fix-broken-langpack-install-manifests.patch
  * Switch to encrypted search for Google
    - update debian/searchplugins/en-GB/google.xml
    - update debian/searchplugins/en-US/google.xml
    - update debian/searchplugins/en-ZA/google.xml
    - update debian/searchplugins/ja/google-jp.xml
    - update debian/searchplugins/ku/google-ku.xml
 -- Chris Coulson <email address hidden> Mon, 18 Feb 2013 10:03:26 +0000

Changed in firefox (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 19.0+build1-0ubuntu0.10.04.1

---------------
firefox (19.0+build1-0ubuntu0.10.04.1) lucid-security; urgency=low

  * New upstream stable release (FIREFOX_19_0_BUILD1)
    - see LP: #1128883 for USN information
    - Fix LP: #1096286 - 404 error when using Chambers (UK) search.
      Temporarily remove the plugin

  * Fix LP: #1064423 - "Submitting your report..." shows missing-icon icon.
    Install the throbber icon in the package
    - update debian/firefox.install.in
  * Refresh patches
    - update debian/patches/mozilla-kde.patch
    - update debian/patches/allow-lockPref-everywhere.patch
    - update debian/patches/fix-broken-langpack-install-manifests.patch
  * Switch to encrypted search for Google
    - update debian/searchplugins/en-GB/google.xml
    - update debian/searchplugins/en-US/google.xml
    - update debian/searchplugins/en-ZA/google.xml
    - update debian/searchplugins/ja/google-jp.xml
    - update debian/searchplugins/ku/google-ku.xml
 -- Chris Coulson <email address hidden> Mon, 18 Feb 2013 10:08:56 +0000

Changed in firefox (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 19.0+build1-0ubuntu0.12.10.1

---------------
firefox (19.0+build1-0ubuntu0.12.10.1) quantal-security; urgency=low

  * New upstream stable release (FIREFOX_19_0_BUILD1)
    - see LP: #1128883 for USN information
    - Fix LP: #1096286 - 404 error when using Chambers (UK) search.
      Temporarily remove the plugin

  * Update globalmenu-extension to 3.7.1
    - Update for imagelib changes in Firefox 19 and 20
    - Update for nsCAutoString removal in Firefox 19
    - Don't #include mozilla/dom/Element.h anywhere, as that now pulls
      in a lot of internal headers since Firefox 19
  * Fix LP: #1064423 - "Submitting your report..." shows missing-icon icon.
    Install the throbber icon in the package
    - update debian/firefox.install.in
  * Refresh patches
    - update debian/patches/allow-lockPref-everywhere.patch
    - update debian/patches/ionmonkey-hardfp-support.patch
    - update debian/patches/fix-broken-langpack-install-manifests.patch
  * Switch to encrypted search for Google
    - update debian/searchplugins/en-GB/google.xml
    - update debian/searchplugins/en-US/google.xml
    - update debian/searchplugins/en-ZA/google.xml
    - update debian/searchplugins/ja/google-jp.xml
    - update debian/searchplugins/ku/google-ku.xml
 -- Chris Coulson <email address hidden> Fri, 15 Feb 2013 22:24:53 +0000

Changed in firefox (Ubuntu Quantal):
status: Fix Committed → Fix Released

Concerning cookie controller..

Your addon is almost what i'm looking for but i don't have the icons i want
&
there are so many functions that i don't need. so i wondered if you could
create a stripped down easy version without menus, only 2 buttons..
with strip entire domains & www active by default..

This is what i'd like:

2 gun targets (2 icons in the customize toolbar of firefox/no submenu
icons) but without the brown light cookie image:

A black gun target icon that does this:
Remove all cookies & dom storage for current host & cookies from third
party sites that the actual host created

&

A blue gun target icon:
Cookies allowed for all domains as 1st parties

That would be amazing if you could create this since you know this coding
field of firefox..

Who are you?

On Monday, December 29, 2014, x l <email address hidden> wrote:

> Concerning cookie controller..
>
> Your addon is almost what i'm looking for but i don't have the icons i want
> &
> there are so many functions that i don't need. so i wondered if you could
> create a stripped down easy version without menus, only 2 buttons..
> with strip entire domains & www active by default..
>
> This is what i'd like:
>
> 2 gun targets (2 icons in the customize toolbar of firefox/no submenu
> icons) but without the brown light cookie image:
>
> A black gun target icon that does this:
> Remove all cookies & dom storage for current host & cookies from third
> party sites that the actual host created
>
> &
>
> A blue gun target icon:
> Cookies allowed for all domains as 1st parties
>
> That would be amazing if you could create this since you know this coding
> field of firefox..
>
> --
> You received this bug notification because you are a member of Ubuntu-
> MozillaSquad, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/1096286
>
> Title:
> Firefox Search Engine is Broken
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/firefox/+bug/1096286/+subscriptions
>

--
Roman Alifanov - MCAD - MCTS - MCP - MCT
http://www.animaonline.com

Daniel Holbert (dholbert) wrote :

#36 is off-topic for this bug. I don't know where the correct place is to send requests for that addon, but it's certainly not here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.