REVIEW/SPONSOR: Please review/sponsor Bugmail extension for Thunderbird

Bug #306836 reported by Saša Bodiroža on 2008-12-10
4
Affects Status Importance Assigned to Milestone
Firefox Extensions
Wishlist
Unassigned
bugmail-extension (Ubuntu)
Wishlist
Unassigned

Bug Description

Hello,

Please review and sponsor Bugmail extension for Thunderbird. This extension adds bug status to the header pane. It currently supports Bugzilla, Trac, Flyspray and Launchpad. It is licensed under GPL v3.

Saša Bodiroža (jazzva) on 2008-12-10
Changed in firefox-extensions:
assignee: nobody → jazzva
importance: Undecided → Wishlist
status: New → In Progress
Saša Bodiroža (jazzva) on 2008-12-10
Changed in firefox-extensions:
assignee: jazzva → nobody
status: In Progress → Confirmed
status: Confirmed → Fix Committed

On Wed, Dec 10, 2008 at 12:37:41PM -0000, Saša Bodiroža wrote:
> ** Changed in: firefox-extensions
> Assignee: Saša Bodiroža (jazzva) => (unassigned)
> Status: In Progress => Confirmed
>
> ** Changed in: firefox-extensions
> Status: Confirmed => Fix Committed

Was the licensing ok?

 - Alexander

Alexander Sack wrote:
> Was the licensing ok?
>
> - Alexander
>

Yep, GPL. It was confirmed by mail. I'll ask him to provide a license
fail for the next upload, if that's ok.

On Mon, Dec 15, 2008 at 07:03:59PM -0000, Saša Bodiroža wrote:
> Alexander Sack wrote:
> > Was the licensing ok?
> >
> > - Alexander
> >
>
> Yep, GPL. It was confirmed by mail. I'll ask him to provide a license
> fail for the next upload, if that's ok.
>

Sure. i guess he will not have problems to add that to the .xpi top
level dir. At least he chose GPL, so he wont feel offended :).

 - Alexander

Andrea Veri (av) wrote :

Any news on this? do we have all needed license headers now? if yes, I gonna take care reviewing this package.

Changed in ubuntu:
importance: Undecided → Wishlist

Hello Andrea,

Just give me a day or two to update the branch. I have checked now,
and version 1.5, which is available on addons.mozilla.org, contains a
license file.

Andrea Veri (av) wrote :

marking this as incomplete and assigning the bug report to you while you fix the license issue. Feel free to set it back as confirmed (plus unassigning you from the bug again) when the branch has been updated.

Changed in ubuntu:
assignee: nobody → Saša Bodiroža (jazzva)
status: Confirmed → Incomplete
Andrea Veri (av) wrote :

any news on this?

Saša Bodiroža (jazzva) wrote :

Hello Andrea,

Sorry for the delay (been pretty busy in the past few months).

The new version (1.6) is detected in Thunderbird 2.0.0.22, but it's not really showing up in bug mails. Could you (or someone other) test (building with "bzr builddeb") the current revision in the linked branch before uploading, because I would like to be sure that it's not just my configuration that is causing the extension to not work, before reporting this upstream.

Thanks.

Changed in ubuntu:
status: Incomplete → In Progress

Saša Bodiroža wrote:
> The new version (1.6) is detected in Thunderbird 2.0.0.22, but it's not
> really showing up in bug mails.

I have found the bug, and will e-mail upstream developer. With version
1.5, I can see the box with bug data, but it's collapsed (so, that's
still not usable).

Andrea Veri (av) wrote :

ok, just let me know when you have a working package ready and I'll take a look at it.

Hello Andrea,

On Mon, Aug 3, 2009 at 10:39 AM, Andrea Veri wrote:
> ok, just let me know when you have a working package ready and I'll take
> a look at it.

It's ready, you can get it from the linked branch and run "bzr builddeb".

Andrea Veri (av) wrote :

you said me the current version doesnt work. Did upstream already fixed the issue you were talking about?

Saša Bodiroža (jazzva) wrote :

Hello Andrea,

On Tue, Aug 4, 2009 at 12:33 AM, Andrea Veri wrote:
> you said me the current version doesnt work. Did upstream already fixed
> the issue you were talking about?

Yes, I received response from him few hours ago that he fixed the
problem, and uploaded the new version to addons.mozilla.org.

Changed in ubuntu:
assignee: Saša Bodiroža (jazzva) → nobody
status: In Progress → Confirmed
Andrea Veri (av) wrote :

Perfect, gonna process this tomorrow.

Changed in ubuntu:
assignee: nobody → Andrea Veri (bluekuja)
Andrea Veri (av) wrote :

Package looks good, but I get three minor lintian warnings:

W: bugmail-extension source: debhelper-but-no-misc-depends bugmail-extension
W: bugmail-extension source: out-of-date-standards-version 3.8.0 (current is 3.8.2)
W: bugmail-extension: extra-license-file usr/share/bugmail-extension/LICENSE

Apart from those the package builds/installs and work fine in thunderbird.

Do you want me to upload anyway or you wanna fix those?

Andrea Veri (av) wrote :

you should also update maintainer field with this mail: Ubuntu Developers <email address hidden> not the old one as per https://wiki.ubuntu.com/DebianMaintainerField

Hello Andrea,

On Tue, Aug 4, 2009 at 1:23 PM, Andrea Veri wrote:
> you should also update maintainer field with this mail: Ubuntu
> Developers <email address hidden> not the old one as
> per https://wiki.ubuntu.com/DebianMaintainerField

Thanks, I didn't know about new DebianMaintainerField spec. I updated
that and bumped Standards-Version to 3.8.2. I can add misc:Depends,
but I don't think it's needed in this package. As for the
extra-license-file, I think it's not a big issue. If you want, I can
fix it, but I would need your help to tell me how to remove it from
the package.

New revisions are located in the linked branch. If you ask me, I would
say it's ready for the upload.

Thanks for your sponsorship.

Andrea Veri (av) wrote :

Uploaded. Thanks for your work :)

Changed in ubuntu:
assignee: Andrea Veri (bluekuja) → nobody
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Saša Bodiroža (jazzva) wrote :

Hello Andrea,

I just noticed that I have forgot to change target from UNRELEASED to karmic in debian/changelog. I pushed a new revision with just that change. Should I bump version to -0ubuntu2 instead?

Or will it be OK with UNRELEASED (e.g. archive administrators will fix that)?

Sorry for this.

Changed in firefox-extensions:
status: Fix Committed → In Progress
Andrea Veri (av) wrote :

I fixed that for you ;)

Andrea Veri (av) wrote :

just fix it on your branch, don't have to add a new changelog entry :)

Andrea Veri (av) wrote :

Package has been accepted through the NEW queue. Moving the bug status to fix released.

Changed in ubuntu:
status: Fix Committed → Fix Released
affects: ubuntu → bugmail-extension (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers