Please update ctxextensions to 4.1.2008062001

Bug #241671 reported by Saša Bodiroža on 2008-06-20
2
Affects Status Importance Assigned to Milestone
Firefox Extensions
Wishlist
Unassigned
ctxextensions (Ubuntu)
Wishlist
Unassigned

Bug Description

Please update ctxextensions to the new upstream release. The packaging is maintained in bzr branch attached to this report. It should be merged in ~ubuntu-dev/firefox-extensions/mozilla-ctxextensions.ubuntu branch.

Additionally, I have adapted packaging to the new directory layout of the extension and updated MOZ_XPI_EMID in debian/rules to be the same as the one in install.rdf. Some files are shipped as executables in XPI. Those permissions are now removed in debian/rules. Because the extension also works in Thunderbird, I added support for it in debian/{control,rules}. The last new change is the inclusion of Homepage field in debian/control.

Saša Bodiroža (jazzva) on 2008-06-20
Changed in ctxextensions:
assignee: nobody → jazzva
importance: Undecided → Wishlist
status: New → In Progress
Saša Bodiroža (jazzva) on 2008-06-25
description: updated
Changed in ctxextensions:
assignee: jazzva → nobody
status: In Progress → Confirmed

Sorry about this. We're not merging Mozilla extensions from Debian, because of different packaging. I'll update the branch and set this back to Confirmed soon.

Changed in ctxextensions:
assignee: nobody → jazzva
status: Confirmed → In Progress
StefanPotyra (sistpoty) wrote :

unsubscribing u-u-s, please resubscribe once you've got s.th. to sponsor, thanks.

Saša Bodiroža (jazzva) wrote :

Hello,

I updated the package for the new upstream release. I changed the description and the title of the bug report, since it's not a merge anymore.

description: updated
Changed in ctxextensions:
assignee: jazzva → nobody
status: In Progress → Confirmed
Saša Bodiroža (jazzva) on 2008-07-07
description: updated
Alexander Sack (asac) wrote :

committed to ~ubuntu-dev branch. pushing to intrepid

Changed in ctxextensions:
status: Confirmed → Fix Committed
Alexander Sack (asac) wrote :

fix released to bzr release branch.

Changed in firefox-extensions:
importance: Undecided → Wishlist
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ctxextensions - 4.1.2008062001-0ubuntu1

---------------
ctxextensions (4.1.2008062001-0ubuntu1) intrepid; urgency=low

  [ Sasa Bodiroza ]
  * New upstream release (LP: #241671)
  * In debian/rules:
    - Use med-xpi-pack for build.
    - Remove clean target.
    - Update MOZ_XPI_EMID to be the same as the one in install.rdf.
    - xpi ships some files as executables. Remove executable permissions in
      build target.
    - Add Thunderbird support
  * In debian/control:
    - Add Homepage field
    - Add thunderbird as optional dependency
  * Update copyright year in debian/copyright

 -- Sasa Bodiroza <email address hidden> Tue, 22 Jul 2008 22:36:40 +0200

Changed in ctxextensions:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers