Zotero (Firefox extension)

Bug #239575 reported by sybille on 2008-06-12
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Firefox Extensions
Undecided
Unassigned
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

Zotero: http://www.zotero.org/

"Zotero [zoh-TAIR-oh] is a free, easy-to-use Firefox extension to help you collect, manage, and cite your research sources. It lives right where you do your work — in the web browser itself."

It's a very useful extension for anyone who does academic or other scholarly research. In addition to scraping citation data directly into its database from the many supported online libraries and other sites, Zotero also allows for web snapshots, PDFs and other files to be associated with the database entries, tagging, full-text searching, export in different styles to a variety of formats. Backup and synching features are in testing.

If Zotero can be packaged for Ubuntu, it also would be nice to package the extension for OpenOffice.org, which enables references stored in Zotero's database to be inserted into ODT documents with formatting.

Dimitrios Symeonidis (azimout) wrote :

This is an advertisment. Marking as invalid.

sybille (sybillel) wrote :

I'm sorry, it wasn't meant as an advertisement. I really would like to see Zotero packaged for Ubuntu, and maybe to see if I can help out with that.

I opened this bug because I thought that was expected. I was following the instructions on the page for Firefox extensions in the Ubuntu wiki:
https://wiki.ubuntu.com/MozillaTeam/Firefox3Extensions

I made an entry for Zotero on the Firefox extensions wiki page in the "Suggested extensions missing details" section because that's what I was told to do on #ubuntu-mozillateam, which I visited to ask about the license of Zotero which is supposedly open but isn't listed in the wiki (it's the Educational Community License, version 1). And the wiki said to include a launchpad bug report, so I made this one. I just followed the examples I found for other Firefox extensions, like this one: https://bugs.launchpad.net/ubuntu/+bug/158835

I have no affiliation with Zotero, other than being a user of the extension. I don't think interest in having Zotero packaged for Ubuntu is invalid, but oh well.

Dimitrios Symeonidis (azimout) wrote :

Dear Sybille,

I have nothing against your favorite extension. The points you made are valid, and I am seeking advice from people more experienced than myself.

Anyway, thank you for your time and effort in making Ubuntu better.

sybille (sybillel) wrote :

I'm not sure that Zotero is my "favorite extension," whatever that means, but it is a useful if specialized tool for researchers and students. And, I believe that including this kind of software in Ubuntu will help with https://bugs.launchpad.net/ubuntu/+bug/1

Anyway, I've added a Zotero documentation page to the Ubuntu community wiki:
https://help.ubuntu.com/community/Zotero

Please reconsider the "Invalid" status. Thanks.

Dimitrios Symeonidis (azimout) wrote :

Dear Sybille, I have asked Brian Murry (of Canonical, and the man who changed the status of bug 158835 to 'confirmed') on the issue, but got no answer.

My assignment as 'Invalid' was in accordance with the guidelines in https://wiki.ubuntu.com/HelpingWithBugs.
Furthermore, no Firefox extensions WHATSOEVER are included in Ubuntu.

Finally, if you are not aware of its existence, there's brainstorm.ubuntu.com, a place where ideas about improving Ubuntu can be submitted and voted upon.

The Bugs section of Launchpad is for problems in hardware, in the sense that "the software claims to do certain things but then fails to".

sybille (sybillel) wrote :

Hmm, not to be argumentative, but it seems to me that there are a series of Firefox extensions included in Ubuntu. For example: https://launchpad.net/ubuntu/+source/adblock-plus

But maybe what you mean is that packages in the Universe repository are not considered to be "in Ubuntu."

Like I said before, I only opened this bug because I thought I was supposed to do so when adding Zotero here:
https://wiki.ubuntu.com/MozillaTeam/Firefox3Extensions

Actually, Zotero doesn't need any packaging to be used in Ubuntu. Users can get everything they need from the Zotero website. So, sorry to have wasted anyone's time if I have.

Dimitrios Symeonidis (azimout) wrote :

Hmm, in fact you're right, there's several extentions under World Wide Web (universe), I was not aware of that.
You could add this suggestion to the Brainstorm website.

You are very polite, and don't worry about wasting time, looking into this issue was actually quite educating.

Feel free to report any other Ubuntu bugs you might come along...

Brian Murray (brian-murray) wrote :

There is actually a wiki page documenting need firefox extensions and a project for creating packages of extensions people are interested in. Subsequently, I am setting the bug to Confirmed and Wishlist.

Brian Murray (brian-murray) wrote :

If you could update the wiki page, https://wiki.ubuntu.com/MozillaTeam/Firefox3Extensions, with the extension you are interested in that would be quite helpful. It should belong in either the Extensions that Need a Maintainer table or the Suggested Extensions Missing Details table. I was not quickly able to determine the license for Zotero so did not add it myself.

Brian Murray (brian-murray) wrote :

I justed noticed it is already on that wiki page but I think it should move the missing details bit to need a maintainer.

Brian Murray wrote:
> I justed noticed it is already on that wiki page but I think it should
> move the missing details bit to need a maintainer.
>
I will look at it to see if it needs more info before continuing to
needs a maintainer. What section is it under atm? i will look once im
done with email. in 2 of my boexs the toltal of email is 2848 emails not
including the rest of my accounts.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

sybille (sybillel) wrote :

Hi john, and thanks for taking a look at this.

Zotero is in the "Suggested extensions missing details" section of this wiki page:
https://wiki.ubuntu.com/MozillaTeam/Extensions/List?action=show&redirect=MozillaTeam%2FFirefox3Extensions

I put it in that section because there is a question about the license. Zotero uses the ECL license, version 1. See:
http://www.zotero.org/documentation/#small_print_stuff
http://www.opensource.org/licenses/ecl1.php
ECLv1 isn't listed as a good license on the wiki, but it is supposed to be OSS.

I haven't done anything at all about trying to make a package myself because I thought it would be better to wait until I heard whether the license would be OK for Ubuntu.

Thanks again.

John Vivirito (gnomefreak) wrote :

Marking as incomplete until work is complete on it, I moved to to Maintained or currently worked on extensions from Suggested extensions missing details a little while ago. Thanks for your help on getting the info. Is this something you plan on packaging or would you rather somone else did? If you want fee free to package it and if you run into problems or have questions please see #ubuntu-mozillateam on IRC or our mailing list at
https://lists.ubuntu.com/mailman/listinfo/ubuntu-mozillateam
That is where to subscribe or you can send email directly to it using <email address hidden> but not signing up will take it longer for your post to hit since one of us needs to allow the post after you send it. The mailing list is very low traffic that we use for meeting announcments and such including development questions and comments.

Changed in firefox-extensions:
status: New → Incomplete
John Vivirito (gnomefreak) wrote :

We had an OO.o extension packaged but last time i looked it was removed from repos but gutsy does have it not sure why it was removed.

sybille (sybillel) wrote :

The OOo extension is specifically for Zotero. Basically, it allows Zotero to be used as a Bibliography manager for OOo. You can see more about how it works here: https://help.ubuntu.com/community/Zotero#Integration%20with%20OpenOffice.org
(There's a screenshot, too :).)
The Zotero extension is an OXT file that is available of the Zotero site:
http://www.zotero.org/documentation/openoffice_integration

So, it's not at all the same as the Mozilla extension for OOo, which allows office files to be viewed in the browser:
http://packages.ubuntu.com/hardy-updates/mozilla-openoffice.org
I couldn't find mozilla-openoffice.org listed on launchpad, but it is in the repos. I'm using version 2.4.1-1ubuntu2 from hardy-updates, and there is a package for intrepid.

Actually, packaging the OOo extension is probably something to be taken up with the OOo team rather than the Mozilla team, so it's not really on-topic for this bug. In any case, the Firefox extension is the first thing to think about, since the Zotero OOo extension won't work without it.

I will see what I can do about trying to package Zotero, and I'll subscribe to the mailing list.

Alexander Sack (asac) wrote :

On Mon, Jul 14, 2008 at 02:23:25PM -0000, sybille wrote:
> Hi john, and thanks for taking a look at this.
>
> Zotero is in the "Suggested extensions missing details" section of this wiki page:
> https://wiki.ubuntu.com/MozillaTeam/Extensions/List?action=show&redirect=MozillaTeam%2FFirefox3Extensions
>
> I put it in that section because there is a question about the license. Zotero uses the ECL license, version 1. See:
> http://www.zotero.org/documentation/#small_print_stuff
> http://www.opensource.org/licenses/ecl1.php
> ECLv1 isn't listed as a good license on the wiki, but it is supposed to be OSS.
>
> I haven't done anything at all about trying to make a package myself
> because I thought it would be better to wait until I heard whether the
> license would be OK for Ubuntu.

I took a quick look and didnt find any clause that doesnt match the
free-softwar criterias. This is no guarantee, but most likely its ok
to ship this in ubuntu.

 - Alexander

John Vivirito (gnomefreak) wrote :

Alexander Sack wrote:
> On Mon, Jul 14, 2008 at 02:23:25PM -0000, sybille wrote:
>> Hi john, and thanks for taking a look at this.
>>
>> Zotero is in the "Suggested extensions missing details" section of this wiki page:
>> https://wiki.ubuntu.com/MozillaTeam/Extensions/List?action=show&redirect=MozillaTeam%2FFirefox3Extensions
>>
>> I put it in that section because there is a question about the license. Zotero uses the ECL license, version 1. See:
>> http://www.zotero.org/documentation/#small_print_stuff
>> http://www.opensource.org/licenses/ecl1.php
>> ECLv1 isn't listed as a good license on the wiki, but it is supposed to be OSS.
>>
>> I haven't done anything at all about trying to make a package myself
>> because I thought it would be better to wait until I heard whether the
>> license would be OK for Ubuntu.
>
> I took a quick look and didnt find any clause that doesnt match the
> free-softwar criterias. This is no guarantee, but most likely its ok
> to ship this in ubuntu.
>
> - Alexander
>
I had questions about this license a few weeks ago from another
extension and IIRC sasa had said its ok to use ECL. However i think this
should be accepted as a license but i would like peoples opinion but
honestly from what i read its all good for us to use. I read this after
talking with sasa.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

Alexander Sack (asac) wrote :

On Tue, Jul 15, 2008 at 09:52:19AM -0000, John Vivirito wrote:
> Alexander Sack wrote:
> > On Mon, Jul 14, 2008 at 02:23:25PM -0000, sybille wrote:
> >> Hi john, and thanks for taking a look at this.
> >>
> >> Zotero is in the "Suggested extensions missing details" section of this wiki page:
> >> https://wiki.ubuntu.com/MozillaTeam/Extensions/List?action=show&redirect=MozillaTeam%2FFirefox3Extensions
> >>
> >> I put it in that section because there is a question about the license. Zotero uses the ECL license, version 1. See:
> >> http://www.zotero.org/documentation/#small_print_stuff
> >> http://www.opensource.org/licenses/ecl1.php
> >> ECLv1 isn't listed as a good license on the wiki, but it is supposed to be OSS.
> >>
> >> I haven't done anything at all about trying to make a package myself
> >> because I thought it would be better to wait until I heard whether the
> >> license would be OK for Ubuntu.
> >
> > I took a quick look and didnt find any clause that doesnt match the
> > free-softwar criterias. This is no guarantee, but most likely its ok
> > to ship this in ubuntu.
> >
> > - Alexander
> >
> I had questions about this license a few weeks ago from another
> extension and IIRC sasa had said its ok to use ECL. However i think this
> should be accepted as a license but i would like peoples opinion but
> honestly from what i read its all good for us to use. I read this after
> talking with sasa.
>

I think its fine. we should upload and let archive admins have the
final say.

 - Alexander

Dimitrios Symeonidis (azimout) wrote :

I want to apologise to sybille for blocking this earlier... Sorry

John Vivirito (gnomefreak) wrote :

Alexander Sack wrote:
> On Tue, Jul 15, 2008 at 09:52:19AM -0000, John Vivirito wrote:
>> Alexander Sack wrote:
>>> On Mon, Jul 14, 2008 at 02:23:25PM -0000, sybille wrote:
>>>> Hi john, and thanks for taking a look at this.
>>>>
>>>> Zotero is in the "Suggested extensions missing details" section of this wiki page:
>>>> https://wiki.ubuntu.com/MozillaTeam/Extensions/List?action=show&redirect=MozillaTeam%2FFirefox3Extensions
>>>>
>>>> I put it in that section because there is a question about the license. Zotero uses the ECL license, version 1. See:
>>>> http://www.zotero.org/documentation/#small_print_stuff
>>>> http://www.opensource.org/licenses/ecl1.php
>>>> ECLv1 isn't listed as a good license on the wiki, but it is supposed to be OSS.
>>>>
>>>> I haven't done anything at all about trying to make a package myself
>>>> because I thought it would be better to wait until I heard whether the
>>>> license would be OK for Ubuntu.
>>> I took a quick look and didnt find any clause that doesnt match the
>>> free-softwar criterias. This is no guarantee, but most likely its ok
>>> to ship this in ubuntu.
>>>
>>> - Alexander
>>>
>> I had questions about this license a few weeks ago from another
>> extension and IIRC sasa had said its ok to use ECL. However i think this
>> should be accepted as a license but i would like peoples opinion but
>> honestly from what i read its all good for us to use. I read this after
>> talking with sasa.
>>
>
> I think its fine. we should upload and let archive admins have the
> final say.
>
> - Alexander
>
Alexander that sounds good to me. If they accept it let me know so i can
add the ECL license to the wiki page since its not there.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

sybille (sybillel) wrote :

@Dimitrios Symeonidis: Thanks for taking the time to post again, I appreciate and accept your apology.

@John Vivirito:
@Alexander Sack:
I've been thinking about this project, and before proceeding, I'd like to talk with you guys about how backports work for Firefox extensions that have been packaged for Ubuntu.

The thing is, Zotero is still in active development and gets updated fairly frequently. Not as frequently as some extensions (NoScript, for example), but still. The updates fix bugs, add new features, and are definitely worth using.

So, I'd like to find out more about whether the Ubuntu package can get updated as Zotero is updated, which I suppose would involve backports.

If the package cannot be updated, I can see that things could get complicated for supporting users. It would be a shame if the first support step for anyone using an Ubuntu package of Zotero is "uninstall the Ubuntu version and update from the Zotero site." In fact, Zotero already recommends using their site rather than addons.mozilla.org, precisely because there can be a delay before new releases are available there. See the last paragraph here:
http://www.zotero.org/documentation/installation

Maybe it would be better to wait until Zotero development stabilizes. I don't know how long that might take - right now, there's a 1.5 version in public beta-testing, which adds some great features like remote sync of the Zotero database. Here's the development roadmap, it looks like a lot of releases are planned through the coming autumn:
http://www.zotero.org/documentation/development_roadmap

I'll try to bring this up for discussion on IRC in the near future, unless there are other suggestions.

Alexander Sack (asac) wrote :

On Wed, Jul 16, 2008 at 09:57:34AM -0000, sybille wrote:
> @Dimitrios Symeonidis: Thanks for taking the time to post again, I
> appreciate and accept your apology.
>
> @John Vivirito:
> @Alexander Sack:
> I've been thinking about this project, and before proceeding, I'd like to talk with you guys about how backports work for Firefox extensions that have been packaged for Ubuntu.
>
> The thing is, Zotero is still in active development and gets updated
> fairly frequently. Not as frequently as some extensions (NoScript, for
> example), but still. The updates fix bugs, add new features, and are
> definitely worth using.
>
> So, I'd like to find out more about whether the Ubuntu package can get
> updated as Zotero is updated, which I suppose would involve backports.
>
> If the package cannot be updated, I can see that things could get complicated for supporting users. It would be a shame if the first support step for anyone using an Ubuntu package of Zotero is "uninstall the Ubuntu version and update from the Zotero site." In fact, Zotero already recommends using their site rather than addons.mozilla.org, precisely because there can be a delay before new releases are available there. See the last paragraph here:
> http://www.zotero.org/documentation/installation

The process we are planning to implement is specified on the wiki in:
https://wiki.ubuntu.com/MozillaTeam/Firefox3Extensions/LargeScaleMaintenance

Your concerns are well understood, which is why we want to get new
upstream releases automatically to backports once the were uploaded to
the current ubuntu development release and as soon as we got some
basic QA in that it doesnt really break a thing.

So basically our approach is to 1. upload to ubuntu development
release and let it bake for a bit. If no negative feedback arrives the
backport should be acked and uploaded.

>
> Maybe it would be better to wait until Zotero development stabilizes. I don't know how long that might take - right now, there's a 1.5 version in public beta-testing, which adds some great features like remote sync of the Zotero database. Here's the development roadmap, it looks like a lot of releases are planned through the coming autumn:
> http://www.zotero.org/documentation/development_roadmap
>
> I'll try to bring this up for discussion on IRC in the near future,
> unless there are other suggestions.
>

If you want to discuss details of the procedures and policies we use
to track upstream development dont hesitate to join
#ubuntu-mozillateam on freenode. We are still in the process of
learning and figuring out the tiny details that will make extensions a
pleasant experience in ubuntu, while providing you with new channels
to new users. So any input and ideas are appreciated.

Thanks!

 - Alexander

Saša Bodiroža (jazzva) wrote :

On Wed, Jul 16, 2008 at 11:57 AM, sybille wrote:
> So, I'd like to find out more about whether the Ubuntu package can get
> updated as Zotero is updated, which I suppose would involve backports.

We are working on a procedure to make it easier to maintain extensions
[1]. However, it's still not done, I suppose Alexander can tell you
when it will be done. It will help by auto-syncing new upstream
versions and notifying a maintainer that he/she should check if
auto-sync went well.

All upgrades go to the current development version (Intrepid, at the
moment), and I suppose they can be backported the usual way (upload to
current dev version, prepare a backport and request it on LP). If
Zotero isn't quite stable yet, maybe it would be better if we could
wait until it gets more stable.

[1] https://wiki.ubuntu.com/MozillaTeam/Extensions/LargeScaleMaintenance
Note: It's more a document describing development of the procedure,
than a tutorial.

--
Best regards,
Saša Bodiroža

sybille (sybillel) wrote :

Yes, in the end, I do think it would be best to wait on packaging Zotero for Ubuntu.

Perhaps it's worth noting that Zotero is not at all unstable from a user's point of view, or at least, it's not for me. I've been using it fairly extensively for over a year now and had no real problems (i.e., data loss, drastic malfunction).

However, Zotero is somewhat unstable from a packager's point of view, just because there are still a lot of releases at present, too many for backports. I think it would be best to wait and see what the development roadmap looks like after the 1.5 release, which is currently in public beta testing.

Alexander Sack (asac) wrote :

> Yes, in the end, I do think it would be best to wait on packaging Zotero
> for Ubuntu.
>
> Perhaps it's worth noting that Zotero is not at all unstable from a
> user's point of view, or at least, it's not for me. I've been using it
> fairly extensively for over a year now and had no real problems (i.e.,
> data loss, drastic malfunction).
>
> However, Zotero is somewhat unstable from a packager's point of view,
> just because there are still a lot of releases at present, too many for
> backports. I think it would be best to wait and see what the development
> roadmap looks like after the 1.5 release, which is currently in public
> beta testing.
>

Why too many for backports? if its usable then it should be fine.

 - Alexander

John Vivirito (gnomefreak) wrote :

Alexander Sack wrote:
> On Wed, Jul 16, 2008 at 09:57:34AM -0000, sybille wrote:
>
>> @Dimitrios Symeonidis: Thanks for taking the time to post again, I
>> appreciate and accept your apology.
>>
>> @John Vivirito:
>> @Alexander Sack:
>> I've been thinking about this project, and before proceeding, I'd like to talk with you guys about how backports work for Firefox extensions that have been packaged for Ubuntu.
>>
>> The thing is, Zotero is still in active development and gets updated
>> fairly frequently. Not as frequently as some extensions (NoScript, for
>> example), but still. The updates fix bugs, add new features, and are
>> definitely worth using.
>>
>> So, I'd like to find out more about whether the Ubuntu package can get
>> updated as Zotero is updated, which I suppose would involve backports.
>>
>> If the package cannot be updated, I can see that things could get complicated for supporting users. It would be a shame if the first support step for anyone using an Ubuntu package of Zotero is "uninstall the Ubuntu version and update from the Zotero site." In fact, Zotero already recommends using their site rather than addons.mozilla.org, precisely because there can be a delay before new releases are available there. See the last paragraph here:
>> http://www.zotero.org/documentation/installation
>>
>
> The process we are planning to implement is specified on the wiki in:
> https://wiki.ubuntu.com/MozillaTeam/Firefox3Extensions/LargeScaleMaintenance
>
> Your concerns are well understood, which is why we want to get new
> upstream releases automatically to backports once the were uploaded to
> the current ubuntu development release and as soon as we got some
> basic QA in that it doesnt really break a thing.
>
> So basically our approach is to 1. upload to ubuntu development
> release and let it bake for a bit. If no negative feedback arrives the
> backport should be acked and uploaded.
>
>
>> Maybe it would be better to wait until Zotero development stabilizes. I don't know how long that might take - right now, there's a 1.5 version in public beta-testing, which adds some great features like remote sync of the Zotero database. Here's the development roadmap, it looks like a lot of releases are planned through the coming autumn:
>> http://www.zotero.org/documentation/development_roadmap
>>
>> I'll try to bring this up for discussion on IRC in the near future,
>> unless there are other suggestions.
>>
>>
>
> If you want to discuss details of the procedures and policies we use
> to track upstream development dont hesitate to join
> #ubuntu-mozillateam on freenode. We are still in the process of
> learning and figuring out the tiny details that will make extensions a
> pleasant experience in ubuntu, while providing you with new channels
> to new users. So any input and ideas are appreciated.
>
> Thanks!
>
> - Alexander
>
>
Alexander please remind me this week to bring this up with you.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

John Vivirito (gnomefreak) wrote :

We should not update a backports extensions for every release. causes too many openings for bugs, maybe updating every month or 3 or whatever. A time should be set and do we want unstable extensions in LTS?

Saša: what do you feel about ECL license.

Changed in debian:
status: Unknown → New
geoffrey (gkgeko) wrote :

In an attempt to revive this thread, I thought I would mention that Zotero is now at version 2.0.2, and considered stable.

Zotero is quickly becoming an essential tool for academics, and as an academic myself I feel it is important that it gets included in the repos (I think it should even be in the Software Centre's 'Featured Applications', but that's another story). In fact, judging from the comments in the zotero forums, quite a few Ubuntu users are using it.

I think it is also important to have zotero in the repos because the new OOo extension (it is now a Firefox extension that automatically sets up the OOo extension) poses a problem for Ubuntu users which is difficult to solve by an inexperienced user, namely the icedtea java plugin needs to be removed and replaced with the sunjava plugin. Installing from synaptic or the software centre could do this automatically for the user.

sybille (sybillel) wrote :

The java problem is version-dependent. For example, I'm using the icedtea plugin with Zotero 2.02, Firefox 3.5.8 and OpenOffice.org 3.2 with no issues.

My understanding is that for Zotero's integration with OpenOffice.org to work with Firefox ≥ 3.6, IcedTea6 1.7 is required, specifically the new IcedTea NPRuntime-based plugin included with IcedTea6 1.7. Otherwise the Sun java plugin is required. Here's a relevant thread at the Zotero forums:
http://forums.zotero.org/discussion/11429/zotero-in-ubuntu-104-lucid-lynx/

I believe that the need for the NPRuntime-based plugin is not limited to Zotero's OOo extension but that it is needed for all java applets to run in Firefox ≥ 3.6. Since Lucid has Firefox 3.6.3, I'm thinking that it's likely that the IcedTea NPRuntime plugin will be available on realease of Lucid. In any case, there continue to be new builds of OpenJDK for Lucid: https://launchpad.net/ubuntu/+source/openjdk-6
As of this writing, the last release was just four days ago.

All of that is to say that I've been waiting for Lucid final before concluding that the plugin from Sun will be required for the Zotero/OOo integration extension. It seems possible that it may not be a requirement. I don't have any authoritative knowledge on any of this, it's just what I've gathered from reading. But it's one reason why I haven't yet updated the Ubuntu wiki page for Zotero 2.0 yet: https://help.ubuntu.com/community/Zotero

FWIW, Zotero is now GPLv3:
http://www.zotero.org/support/changelog#changes_in_2.0rc1_january_26_2010

Chris Coulson (chrisccoulson) wrote :

This is WONTFIX really, as we're currently going through a process of reducing the number of extensions in the archive. In the future, we want to keep the list of supported extensions in the archive to an absolute minimum.

See the spec here: https://wiki.ubuntu.com/DesktopTeam/Specs/Lucid/FirefoxNewSupportModel/

Changed in ubuntu:
status: Confirmed → Won't Fix
sybille (sybillel) wrote :

That's fine by me, the original reporter. After the initial responses to this bug, I decided I didn't really care about the matter.

I only added information today for people who might find this bug when searching for information about using Zotero with Lucid.

Close the bug if it will improve statistics.

Chris Coulson (chrisccoulson) wrote :

It's nothing to do with "improving statistics". Shipping lots of random extensions in our archive is not compatible with the new Firefox support model, and will be a significant maintenance burden in the future

sybille (sybillel) wrote :

So then the bug can be left as is. I was just thinking that maybe something about it could have been useful in some way.

Jezza (balingupjer) wrote :

If zotero was to be included in repo's, that would be great!

Zotero has many users, and geting it from the software center would be nice & professional!
Perhaps Zotero standalone is viable for inclusion into ubuntu repositories?

see https://bugs.launchpad.net/ubuntu/+bug/782079

It has already been requested on debian - http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=504058

What is the way forward with this?

Micah Gersten (micahg) wrote :

No way forward in Ubuntu to get it in the repos, the solution is to use addons.mozilla.org to get it.

papukaija (papukaija) wrote :

The above comment applies to the FF plugin, not the standalone desktop client.

Changed in debian:
status: New → Fix Committed
Changed in debian:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.