Extension description mentions Iceweasel/Icedove/Iceape

Bug #184084 reported by Maia Everett on 2008-01-18
14
Affects Status Importance Assigned to Milestone
Firefox Extensions
Medium
Unassigned
bidiui (Ubuntu)
Undecided
Unassigned
biofox (Ubuntu)
Low
Siegfried Gevatter
bookmarksftp (Ubuntu)
Undecided
Unassigned
checky (Ubuntu)
Undecided
Unassigned
ctxextensions (Ubuntu)
Undecided
Unassigned
diggler (Ubuntu)
Undecided
Unassigned
mozilla-firefox-adblock (Ubuntu)
Low
Siegfried Gevatter
mozilla-noscript (Ubuntu)
Undecided
Unassigned
openthesaurus (Ubuntu)
Wishlist
Daniel T Chen
tabextensions (Ubuntu)
Low
Siegfried Gevatter
torbutton (Ubuntu)
Undecided
Unassigned
venkman (Ubuntu)
Low
Siegfried Gevatter

Bug Description

Binary package hint: mozilla-noscript

I'm filing this bug in all extension packages containing the names "Iceweasel/Icedove/Iceape" in the description. This will be confusing to users, since Ubuntu calls them Firefox/Thunderbird/SeaMonkey.

Maia Everett (linneris) wrote :

Looked at wrong torbutton version, it's fixed now there.

Changed in torbutton:
status: New → Invalid
Changed in tabextensions:
assignee: nobody → rainct
importance: Undecided → Low
status: New → In Progress
Changed in mozilla-firefox-adblock:
assignee: nobody → rainct
importance: Undecided → Low
status: New → In Progress
Maia Everett (linneris) wrote :

These debdiffs only partially fix the problem. Ubuntu calls Iceape SeaMonkey. :)

description: updated

I know, but Iceape is also in it's repositories. I asked in
#ubuntu-mozillateam about this and they told me to wait for answers to
the email that was sent recently to the MOTU mailing list about
"Mozilla packaging standards".

Siegfried Gevatter (rainct) wrote :

(After speaking with Matvey on IRC again I realied that Iceape should indeed be SeaMonkey, as its only a transitional package; thanks for the notice, Matvey! I'll update the debdiff's soon and provide more for the other packages that need such changes.)

Siegfried Gevatter (rainct) wrote :
Changed in mozilla-firefox-adblock:
status: In Progress → Confirmed
Changed in tabextensions:
status: In Progress → Confirmed
Siegfried Gevatter (rainct) wrote :
Changed in biofox:
assignee: nobody → rainct
importance: Undecided → Low
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mozilla-noscript - 1.3.2-0ubuntu1

---------------
mozilla-noscript (1.3.2-0ubuntu1) hardy; urgency=low

  * New upstream release, based on the latest Debian release. (LP: #178445)
  * Updated package description to mention Firefox/SeaMonkey. (LP: #184084)
  * Updated debian/patches/50_whitelist.dpatch because it no longer applied.

 -- Matvey Kozhev <email address hidden> Thu, 14 Feb 2008 12:56:01 +0600

Changed in mozilla-noscript:
status: New → Fix Released
Changed in mozilla-firefox-adblock:
status: Confirmed → In Progress
Siegfried Gevatter (rainct) wrote :

Setting the mozilla-firefox-adblock task to "Won't Fix", as it will be replaced with Adblock Plus.

Changed in mozilla-firefox-adblock:
status: In Progress → Won't Fix
David Futcher (bobbo) on 2008-03-29
Changed in diggler:
assignee: nobody → bobbo
status: New → In Progress
David Futcher (bobbo) wrote :
Changed in diggler:
assignee: bobbo → nobody
status: In Progress → Confirmed
David Futcher (bobbo) wrote :

Updated debdiff, replaces mozilla-browser with seamonkey-browser

David Futcher (bobbo) wrote :

Sorry uploaded wrong debdiff.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package diggler - 0.9-14ubuntu2

---------------
diggler (0.9-14ubuntu2) hardy; urgency=low

  * Changed package description to mention Firefox/Seamonkey (LP: #184084)
  * Replace mozilla-browser in Depends with seamonkey-browser
  * Bump Debian standards version to 3.7.3
  * debian/control: Add Homepage field

 -- David Futcher <email address hidden> Sat, 29 Mar 2008 11:43:55 +0000

Changed in diggler:
status: Confirmed → Fix Released
Changed in diggler:
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package biofox - 1.1.4-3ubuntu1

---------------
biofox (1.1.4-3ubuntu1) hardy; urgency=low

  * debian/control:
     - Add firefox and seamonkey-browser as alternative build dependencies.
     - Change description to mention Firefox and Seamonkey instead of
       Iceweasel and Iceape (LP: #184084).
     - Modify Maintainer value to match the DebianMaintainerField
       specification.

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Sat, 29 Mar 2008 13:51:14 +0100

Changed in biofox:
status: Confirmed → Fix Released
Siegfried Gevatter (rainct) wrote :

Package tabextensions will be removed from Hardy; see bug #184121.

Changed in venkman:
assignee: nobody → rainct
importance: Undecided → Low
status: New → Fix Committed
Changed in tabextensions:
status: Confirmed → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package venkman - 0.9.87.2-2ubuntu2

---------------
venkman (0.9.87.2-2ubuntu2) hardy; urgency=low

  * debian/control:
     - Change alternative build dependency "mozilla-browser" and "mozilla-
       thunderbird" to "seamonkey-browser" and "thunderbird" (as the first
       ones are now transitional packages in Ubuntu).
     - Change the description so that it mentions the names of Mozilla's
       products in Ubuntu instead of Debian's names (LP: #184084).

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Sat, 29 Mar 2008 14:42:15 +0100

Changed in venkman:
status: Fix Committed → Fix Released
David Futcher (bobbo) on 2008-03-29
Changed in checky:
assignee: nobody → bobbo
status: New → In Progress
David Futcher (bobbo) wrote :
Changed in checky:
status: In Progress → Confirmed
Siegfried Gevatter (rainct) wrote :

Subscribing motu-release for them to grant (or not) an exception for checky.

StefanPotyra (sistpoty) wrote :

handing FFe over to Alexander/mozilla team. Unsubscribing motu-release again.

John Vivirito (gnomefreak) wrote :

Iceape is only in feisty I did that because i was using Debians and merging the updates with ours. I did that for half the cycle of fiesty so Mozilla team (we) decided to use the Mozilla branding name for Hardy. <just a comment from earlier comments about iceape/seamonkey>

Saša Bodiroža (jazzva) on 2008-04-21
Changed in ctxextensions:
assignee: nobody → jazzva
status: New → In Progress
Changed in bookmarksftp:
assignee: nobody → jazzva
status: New → In Progress
Changed in bidiui:
assignee: nobody → jazzva
status: New → In Progress
Alexander Sack (asac) wrote :

we should fix what is left in intrepid.

Changed in firefox-extensions:
importance: Undecided → Medium
status: New → Confirmed
Saša Bodiroža (jazzva) wrote :

Fix for bidiui.

Changed in bidiui:
status: In Progress → Fix Committed
status: Fix Committed → Confirmed
Saša Bodiroža (jazzva) wrote :

Fix for bookmarksftp.

Changed in bookmarksftp:
assignee: jazzva → nobody
status: In Progress → Confirmed
Changed in bidiui:
assignee: jazzva → nobody
Saša Bodiroža (jazzva) wrote :

Fix for ctxextensions.

Changed in ctxextensions:
assignee: jazzva → nobody
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bidiui - 0.7.3-3ubuntu3

---------------
bidiui (0.7.3-3ubuntu3) intrepid; urgency=low

  * Modify "Icedove" to "Thunderbird" in debian/control (LP: #184084)

 -- Sasa Bodiroza <email address hidden> Wed, 14 May 2008 01:42:42 +0200

Changed in bidiui:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bookmarksftp - 1.0.2-6ubuntu2

---------------
bookmarksftp (1.0.2-6ubuntu2) intrepid; urgency=low

  * In debian/control (LP: #184084)
    - Remove iceweasel and mozilla-firefox dependency
    - Modify "Iceweasel" to "Firefox"

 -- Sasa Bodiroza <email address hidden> Tue, 14 May 2008 01:48:30 +0200

Changed in bookmarksftp:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ctxextensions - 4.1.2007090601-0ubuntu2

---------------
ctxextensions (4.1.2007090601-0ubuntu2) intrepid; urgency=low

  * Modify "Iceweasel" to "Firefox" in debian/control (LP: #184084)

 -- Sasa Bodiroza <email address hidden> Tue, 14 May 2008 01:54:50 +0200

Changed in ctxextensions:
status: Confirmed → Fix Released
Maia Everett (linneris) wrote :

David, could you please reupload the checky debdiff with intrepid as the target distribution?

Changed in checky:
status: Confirmed → Incomplete
David Futcher (bobbo) wrote :

Updated version of the checky patch, now for intrepid distro.

Changed in checky:
status: Incomplete → Confirmed
Maia Everett (linneris) wrote :

Unfortunately, as counterintuitive as it sounds, this has to be -7ubuntu2 because -7ubuntu1 was in Feisty before it was removed. Could you please reupload with just the version number changed?

David Futcher (bobbo) wrote :

Fixed for the version number.

Maia Everett (linneris) on 2008-05-17
Changed in checky:
assignee: bobbo → nobody
status: Confirmed → Fix Released

On Sat, May 17, 2008 at 10:47:09AM -0000, David Futcher wrote:
> Updated version of the checky patch, now for intrepid distro.
>
> ** Attachment added: "checky_2.5-7ubuntu1.debdiff"
> http://launchpadlibrarian.net/14571286/checky.debdiff
>
> ** Changed in: checky (Ubuntu)
> Status: Incomplete => Confirmed
>

Thanks for the patch.

Do we have a bzr branch for checky? If so, integrate that in bzr
please.

 status incomplete

Thanks,

 - Alexander

Changed in firefox-extensions:
status: Confirmed → Incomplete
jan (jan-ubuntu-h-i-s) wrote :

Note that the fix does not work. See separate bug report:
https://bugs.launchpad.net/ubuntu/+source/mozilla-noscript/+bug/260955

Changed in mozilla-noscript:
status: Fix Released → New
John Vivirito (gnomefreak) wrote :

jan wrote:
> Note that the fix does not work. See separate bug report:
> https://bugs.launchpad.net/ubuntu/+source/mozilla-noscript/+bug/260955
>
> ** Changed in: mozilla-noscript (Ubuntu)
> Status: Fix Released => New
>
>
Changing to incomplete as this is not a new bug. Please give more detail
as to what doesn't work in new release that was supposed to be fixed and
are you sure the fix was for your bug or a bug that was similar to the
posted bug.

John Vivirito (gnomefreak) wrote :

jan wrote:
> Note that the fix does not work. See separate bug report:
> https://bugs.launchpad.net/ubuntu/+source/mozilla-noscript/+bug/260955
>
> ** Changed in: mozilla-noscript (Ubuntu)
> Status: Fix Released => New
>
>
Also if your bug is say bug #260955 and bug 184064 was fixed assuming
they are not marked as duplicates that makes me think one persons was
fixed but other people with similar issues were not same as reported
issues

Siegfried Gevatter (rainct) wrote :

I'm changing the status back to "Fix Released". This bug is about changing the description of some packages; bug #260955 is about those not working.

Changed in mozilla-noscript:
status: New → Fix Released
Daniel T Chen (crimsun) wrote :
Changed in openthesaurus:
assignee: nobody → crimsun
importance: Undecided → Wishlist
status: New → In Progress

needs update for openthesaurus

Changed in openthesaurus (Ubuntu):
status: In Progress → Incomplete
To post a comment you must log in.