ATI/AMD drivers are not working

Bug #1376988 reported by Vitaly Korolev on 2014-10-03
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
fglrx
New
Undecided
Unassigned
fglrx-installer (Ubuntu)
Critical
job
Nominated for Utopic by Alberto Salvia Novella

Bug Description

After installation Ubuntu boots with blank screen and blinking cursor. I reported the bug after uninstalling the drivers.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: fglrx (not installed)
ProcVersionSignature: Ubuntu 3.16.0-20.27-generic 3.16.3
Uname: Linux 3.16.0-20-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Oct 2 19:27:04 2014
DistUpgraded: Fresh install
DistroCodename: utopic
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:198f]
 Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8730M] [1002:6601] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:1990]
InstallationDate: Installed on 2014-09-29 (3 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140923)
MachineType: Hewlett-Packard HP EliteBook 840 G1
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-20-generic.efi.signed root=UUID=c8fab4c2-0ba3-4f38-9432-790323999938 ro quiet splash vt.handoff=7
SourcePackage: fglrx-installer
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/09/2013
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: L71 Ver. 01.04
dmi.board.name: 198F
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 15.50
dmi.chassis.asset.tag: CNU347DHK4
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvrL71Ver.01.04:bd10/09/2013:svnHewlett-Packard:pnHPEliteBook840G1:pvrA3009DD10303:rvnHewlett-Packard:rn198F:rvrKBCVersion15.50:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP EliteBook 840 G1
dmi.product.version: A3009DD10303
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.12+14.10.20140918-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.56-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.3.0-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.3.0-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.16.0-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
xserver.bootTime: Thu Oct 2 19:26:35 2014
xserver.configfile: default
xserver.errors: RADEON(G0): [XvMC] Failed to initialize extension.
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 4669
 vendor AUO
xserver.version: 2:1.16.0-1ubuntu1

Vitaly Korolev (vitaly-korolev) wrote :
description: updated
David Chen (david.chen) wrote :

Seems you are having the same problem as I meet in Ubuntu 14.10 beta. I tried the latest driver from AMD website, latest in Ubuntu repo, none of them works. Drivers can be installed just fine, xorg.conf generated, but system can't boot. I can boot with radeon driver, or with fglrx-core installed. System boots fine with 14.04.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Beavis (gordian-dziwis) wrote :

It affects Lubuntu too.

Vitaly Korolev (vitaly-korolev) wrote :

Seems to be working in 14.10.
At least the drivers install (both fglrx and fglrx-update) and I can login. Overall open source drivers seem to work a bit better except for 3D stuff.

Ben Kietzman (ben-kietzman) wrote :

I ended up having /etc/api in some kind of weird state. Ended up doing the following as root:

NOTE: You may want to backup /etc/ati somewhere before doing the remove just in case you need to restore it for some reason.

1) rm -r /etc/ati
2) ln -s /usr/lib/fglrx/etc/ati /etc/ati
3) amdconfig --initial
4) reboot

That fixed the issue for me.

Changed in fglrx-installer (Ubuntu):
importance: Undecided → Critical

Please:
1. Report to <http://ati.cchtml.com/>.
2. Paste the new report URL here.
3. Set this bug status back to "confirmed".

Thank you.

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Incomplete
tags: added: asked-to-upstream
job (jeppekdahl) on 2015-04-07
Changed in fglrx-installer (Ubuntu):
assignee: nobody → job (jeppekdahl)
status: Incomplete → Fix Committed
Changed in fglrx-installer (Ubuntu):
status: Fix Committed → In Progress
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers