[radeon] Rendering of combo boxes and tooltips is broken

Bug #1841718 reported by Jean-Baptiste Lallement on 2019-08-28
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
Unknown
xserver-xorg-video-amdgpu (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ati (Fedora)
Fix Released
Undecided
xserver-xorg-video-ati (Ubuntu)
High
Timo Aaltonen
Eoan
High
Timo Aaltonen

Bug Description

Combo boxes are broken (cf screenshot) Tested in gnome-control-center and gtk3-demo.

Tooltips are also garbage.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: gnome-shell 3.33.91-1ubuntu1
ProcVersionSignature: Ubuntu 5.2.0-13.14-generic 5.2.8
Uname: Linux 5.2.0-13-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Aug 28 07:08:33 2019
DisplayManager: gdm3
InstallationDate: Installed on 2014-07-15 (1869 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140520)
RelatedPackageVersions: mutter-common 3.33.91-1ubuntu1
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to eoan on 2018-03-24 (521 days ago)

Created attachment 1586097
Xorg log file

Description of problem:

After update of xorg-x11-server-common and xorg-x11-server-Xorg packages to version 1.20.5-3.fc30, the tooltips got corrupted in KDE.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg (1.20.5-3.fc30)
xorg-x11-server-common (1.20.5-3.fc30)

How reproducible:

Always.

Steps to Reproduce:
1. Hoover the mouse pointer over the tool.
2.
3.

Actual results:
Corrupted tooltip.

Expected results:

Additional info:

$ uname -a
Linux localhost.localdomain 5.1.15-300.fc30.x86_64 #1 SMP Tue Jun 25 14:07:22 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: AMD CYPRESS (DRM 2.50.0 / 5.1.15-300.fc30.x86_64, LLVM 8.0.0) (0x6898)
    Version: 19.0.6
    Accelerated: yes
    Video memory: 1024MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.3
    Max compat profile version: 3.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1

I have rolled back the above packages to 1.20.4-3.fc30, where everything works OK.

Created attachment 1586435
Screenshot of the corrupted tooltip

Corruption happens to me on Gnome on Fedora 30 after the update from:

xorg-x11-server-Xorg-1.20.4-3.fc30
xorg-x11-server-common-1.20.4-3.fc30.x86_64

to:

xorg-x11-server-Xorg-1.20.5-3.fc30.x86_64
xorg-x11-server-common-1.20.5-3.fc30.x86_64

I get corrupted icons in Gnome's top panel (specifically the Quake and Dropbox icons (I use the topicons-plus Gnome extension)).
I also get corrupted tooltips in Firefox, e.g., hovering my mouse over my account circle in GMail produces corruption similar to the screenshot shown on this bug.
As suggested by OP, downgrading xorg made the problem go away:

$ glxinfo -B
name of display: :0
display: :0 screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: AMD TURKS (DRM 2.50.0 / 5.1.15-300.fc30.x86_64, LLVM 8.0.0) (0x6740)
    Version: 19.0.8
    Accelerated: yes
    Video memory: 1024MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
...

A comment on a different bug describes a similar problem, and he has an AMD card as well:
https://bugzilla.redhat.com/show_bug.cgi?id=1726419#c1

Can you please try if either of these two scratch (test) builds fix the issue:

xorg-x11-server-1.20.5-3.1test.fc30
https://koji.fedoraproject.org/koji/taskinfo?taskID=36015101

or:

xorg-x11-server-1.20.5-3.2test.fc30
https://koji.fedoraproject.org/koji/taskinfo?taskID=36027647

And report if either fix the corruption issue?

(In reply to Olivier Fourdan from comment #3)
> Can you please try if either of these two scratch (test) builds fix the

I will be away from the keyboard today, but will report tomorrow (friday) afternoon.

(In reply to Olivier Fourdan from comment #3)
> Can you please try if either of these two scratch (test) builds fix the
> issue:
>
> xorg-x11-server-1.20.5-3.1test.fc30
> https://koji.fedoraproject.org/koji/taskinfo?taskID=36015101
>
> or:
>
> xorg-x11-server-1.20.5-3.2test.fc30
> https://koji.fedoraproject.org/koji/taskinfo?taskID=36027647
>
> And report if either fix the corruption issue?

I have the same tooltip corruption issues under cinnamon.

xorg-x11-server-1.20.5-3.1test.fc30 DOES fix the issue.

xorg-x11-server-1.20.5-3.2test.fc30 DOES *NOT* fix the issue. The corruption is the same as under xorg-x11-server-1.20.5-3.fc30.x86_64.

Created attachment 1587437
Tooltip corruption

Tooltip corruption under xorg-x11-server-1.20.5-3.2test.fc30 & xorg-x11-server-1.20.5-3.fc30.x86_64
Desktop is cinnamon.

(In reply to Uros Bizjak from comment #4)
> (In reply to Olivier Fourdan from comment #3)
> > Can you please try if either of these two scratch (test) builds fix the
>
> I will be away from the keyboard today, but will report tomorrow (friday)
> afternoon.

I can confirm that

xorg-x11-server-1.20.5-3.1test.fc30 fixes the issue for me.

xorg-x11-server-1.20.5-3.2test.fc30 DOES NOT fix the issue.

So this is the fix for bug 1645553 which introduced that regression.

I filed https://gitlab.freedesktop.org/xorg/xserver/issues/842 upstream for that regression, and interestingly Michel points out to a commit in xf86-vido-ati which would fix it, meaning that we may not have to revert.

I shall run a scratch build with the fix for xf86-vido-ati to test.

Thank you both for testing, this is very helpful!

With either xorg-x11-server-1.20.5-3.fc30 or xorg-x11-server-1.20.5-3.2test.fc30 (i.e. one that does *not* fix the issue in the Xserver), can you please try with this test build for xorg-x11-drv-ati-19.0.1-1.1test.fc30:

https://koji.fedoraproject.org/koji/taskinfo?taskID=36052571

Hi Olivier - thanks for looking into this.

I started with xorg-x11-server-1.20.5-3.fc30, which I confirmed as before showed the bug.

I then applied your latest fix, xorg-x11-drv-ati-19.0.1-1.1test.fc30.x86_64, and I can confirm that this does indeed solve the issue.

This worked for both machines showing the problem (although with slight different symptoms), one AMD RV730 and one AMD CEDAR.

(In reply to Jonathan S from comment #11)
> Hi Olivier - thanks for looking into this.
>
> I started with xorg-x11-server-1.20.5-3.fc30, which I confirmed as before
> showed the bug.
>
> I then applied your latest fix, xorg-x11-drv-ati-19.0.1-1.1test.fc30.x86_64,
> and I can confirm that this does indeed solve the issue.
>
> This worked for both machines showing the problem (although with slight
> different symptoms), one AMD RV730 and one AMD CEDAR.

It means I won't have to revert the fix for bug 1645553, this is great news, many thanks for taking the time to try those packages!

Moving to xorg-x11-drv-ati to fix it there

I can also confirm that xorg-x11-drv-ati-19.0.1-1.1test.fc30.x86_64 fixes the problem for me. I have:

Installed Packages
xorg-x11-drv-ati.x86_64 19.0.1-1.1test.fc30 @@commandline
xorg-x11-server-Xorg.x86_64 1.20.5-3.fc30 @updates
xorg-x11-server-common.x86_64 1.20.5-3.fc30 @updates

and everything looks OK.

Same here. My laptop is working good with:

xorg-x11-drv-ati.x86_64 19.0.1-1.1test.fc30
xorg-x11-server-Xorg.x86_64 1.20.5-3.fc30
xorg-x11-server-common.x86_64 1.20.5-3.fc30

Thanks!

Well in my case there were no just tooltips corrupted. Also quiet a few text menu entries unreadable in various programs. Plasma's apps/windows bar totally messed up on one system.
But I can, like the others, confirm: Fixed with xorg-x11-drv-ati-19.0.1-1.1test.fc30.x86_64.
Thanks, Olivier.

*** Bug 1727906 has been marked as a duplicate of this bug. ***

FEDORA-2019-d91c61517e has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d91c61517e

xorg-x11-drv-ati-19.0.1-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d91c61517e

xorg-x11-drv-ati-19.0.1-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Jean-Baptiste Lallement (jibel) wrote :
Daniel van Vugt (vanvugt) wrote :

This might be specific to AMD. What kernel driver does 'lspci -k' show for the GPU? Also, could you attach a Xorg log?

affects: gnome-shell (Ubuntu) → mutter (Ubuntu)
Jean-Baptiste Lallement (jibel) wrote :

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Juniper XT [Radeon HD 5770]
        Subsystem: PC Partner Limited / Sapphire Technology Juniper XT [Radeon HD 5770]
        Kernel driver in use: radeon
        Kernel modules: radeon

IIRC it happened in a previous version months ago.

description: updated
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :

This is similar to bug 1822075

summary: - Rendering of combo boxes is broken
+ [radeon] Rendering of combo boxes is broken
tags: added: radeon
summary: - [radeon] Rendering of combo boxes is broken
+ [radeon] Rendering of combo boxes is broken (skewed - wrong stride)
summary: - [radeon] Rendering of combo boxes is broken (skewed - wrong stride)
+ [radeon] Rendering of combo boxes is broken

Actually, yes this looks a lot like 1822075

summary: - [radeon] Rendering of combo boxes is broken
+ [radeon] Rendering of combo boxes and tooltips is broken
Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → Triaged
Changed in xserver-xorg-video-ati (Ubuntu Eoan):
importance: Undecided → Medium
tags: removed: rls-ee-incoming
Changed in mutter (Ubuntu Eoan):
status: New → Invalid
Changed in gtk+3.0 (Ubuntu Eoan):
status: New → Invalid
Timo Aaltonen (tjaalton) on 2019-09-03
affects: xserver-xorg-video-ati (Ubuntu Eoan) → mesa (Ubuntu Eoan)
Daniel van Vugt (vanvugt) wrote :

Also reported upstream: https://gitlab.gnome.org/GNOME/mutter/issues/767

Though that's also on eoan.

Changed in mutter:
status: Unknown → New
no longer affects: gtk+3.0 (Ubuntu Eoan)
no longer affects: gtk+3.0 (Ubuntu)
Changed in xserver-xorg-video-ati (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
Timo Aaltonen (tjaalton) on 2019-10-01
Changed in mesa (Ubuntu Eoan):
assignee: Timo Aaltonen (tjaalton) → nobody
status: Triaged → Invalid
Changed in xserver-xorg-video-ati (Ubuntu Eoan):
assignee: nobody → Timo Aaltonen (tjaalton)
Changed in xserver-xorg-video-ati (Ubuntu Eoan):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
no longer affects: mesa (Ubuntu)
no longer affects: mesa (Ubuntu Eoan)
Changed in xserver-xorg-driver-ati:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-amdgpu - 19.0.1-1ubuntu1

---------------
xserver-xorg-video-amdgpu (19.0.1-1ubuntu1) eoan; urgency=medium

  * dri3-always-flush-glamor.diff: Fix broken tooltips. (LP: #1841718)

 -- Timo Aaltonen <email address hidden> Thu, 03 Oct 2019 11:56:41 +0300

Changed in xserver-xorg-video-amdgpu (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-ati - 1:19.0.1-1ubuntu1

---------------
xserver-xorg-video-ati (1:19.0.1-1ubuntu1) eoan; urgency=medium

  * dri3-always-flush-glamor.diff: Fix broken tooltips. (LP: #1841718)

 -- Timo Aaltonen <email address hidden> Thu, 03 Oct 2019 11:47:01 +0300

Changed in xserver-xorg-video-ati (Ubuntu Eoan):
status: Confirmed → Fix Released
no longer affects: mutter (Ubuntu)
no longer affects: mutter (Ubuntu Eoan)
no longer affects: mutter
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.