two mouse cursors visible at the same time on rotated screen

Bug #1724977 reported by Scott Palmer on 2017-10-19
108
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Medium
mutter (Fedora)
Confirmed
Undecided
mutter (Ubuntu)
Medium
Unassigned

Bug Description

When my 2nd Asus (Ancor) display is in portrait mode and is set to be to the left of my centered landscape display in extended mode, moving the mouse to roughly the left 20% of my landscape display will show a mouse cursor on my landcape display AND portrait display at the same time. Oddly moving a window into this area only shows on the landscape display.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: xorg 1:7.7+19ubuntu3
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Thu Oct 19 13:43:30 2017
DistUpgraded: Fresh install
DistroCodename: artful
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo 3rd Gen Core processor Graphics Controller [17aa:2203]
InstallationDate: Installed on 2017-10-19 (0 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
MachineType: LENOVO 343522U
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-16-generic.efi.signed root=UUID=df6662ff-9496-4ff5-8165-82efdbf0b335 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/28/2014
dmi.bios.vendor: LENOVO
dmi.bios.version: GCET99WW (2.59 )
dmi.board.asset.tag: Not Available
dmi.board.name: 343522U
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrGCET99WW(2.59):bd05/28/2014:svnLENOVO:pn343522U:pvrThinkPadX230Tablet:rvnLENOVO:rn343522U:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.family: ThinkPad X230 Tablet
dmi.product.name: 343522U
dmi.product.version: ThinkPad X230 Tablet
dmi.sys.vendor: LENOVO
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.83-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.2-0ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.5-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20170309-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

Scott Palmer (skewty) wrote :
Scott Palmer (skewty) wrote :

I have attached a copy of a monitor.xml file I can use that will yield this behavior.

Scott Palmer (skewty) wrote :

I have attached a photo of my screen showing this behavior.

Notice how the icon is shown with correct orientation but the mouse cursor has landscape orientation.

Scott Palmer (skewty) wrote :

Oops, I attached the wrong picture. This one is correct.

Scott Palmer (skewty) wrote :

It could be related to this bug:

See Comment #62 https://bugzilla.gnome.org/show_bug.cgi?id=745079#c62

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

summary: - two mouse cursors visible at the same time
+ two mouse cursors visible at the same time on rotated screen
affects: xorg (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
importance: Undecided → Low
xornet (xornet) wrote :

+1
I've just upgraded ubuntu to 17.10 and got this bug =(
I have 3 monitors (1 laptop and two 2560x1440 monitors)
first is the laptop screen, second is rotated vertically screen and next one is not rotated normal screen. when I move cursor on third screen I can see rotated reflection of cursor on second (rotated) screen. It really annoys me, because I cann't work now. =(

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in mutter (Ubuntu):
status: New → Confirmed
tags: added: cursor multimonitor
Changed in gnome-shell (Ubuntu):
importance: Low → Medium
Changed in mutter (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

Could somebody having the issue open an upstream report?

I have a 3 screen setup on a notebook with intel graphics. The left one is in portrait view, the center one is in normal view and right is in normal view (buildin), mostly turned off.
When the mouse is in left side of the center monitor it shows also on the left monitor bottom.

The same problem is better described here: https://askubuntu.com/questions/964239/ubuntu-17-10-cursor-mirrored-on-second-screen
And here:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1724977
And since those aren't my post, it affects multiple users.

Thanks

quicksand (matei-tene) wrote :

I can confirm the exact same behaviour in my 2 monitor setup, one in portrait mode to the left and one in landscape to the right. I have just upgraded to 17.10 and, oddly enough, the problem only happens when the open source Nouveau driver is in use. If I switch to the proprietary nVidia driver, the second cursor does not appear, as expected.

Sebastien Bacher (seb128) wrote :

thanks for sending it upstream

Sebastien Bacher (seb128) wrote :

@Rafael, are you using the nouveau driver as well?

Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → Confirmed

My notebook is using the default Intel driver.

Daniel van Vugt (vanvugt) wrote :

I doubt this bug is driver-specific. A rotated screen might get "software" (GL) cursor rendering by default in Wayland sessions (I am guessing since we did the same in Mir). And the hardware cursor is used on non-rotated screens. The two should co-exist and only one display at a time, so that's no excuse, just a possible explanation.

One reason why the problem might appear to go away with the proprietary Nvidia driver is because that uses Xorg by default. So it avoids all such issues that are peculiar to the Wayland/eglnative case.

jeffbl (jeff-mulb) wrote :

Confirmed - rotated second screen causes duplicate cursor. Luckily the second one is un-rotated, so it is easy to know which is the "real" cursor.

Stratos Goudelis (sgoudelis) wrote :

I switched to KDE Plasma..

Description of problem:

I have three displays connected to a Radeon RX480. One is 3840x2160 (landscape), the other two are 1200x1920 (portrait left and right, respectively). The 4k display is indexed as the third one in the Displays panel of the Settings app, and arranged as the rightmost of the three displays.

After upgrading to Fedora 27, when the mouse pointer is near the left edge of the 4k display, it also appears on the adjacent 2k display. The extra pointer is displayed as if the display was in landscape mode, so it appears rotated relative to the display contents. It seems to be just a display bug; click events go correctly to items on the 4k display.

Version-Release number of selected component (if applicable):

wayland-1.14.0-1.fc27
gnome-shell-3.26.2-1.fc27

How reproducible:

Always.

Steps to Reproduce:

I haven't tried to reproduce from a fresh config. Hopefully it's reproducible with a similar config.

Created attachment 1352198
video demonstrating the issue

If I unplug one of the 2k monitors I can still reproduce if the remaining 2k monitor is in 'portrait left' but not 'landscape'. So the issue should be reproducible with two screens.

Any hints on how to debug this?

I'm experiencing the same problem in gnome-shell 3.26.2-1 on Debian testing.

It also happens to me, I have two monitors and one is on 'Portrait right'.
Any hint on how to debug or provide more information?

Also happening here. Incidentally my third screen on the left is in portrait as well. Using the intel i915 driver and wayland

Same here with 3 screens on Wayland.
The second pointer appears on the monitor on the left which is set as portrait. All of the 3 screens are set to 1920x1080.

Happens on Fedora 27 as well. The problem appeared after the upgrade and was not present on Fedora 26 with GNOME 3.24.

I had the same issue after uprading from Ubuntu Gnome 17.04 to Ubuntu 17.10.
I "fixed it" by using Xorg instead of Wayland.
A colleague of me had the same issue in Arch Linux half a year ago. Always good to know someone who is living on the bleeding edge :D

*** Bug 791888 has been marked as a duplicate of this bug. ***

same problem here, 2 screens, left one set to "Portrait right", right one "landscape".

Doug Winter (doug-isotoma) wrote :

Upgraded from 17.04 to 17.10, and now I am experiencing this. 3 screens, duplicate appears on the rotated second screen.

Happens also in Ubuntu 17.10.
Screen setup is similar to the original bug report.

Using GeForce 940MX with nouveau.

Kai Mast (kai-mast) wrote :

Still a problem in 18.04.

tags: added: bionic

I have this problem on Ubuntu 18.04 with Intel integrated graphics (on a Thinkpad T460s).

Any way I can help you debug this?

I currently have this problem after a system upgrade from 26 to 27.
I have a triple monitor setup, with the leftmost monitor set to "portrait right" (like most people commenting)

My current work around is to align the bottom of my left monitor (in portrait right) to the bottom of my center monitor (in landscape)

If I align the top, so that there are more pixels below my center monitor the "ghost" cursor appears. After some testing, I found that this only happens in "portrait right" and "portrait left" on the left-most monitor. Adjusting the position and orientation on my right monitor doesn't have an affect.

Thanks, Evan, for the new data. Hopefully that will help narrow down the issue.

As a temporary workaround, selecting "GNOME on Xorg" at login does work with F27 and the same gnome-shell version.

I'm having this bug too on Debian Testing, a GTX 1080, and the proprietary drivers.

(In reply to Weston Reed from comment #7)
> I'm having this bug too on Debian Testing, a GTX 1080, and the proprietary
> drivers.

Correction: I updated my system and it re-installed the nouveau drivers, which is when the bug appeared. I re-installed the proprietary drivers and the bug has disappeared.

I am also affected by this 'feature'. I have 3 1920x1200 displays and primarily use my i7-6700hq's integrated graphics. I also have a discrete 960m; however, I don't believe it's in use. I am running Fedora 27 with Gnome 3.26.2.

The issue only occurs with my leftmost monitor when it's set to portrait mode. Feel free to contact me if I can help troubleshoot this.

I'm also affected:

x2 1920x1080 screens (left in portrait right mode and left in landscape mode)
OS: Arch Linux
GNOME: 3.26.2
Wayland: 1.14.0
Weston: 3.0.0
Graphics card: Intel HD Graphics 530 (There is a secondary nVidia GTX 1050 but it is disabled and power disconnected)

In my case the mouse from the top left corner (aproximattely a quarter of the screen area) of the landscape screen replicates onto the bottom left of the portrait screen, in landscape orientation. Actions do not affect the portrait screen.

This issue does not happen with the reverse layout: left screen in landscape mode and right in portrait right mode.

I am also having this issue.

Ubuntu 17.10

Pretty much same setup as OP.

since the last dnf update i'm back to one cursor, this is works-for-me.

I just did a dnf update and i still see the duplicate cursor when moving on the top left part of my screen.

This happens also on a ThinkPad T530 with Fedora 27, both with either the discrete (NVIDIA) or integrated (Intel) GPU enabled, but not with OPTIMUS.

Just FYI if it can help you guys in any way (I do know this is an Ubuntu forum), I'm adding a confirmation that this is not Ubuntu specific. I've also reproduced it in Fedora 27 under Wayland with 3 monitors: left horizontal, middle vertical (rotated right), right horizontal. There's algo an open bug in Fedora Bugzilla: see RedHat bug: https://bugzilla.redhat.com/show_bug.cgi?id=1513160.

Same here under Wayland with 3 monitors: left horizontal, middle vertical (physically rotated right, image rotated left), right horizontal. Attaching image that shows screen configuration: primary screen #3, which is the most left one (ordered 312 from left to right).

Created attachment 1410471
Screen configuration with 3 monitors 3-horiz 1-vert 2-horiz

Screen configuration with 3 monitors: left most, #3 horizontal; middle, #1 vertical; right most, #2 horizontal.

This bug has moved to: https://gitlab.gnome.org/GNOME/mutter/issues/85
where it is now fixed.

Changed in mutter (Ubuntu):
status: Confirmed → Triaged
Daniel van Vugt (vanvugt) wrote :

Fix landed upstream ready for mutter release 3.28.1:
https://gitlab.gnome.org/GNOME/mutter/commit/8696a794

The upstream bug is now:
https://gitlab.gnome.org/GNOME/mutter/issues/85

Fixed with MR!59

Changed in gnome-shell:
status: Confirmed → Fix Released
tags: added: fixed-in-3.28.1

Is the fix for this bug going to make it to 18.04 release?

Daniel van Vugt (vanvugt) wrote :

Not sure. Maybe keep an eye on the version numbers in:
https://launchpad.net/ubuntu/+source/mutter

Changed in wayland (Fedora):
importance: Unknown → Undecided
status: Unknown → Confirmed
Daniel van Vugt (vanvugt) wrote :

mutter (3.28.1-1) unstable; urgency=medium

  [ Jeremy Bicha ]
  * New upstream release
    - Fix window button spacing when display is scaled (LP: #1725133)
  * Bump Standards-Version to 4.1.4

  [ Marco Trevisan (Treviño) ]
  * Add patches proposed upstream:
  * theme-frames-Use-surface-device-scale-instead-of-cairo_sc.patch:
    - theme, frames: Use surface device scale instead of cairo_scale
      (LP: #1764554)
  * theme-use-gtk_render_icon_suface-to-paint-button-icon.patch:
    - theme: use gtk_render_icon_suface to paint button icon
      (LP: #1764558)
  * theme-load-icons-as-Gtk-does-with-fallback-and-RTL-suppor.patch:
    - theme: load icons as Gtk does with fallback and RTL support
  * clutter-Smooth-out-master-clock-to-smooth-visuals.patch:
    - clutter: Smooth out master clock to smooth visuals
  * core-Return-1-if-meta_window_get_monitor-is-called-on-an-.patch:
    - core: Return -1 if meta_window_get_monitor is called on an
      unmanaged window (LP: #1724439)
  * backends-Move-MetaOutput-crtc-field-into-private-struct.patch:
    - backends: Move MetaOutput::crtc field into private struct
      (LP: #1703668)
  * backends-Add-logical-monitor-monitor-output-crtc-ref-chai.patch:
    - backends: Add logical monitor -> monitor -> output -> crtc ref
      chain (LP: #1703668)

 -- Jeremy Bicha <email address hidden> Mon, 16 Apr 2018 22:35:14 -0400

Changed in mutter (Ubuntu):
status: Triaged → Fix Released
no longer affects: gnome-shell (Ubuntu)
affects: wayland (Fedora) → mutter (Fedora)
affects: gnome-shell → mutter
Daniel van Vugt (vanvugt) wrote :

3.28.1 is now in Ubuntu 18.04 so this bug *should* be fixed.

Changed in mutter:
importance: Medium → Unknown
status: Fix Released → Unknown
Changed in mutter:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.