[Natty] [i915] spurious eDP1 display detected as permanently connected (HP ProBook 5320m)

Bug #773734 reported by Olivier Dony (Odoo) on 2011-04-30
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Fedora)
New
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

After today's upgrade to Natty, my HP ProBook 5320m gets a second builtin screen detected as always connected, which causes some issues and makes real dual-screen setup impossible. It seems to be related to the DisplayPort, as xrandr shows it as eDP1 (the gnome display planel shows it as "Unknown").
Yesterday when I was still on Maverick with 2.6.35-28-generic, it was apparently detecting this differently, and not causing any issue.

To summarize the content of the full system logs attached, previously on 10.10, when the laptop was not connected to any external display, xrandr detected the following displays:
- LVDS1, connected
- VGA1, disconnected
- HDMI1, disconnected
- DP1, disconnected
- DP2, disconnected
After plugging in the VGA port to an external LCD, it would simply show VGA1 as connected as well.

Now on 11.04, when laptop is not connected to anything, xrandr shows:
- LVDS1, connected
- eDP1, connected
- VGA1, disconnected
- HDMI1, disconnected
- DP1, disconnected

As you can see in the logs, eDP1 is detected with the same capabilities as the builtin LCD (LVDS1).
Here are some of the consequences I have seen so far:
- I can't turn eDP1 off, as it also switches off the main laptop display (supposed to be LVDS1)
- By default eDP1 is virtually positioned on the side of LVDS1, extending the screen estate, except that all things put there can't be seen anywhere. The only workaround I could find is to enable "mirrorring" of the 2 displays.
- Because both LVDS1 and eDP1 must be enabled all the time, I can't connect to any external display via the VGA port, because (AFAICS) both CRTC slots of the video card are used. External displays work only if eDP1 is turned off, but that disables the laptop's display...

Any help or workaround would be appreciated, and I am ready to try anything that might be useful for further debugging.

Thanks!

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAGrywRAAAAAAESAQOAHRB4CvnVlVVUkychUFQAAAABAQEBAQEBAQEBAQEBAQEBEhtWWlAAGTAwIDYAJaQQAAAYEhtWSlEA/DAwIDYAJaQQAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBCMTMzWFcwMSBWMSAKALg=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.eDP.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64:
Date: Sat Apr 30 01:37:56 2011
DistUpgraded: Log time: 2011-04-29 14:02:21.492501
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 2.6.38-8-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 2.6.35-28-generic, x86_64: installed
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:149b]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Hewlett-Packard HP ProBook 5320m
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=13cd156c-950d-43c5-9ecf-33e8f3ae57d6 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
UpgradeStatus: Upgraded to natty on 2011-04-29 (0 days ago)
dmi.bios.date: 06/25/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68AFU Ver. F.02
dmi.board.name: 149B
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 82.10
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68AFUVer.F.02:bd06/25/2010:svnHewlett-Packard:pnHPProBook5320m:pvr:rvnHewlett-Packard:rn149B:rvrKBCVersion82.10:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP ProBook 5320m
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

bugbot (bugbot) on 2011-04-30
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Bryce Harrington (bryce) wrote :

Sounds like kernel drm is enabling the eDP1 output inappropriately, and probably needs a quirk or something.

affects: xserver-xorg-video-intel (Ubuntu) → linux (Ubuntu)
tags: added: regression-release
removed: regression-update

Bryce, thanks for the feedback.
In case it helps, I am attaching the result of "dmesg | grep drm" after booting the same machine with drm.debug=0x04.

Any hints as to what I can try to narrow down the problem or solve it would be very much appreciated, I'm in the dark ;-)

I tried to boot some other kernels, and got mixed results:

- 2.6.39-997-generic_amd64 [latest one from drm-intel-next from kernel-ppa]
  -> black screen on boot, fan spinning up and lots of disk activity, but doesn't seem to boot

- 2.6.36-020636-generic_amd64 [an older one from 10.10, from the kernel-ppa]
  -> initally black screen, flickers, shows log messages for a second, then black forever (but actually boots, can hear login prompt sound)

- 2.6.35-28-generic_amd64 (2.6.35-28.50) [a previous one found on my system]
 -> boots fine, and eDP1 is gone from xrandr (yay!), but unstable, no network, various errors in syslog (e.g CPU power or thermal limit exceeded, etc.)

So, I'm back to 2.6.38-8-generic, but it seems more and more unstable wrt intel drm. I often get video freezes when plugging in VGA or changing modes with xrandr, with this in syslog: "BUG: unable to handle kernel NULL pointer dereference".
In case it helps, I'm attaching an extract from syslog with a few of these, including trace, but I suppose this might be a different bug?

summary: - [Natty] spurious eDP1 display detected as permanently connected, on i915
+ [Natty] [i915] spurious eDP1 display detected as permanently connected
+ (HP ProBook 5320m)
zonky (zonky) wrote :

Hi, i can't add much to the above, only to report i have the same Laptop, Hp 5320m, running 11.04 (amd64) with exactly the same problem.

Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed

Hi,
 I have the same problem with my ProBook 5320m and 11.04 (X86) that I upgraded last Sunday from a 10.10.

Hi all,

I confirm the bug of Olivier Dony, I have the same symptoms. I have a Dual Screen and now, I can't work.

Regards,

Stéphane

FWIW: Stephane helped me find out that you can forcefully disconnect the eDP1 output via a kernel boot parameter. We added video=eDP-1:d as a kernel boot param (manually during bootup, or directly by adding it in /boot/grub/grub.cfg).
In my case it doesn't seem to help much: eDP1 output appears indeed "disconnected" in xrandr, but unsurprisingly LVDS1 does not want to turn on anymore (as they seem to be linked somehow). And as a bonus side effect, the VGA1 output does not work properly in 1680x1050 anymore, instead it has a bottom left area of 1024x768 that works, and the other 3 quarters of the screen are black or show graphical glitches... not usable.

Replying to myself again... I found one way to get "usable" dual screen in Natty:

1.- Boot normally without disabling eDP1 (i.e. forget about comment #8)
2.- Login using the Gnome Classic interface (yes apparently Unity is causing some problems here)
3.- Manually disable the eDP1 output, e.g. with xrandr, and only enable the LVDS and VGA output. This line works for me:
    $ xrandr --output eDP1 --off --output --LVDS1 --mode 1366x768 --output VGA1 --mode 1680x1050 --primary
4.- Yay, both screens work at the same time at their max resolutions!

This indicates that there is probably more than one bug at play here, and the fact that Unity and Gnome-shell have different results could be related to bug 661450, or more specifically to bug 726892, which is a duplicate of it.

Hope this will help those looking for a solution...

lightweight (dave-egressive) wrote :

I also have this problem with my HP 5320m, also upgraded from Maverick to Natty yesterday. I seem to have solved the xrandr problem by upgrading the kernel to 2.6.39-020639rc4-generic via the mainline kernel PPA: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.39-rc4-natty/

Haven't tested it much yet, but it seems to be allowing me to use xrandr to use my external 1920x1080 LCD (with LVDS1 to the right, i.e. no mirrored) as I did on Maverick and Lucid before that.

Hope that helps someone.

lightweight (dave-egressive) wrote :

To provide a bit further assistance, I had to download the following packages:
linux-headers-2.6.39-020639rc4_2.6.39-020639rc4.201104191410_all.deb
linux-headers-2.6.39-020639rc4-generic_2.6.39-020639rc4.201104191410_amd64.deb
linux-image-2.6.39-020639rc4-generic_2.6.39-020639rc4.201104191410_amd64.deb

and installed them via (from a dir containing *only those 3 debs* :))
sudo dpkg -i *.deb

The deb post processing updated my grub configuration, and made this kernel the default boot kernel.

lightweight (dave-egressive) wrote :

Finally, I should note that I was largely motivated to update to Natty due to an annoying instability with Maverick's latest kernel update that meant I got black screens and hangs when switching between graphics modes via xrandr or when recovering from suspend (and having a different monitor configuration from before the suspend). So far, the 2.6.39-rc4 kernel has not exhibited those problems, so cautiously optimistic.

lightweight (dave-egressive) wrote :

Final final clarification :) - with 2.6.39-rc4, I no longer have the eDP1 device under xrandr.

@lightweight: thanks a lot for your detailed feedback, I installed the same 2.6.39-rc4 kernel version you mentioned, and this annoying eDP1 output is gone too! Great! As a bonus it almost makes unity usable again.

Looking at the changelog of the 2.6.39 rc kernels, it looks like this bug report is fixed upstream by https://bugzilla.kernel.org/show_bug.cgi?id=24822 which was merged in 2.6.39-rc1 (commit 48898b038b69ef4801f0e059026c8f6920684677, see http://www.kernel.org/pub/linux/kernel/v2.6/testing/ChangeLog-2.6.39-rc1)
Therefore any working 2.6.39-rc1 kernel or later should fix the problem. Great!

I'm marking the bug as Fix Committed, not sure if it can be Fix Released yet?

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
zonky (zonky) wrote :

Hi, installing the 2.6.39-rc4 kernel did fix the video issue, but i got some weird screen problems with an additonal montior, which may be unrelated to this bug.

Also, i found that the wireless no longer worked (might now need the STA driver?), neither did inbuilt 3G?

On 05/16/2011 10:53 PM, zonky wrote:
> Hi, installing the 2.6.39-rc4 kernel did fix the video issue, but i got
> some weird screen problems with an additonal montior, which may be
> unrelated to this bug.

I don't have more weird screen problems here, but I'm still using Ubuntu
Classic, rather than Unity. My guess would be that these are unrelated
indeed.

Also noteworthy: I'm experiencing less screen issues when waking from
suspend too, with 2.6.39-rc4. It used to lead to permanent black screen
in about 90% of the cases before.

> Also, i found that the wireless no longer worked (might now need the STA
> driver?), neither did inbuilt 3G?

The wireless appears to be working fine here, using the wl driver. I'm
attaching the output of "lspci", "lshw -class network", and an extract
from "dmesg" so you can compare the hardware specs and results.

BTW, it turns out that the issue was fixed as of 2.6.39-rc1, so you
could try any of the 2.6.39 kernels after rc1, in case you get different
results with the wifi. You could even try the oneiric builds, which
contain the latest rc7 kernel.

zonky (zonky) wrote :

Pretty sure the bugs i'm now seeing a unity related when using one of the RC Kernels.

Have 3G working after:
:~$ sudo pkill modem-manager; sudo rmmod qcserial; sudo modprobe qcserial

Not much luck on the wireless front however. Will try and devote some more time to it in next few days, but with unity still broken, i'll just have to live without the extenal monitor for now.

heap (lenovomi) wrote :

Hello,

I occurred the same problem, so I installed 2.6.39-020639rc4-generic #201104191410.

The Unknown display device lost, but with Unity, the dual head screen is broken. The external display is black and the half of lcd laptop is black. I cant see any window in external display.

Maybe log attached will be helpful?

Thanks

heap (lenovomi) wrote :

One more note,

with Ubuntu old - everything works fine.

zonky (zonky) wrote :

Heap as the same symptoms as i- but i am guessing this a unity bug, unrelated to this bug.

zonky (zonky) wrote :

My wireless problem turn out to be that my laptop uses the brcm80211 driver, which while built in to the natty release kernel, is not present in these RC kernels. I can confirm that using the RC kernel plus recent unity fixes negates all this problems above, but i have no desire to go back to the STA driver.

Julian Wiedmann (jwiedmann) wrote :

Closing per comment #14.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.