Ubuntu Installation Bug Int 6: CR2 00f009b8

Bug #440310 reported by Archish on 2009-10-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Fedora)
Invalid
Critical
linux (Ubuntu)
High
Colin Ian King
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

I am using ASUS K40IN Notebook with Intel Core 2 Duo T6670 processor. This notebook is based on Nvidia MCP75 Chipset. Latest/Installed BIOS:213
When I try to install Ubuntu 9.04 32bit or use try Ubuntu without installing I get the following Error

BUG: Int 6: CR2 00f009b8
          EDI ff700000 ESI c2c35a00 EBP c08e7f14 ESP c08e7efc
          EBX c07d8521 EDX 00000006 ECX c07d8521 EAX ff700000
          err (null) EIP c0666d3f CS 00000060 flg 00010092
Stack: c07d8521 1fffffff c08e7f2c c09151e2 c2c35a00 c095cfa0 0000000b 0000000c
            c08e7f44 c08f3d5b 1fffffff c08782fc c08e7fa4 37fef34a c08efc0 c08f2ade
            373fe000 (null) 37fef34a (null) 00031334a 36dd4000 (null) 37fef34a

The same issues are reported in other places as well:
http://vip.asus.com/forum/view.aspx?board_id=3&model=K40IN&id=20090718171113562&page=1&SLanguage=en-us

https://bugzilla.redhat.com/show_bug.cgi?id=513761

Its quite annoying as I am unable to install Ubuntu at all. Any fix for this issue?

Thanks.

Created attachment 355143
Fedora 10 dmesg for Asus K50IN laptop

Description of problem:

I've tried to upgrade my Fedora 10 using preupgrade package. It prepared the system for upgrade to Fedora 11, downloaded and installed the kernel (I believe it is 2.6.29.4-167.fc11). And now I have the grub menu item "Upgrade to Fedora 11 (Leonidas)". If I'm trying to use this menu I get the same bug.
So I have to use my old Fedora 10 grub menu item with kernel 2.6.27.25-170.2.72.fc10.i386. Fedora 10 works correctly.

I've tried to upgrade using Fedora Live DVD (http://mirror.yandex.ru/fedora/linux/releases/11/Fedora/i386/iso/Fedora-11-i386-DVD.iso) and got the same bug.
When I've tried to use the rescue mode it wrote: Loding vmlinuz... Loading initrd.img... blinked about EDD check... and bug message.
I've tried to use edd=off kernel option, result is the same.

The same bug with Fedora Live CD.

Version-Release number of selected component (if applicable):
kernel-2.6.29.4-167.fc11.i586

How reproducible:

Steps to Reproduce:
1. Download the Fedora 11 DVD (http://mirror.yandex.ru/fedora/linux/releases/11/Fedora/i386/iso/Fedora-11-i386-DVD.iso)
2. Prepare the Fedora 11 DVD disk.
3. Get the Asus K50IN laptop.
4. Try to boot the laptop in rescue mode from Fedora 11 DVD.

Actual results:

While kernel booting up the system halt with following message:
---
BUG: Int 6: CR2 00f009b8
          EDI ff700000 ESI c2c35a00 EBP c08e7f14 ESP c08e7efc
          EBX c07d8521 EDX 00000006 ECX c07d8521 EAX ff700000
          err (null) EIP c0666d3f CS 00000060 flg 00010092
Stack: c07d8521 1fffffff c08e7f2c c09151e2 c2c35a00 c095cfa0 0000000b 0000000c
       c08e7f44 c08f3d5b 1fffffff c08782fc c08e7fa4 37fef34a c08efc0 c08f2ade
       373fe000 (null) 37fef34a (null) 00031334a 36dd4000 (null) 37fef34a
---

Expected results:

Normal system boot.

Additional info:

Model: ASUS K50IN
Chipset: Nvidia MCP79
Processor: Pentium Dual-Core CPU T4200 @ 2.00GHz
Videocard: GeForce G102M/PCI/SSE2
Sound: ALC662

Also I'll attach the Fedora 10 dmesg for this laptop.

Please, change the severity from Urgent the High.

Thank you.

I not the steady user of Fedora, but the same bug occured on my notebook ASUS K40IN (K40IN-T420SCELWW).

When i'm trying to boot from Fedora-11-i686-Live, i'm getting exactly the same error.

But OpenSUSE 11.1 works fine:
alex@linux-b6dc:~> uname -a

Linux linux-b6dc 2.6.27.23-0.1-pae #1 SMP 2009-05-26 17:02:05 -0400 i686 i686 i386 GNU/Linux

Colin Ian King (colin-king) wrote :

I've read on several forums that this could only affect the 32 bit version. Have you tried the 64bit Ubuntu?

Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Colin King (colin-king)
summary: - Ubuntu Insallation Bug Int 6: CR2 00f009b8
+ Ubuntu Installation Bug Int 6: CR2 00f009b8
Changed in linux (Ubuntu):
status: Triaged → In Progress
status: In Progress → Incomplete
Archish (archish) wrote :

Hi Colin,
Thanks for the reply. As mentioned the issue is only in Ubuntu 9.04 32bit. I tried Ubuntu 9.04 64 bit and also 9.10 32bit Beta and it works fine. Looks like the issue is with 32bit 2.6.28 series kernel alone.

Changed in linux (Fedora):
status: Unknown → Confirmed
Changed in linux (Ubuntu):
importance: Medium → High
Colin Ian King (colin-king) wrote :

This is fixed with Ubuntu 9.10 Karmic (32 + 64 bit), so we recommend upgrading to Karmic as this contains the support for your processor. We won't fix this for Jaunty.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
Changed in linux (Ubuntu):
milestone: none → karmic-updates
milestone: karmic-updates → none

Just updating the status to reflect Colin's note in comment #3. Thanks.

Changed in linux (Ubuntu Karmic):
status: New → Fix Released
Changed in linux (Ubuntu Jaunty):
status: New → Won't Fix

There is no such the bug anymore with current kernel versions (2.6.29 and up). So I'm closing the ticket.

Cheers.

Changed in linux (Fedora):
importance: Unknown → Critical
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.