Fedora

[Regression intrepid] Screen brightness problems on Acer laptop

Reported by Rohan Dhruva on 2008-12-03
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-power
Expired
Medium
gnome-power-manager (Fedora)
Fix Released
Unknown
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

Description of problem:
I have an Acer TravelMate 3260 laptop. The ACPI stuff like bluetooth, screen brightness etc. is handled by acer-wmi module. In Ubuntu 8.04, brightness control worked perfectly. On trying the Intrepid LiveCD, I am having the problems with both control of brightness in preferences, and the on-screen display which appears when I change brightness using the Fn+Arrow keys. The problem is described in detail below. The problem is related to gnome-power-manager per se.

This bug is reproducible on Fedora 10 as well.

How reproducible:
Always

Steps to Reproduce:
1. In g-p-m Preferences, "On AC Power", Set display brightness to XX% doesn't work
2. Control brightness using Fn+Left/Right arrow keys, OSD shoots beyond max and min limits

Actual results:
1. The brightness does not reduce/increase
2. The OSD fill increases even after full brightness, and decreases even after zero

Expected results:
1. Change should take place instantly
2. OSD fill limits should be between actual limits of brightness only

Additional info:
I am pasting this info from fedora, but the same is also applicable from Intrepid LiveCD.

I can control brightness software-"manually" from the console, by manually writing and reading entries from
/sys/devices/platform/acer-wmi/backlight/acer-wmi. Here is sample output:

[rohan@fedora acer-wmi]$ pwd
/sys/devices/platform/acer-wmi/backlight/acer-wmi
[rohan@fedora acer-wmi]$ cat max_brightness
15
[rohan@fedora acer-wmi]$ cat actual_brightness
10
[rohan@fedora acer-wmi]$ echo 5 | sudo tee brightness
5
[rohan@fedora acer-wmi]$ cat brightness
5
[rohan@fedora acer-wmi]$ cat actual_brightness
5
[rohan@fedora acer-wmi]$

Changed in gnome-power-manager:
status: Unknown → Confirmed
Changed in gnome-power-manager:
importance: Undecided → Low
status: New → Triaged
Changed in gnome-power:
status: Unknown → New
Rohan Dhruva (rohandhruva) wrote :

Update: I tried reproducing this situation on recently released Debian lenny, and there the indicator and slider works perfectly. Debian has g-p-m 2.22.1.

Rohan Dhruva (rohandhruva) wrote :

Update 2: I tried the Jaunty Alpha 5 livecd, and the problem persists even in the new notifications system - here is the bug about it here -- https://bugs.launchpad.net/bugs/337772

Rohan Dhruva (rohandhruva) wrote :

As mentioned in the above report, it seems that problem is that g-p-m is not getting proper values from hardware. However, I have talked to the maintainer of the acer-wmi module (which handles acpi stuff for acer), and he feels that the module itself is not at fault. What can I do to debug this problem further?

Rohan Dhruva (rohandhruva) wrote :

The exact same problem exists in Fedora 11, so I am prompted to think it is a gnome 2.24 and 2.26 problem.

Carey Underwood (cwillu) wrote :

I can confirm that the module is not at fault, /sys/class/backlight/acer-wmi/brightness reports 0 when the screen is at minimum brightness, and 15 when at maximum brightness, and further key-presses produce no effect on the actual screen brightness nor the reported value. However, the gnome brightness meter still moves up and down past those limits, as if it is keeping track of a running total, rather than reading the current value from any authoritative source.

Carey Underwood (cwillu) wrote :

Also, the old meter displayed properly.

(Intended as a data-point, not as a knock against notify-osd)

Rohan Dhruva (rohandhruva) wrote :

Carey, by the "old" meter, do you mean the one in hardy i.e. gnome 2.22? Because intrepid i.e. gnome 2.24 onwards, the meter hasn't been working properly for me.

@Rohan

From memory, it worked until fairly recently. I'll download an
intrepid live cd and verify it though.

On Sun, Mar 22, 2009 at 7:32 AM, Rohan Dhruva <email address hidden> wrote:
> Carey, by the "old" meter, do you mean the one in hardy i.e. gnome 2.22?
> Because intrepid i.e. gnome 2.24 onwards, the meter hasn't been working
> properly for me.
>
> --
> [Regression intrepid] Screen brightness problems on Acer laptop
> https://bugs.launchpad.net/bugs/304940
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in gnome-power-manager (Fedora):
status: Confirmed → Fix Released
Rohan Dhruva (rohandhruva) wrote :

I can confirm that this bug occurs in Ubuntu 9.04 release too. As the previous update by Bug Watcher shows, it has been fixed in Fedora 11, so can the fix be backported?

Scott Howard (showard314) wrote :

Hi Rohan, does this bug exist in the latest Karmic releases?
I'm trying to see if this is a duplicate:
https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/378072
or if it has been fixed.

Rohan Dhruva (rohandhruva) wrote :

I am very sorry, I no longer have this laptop, so I won't be able to test it.

Changed in gnome-power:
importance: Unknown → Medium
Changed in gnome-power:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.