[Regression intrepid] Screen brightness problems on Acer laptop

Bug #304940 reported by Rohan Dhruva on 2008-12-03
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-power
Expired
Medium
gnome-power-manager (Fedora)
Fix Released
High
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

Description of problem:
I have an Acer TravelMate 3260 laptop. The ACPI stuff like bluetooth, screen brightness etc. is handled by acer-wmi module. In Ubuntu 8.04, brightness control worked perfectly. On trying the Intrepid LiveCD, I am having the problems with both control of brightness in preferences, and the on-screen display which appears when I change brightness using the Fn+Arrow keys. The problem is described in detail below. The problem is related to gnome-power-manager per se.

This bug is reproducible on Fedora 10 as well.

How reproducible:
Always

Steps to Reproduce:
1. In g-p-m Preferences, "On AC Power", Set display brightness to XX% doesn't work
2. Control brightness using Fn+Left/Right arrow keys, OSD shoots beyond max and min limits

Actual results:
1. The brightness does not reduce/increase
2. The OSD fill increases even after full brightness, and decreases even after zero

Expected results:
1. Change should take place instantly
2. OSD fill limits should be between actual limits of brightness only

Additional info:
I am pasting this info from fedora, but the same is also applicable from Intrepid LiveCD.

I can control brightness software-"manually" from the console, by manually writing and reading entries from
/sys/devices/platform/acer-wmi/backlight/acer-wmi. Here is sample output:

[rohan@fedora acer-wmi]$ pwd
/sys/devices/platform/acer-wmi/backlight/acer-wmi
[rohan@fedora acer-wmi]$ cat max_brightness
15
[rohan@fedora acer-wmi]$ cat actual_brightness
10
[rohan@fedora acer-wmi]$ echo 5 | sudo tee brightness
5
[rohan@fedora acer-wmi]$ cat brightness
5
[rohan@fedora acer-wmi]$ cat actual_brightness
5
[rohan@fedora acer-wmi]$

Description of problem:
I just installed F10 on my Acer TravelMate 3260 laptop. The ACPI stuff like bluetooth, screen brightness etc. is handled by acer-wmi module. In Fedora 9, brightness control worked perfectly. In Fedora 10, I am having the problems with both control of brightness in preferences, and the on-screen display which appears when I change brightness using the Fn+Arrow keys. The problem is described in detail below.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.24.1-3.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. In g-p-m Preferences, "On AC Power", Set display brightness to XX% doesn't work
2. Control brightness using Fn+Left/Right arrow keys, OSD shoots beyond max and min limits

Actual results:
1. The brightness does not reduce/increase
2. The OSD fill increases even after full brightness, and decreases even after zero

Expected results:
1. Change should take place instantly
2. OSD fill limits should be between actual limits of brightness only

Additional info:
I can control brightness software-"manually" from the console, by manually writing and reading entries from /sys/devices/platform/acer-wmi/backlight/acer-wmi. Here is sample output:

[rohan@fedora acer-wmi]$ pwd
/sys/devices/platform/acer-wmi/backlight/acer-wmi
[rohan@fedora acer-wmi]$ cat max_brightness
15
[rohan@fedora acer-wmi]$ cat actual_brightness
10
[rohan@fedora acer-wmi]$ echo 5 | sudo tee brightness
5
[rohan@fedora acer-wmi]$ cat brightness
5
[rohan@fedora acer-wmi]$ cat actual_brightness
5
[rohan@fedora acer-wmi]$

This output might be helpful:

[rohan@fedora ~]$ lshal | grep laptop_panel
  info.capabilities = {'laptop_panel'} (string list)
  info.category = 'laptop_panel' (string)
  laptop_panel.access_method = 'general' (string)
  laptop_panel.num_levels = 16 (0x10) (int)

I could reproduce this exact same bug on Ubuntu 8.10 livecd which uses GNOME 2.24 too. Hence I concluded that this might be an upstream bug, and filed one here - http://bugzilla.gnome.org/show_bug.cgi?id=563165

Changed in gnome-power-manager:
status: Unknown → Confirmed
Changed in gnome-power-manager:
importance: Undecided → Low
status: New → Triaged

This is something I noticed of Fedora 10 - whenever I change the brightness using the keyboard (Fn-Left/Right Arrow) key, I get this message in dmesg:

[rohan@fedora Shared]$ dmesg
ACPI: EC: non-query interrupt received, switching to interrupt mode
ACPI: EC: non-query interrupt received, switching to interrupt mode
ACPI: EC: non-query interrupt received, switching to interrupt mode

This happens regardless whether acer_wmi module is loaded or unloaded. Could this be indicative of some problem, or is it harmless?

Changed in gnome-power:
status: Unknown → New

Same thing on Fedora 10, Acer Travelmate 6492.
The symptom is as described by Rohan.

Update: I tried reproducing this situation on recently released Debian lenny, and there the indicator and slider works perfectly. Debian has g-p-m 2.22.1.

Rohan Dhruva (rohandhruva) wrote :

Update: I tried reproducing this situation on recently released Debian lenny, and there the indicator and slider works perfectly. Debian has g-p-m 2.22.1.

Rohan Dhruva (rohandhruva) wrote :

Update 2: I tried the Jaunty Alpha 5 livecd, and the problem persists even in the new notifications system - here is the bug about it here -- https://bugs.launchpad.net/bugs/337772

Rohan Dhruva (rohandhruva) wrote :

As mentioned in the above report, it seems that problem is that g-p-m is not getting proper values from hardware. However, I have talked to the maintainer of the acer-wmi module (which handles acpi stuff for acer), and he feels that the module itself is not at fault. What can I do to debug this problem further?

Rohan Dhruva (rohandhruva) wrote :

The exact same problem exists in Fedora 11, so I am prompted to think it is a gnome 2.24 and 2.26 problem.

The exact same problem exists in Fedora 11 Alpha and Ubuntu 9.04 Alpha 5, so I
am prompted to think it is a gnome 2.24 and 2.26 problem.

Carey Underwood (cwillu) wrote :

I can confirm that the module is not at fault, /sys/class/backlight/acer-wmi/brightness reports 0 when the screen is at minimum brightness, and 15 when at maximum brightness, and further key-presses produce no effect on the actual screen brightness nor the reported value. However, the gnome brightness meter still moves up and down past those limits, as if it is keeping track of a running total, rather than reading the current value from any authoritative source.

Carey Underwood (cwillu) wrote :

Also, the old meter displayed properly.

(Intended as a data-point, not as a knock against notify-osd)

Rohan Dhruva (rohandhruva) wrote :

Carey, by the "old" meter, do you mean the one in hardy i.e. gnome 2.22? Because intrepid i.e. gnome 2.24 onwards, the meter hasn't been working properly for me.

@Rohan

From memory, it worked until fairly recently. I'll download an
intrepid live cd and verify it though.

On Sun, Mar 22, 2009 at 7:32 AM, Rohan Dhruva <email address hidden> wrote:
> Carey, by the "old" meter, do you mean the one in hardy i.e. gnome 2.22?
> Because intrepid i.e. gnome 2.24 onwards, the meter hasn't been working
> properly for me.
>
> --
> [Regression intrepid] Screen brightness problems on Acer laptop
> https://bugs.launchpad.net/bugs/304940
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Does this still happen with the version in fedora rawhide, or the version of the Fedora 11 beta live cd?

Hi Richard,

I am on the live system of Fedora 11 snap1. I can confirm that this bug is definitely solved, the increments in the OSD are proper, and g-p-m settings change apply instantly.

Is the fix local to fedora, or would it work on other distributions like Ubuntu?

Thanks a lot.

Ok, closing this then.

Changed in gnome-power-manager (Fedora):
status: Confirmed → Fix Released
Rohan Dhruva (rohandhruva) wrote :

I can confirm that this bug occurs in Ubuntu 9.04 release too. As the previous update by Bug Watcher shows, it has been fixed in Fedora 11, so can the fix be backported?

Scott Howard (showard314) wrote :

Hi Rohan, does this bug exist in the latest Karmic releases?
I'm trying to see if this is a duplicate:
https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/378072
or if it has been fixed.

Rohan Dhruva (rohandhruva) wrote :

I am very sorry, I no longer have this laptop, so I won't be able to test it.

I have purchased an Acer Aspire AS-3810T 354G32N and installed Centos (presently 5.4). I already have an Acer TravelMate C112TCI with the same Centos installation.

In none of the two computers do the Fn-direction keyboard keys RIGHT and LEFT work. Those are the ones that set screen brightness. On the 3810T that is a serious problem due to the extremely bright screen that Linux is showing.

I am writing from the 3810T and these are my kernel brightness documented scripts and uname outputs:

---------------------------------------------------------------------------

[root@aspire scripts]# chmod 755 *brightness
[root@aspire scripts]# ./*get-bright*
org.freedesktop.Hal.Device.UnknownError
Missing or empty environment variable(s).
This script should be started by hald.
[root@aspire scripts]# cd linux
[root@aspire linux]# ls
hal-luks-remove-linux hal-system-power-hibernate-linux
hal-luks-setup-linux hal-system-power-reboot-linux
hal-luks-teardown-linux hal-system-power-set-power-save-linux
hal-system-lcd-get-brightness-linux hal-system-power-shutdown-linux
hal-system-lcd-set-brightness-linux hal-system-power-suspend-linux
[root@aspire linux]# ./*get-bright*
org.freedesktop.Hal.Device.LaptopPanel.NotSupported
No ACPI method found
[root@aspire linux]#
[root@aspire linux]# uname -a
Linux aspire.workgroup 2.6.18-164.6.1.el5.centos.plusPAE #1 SMP Wed Nov 4 10:17:55 EST 2009 i686 i686 i386 GNU/Linux
[root@aspire linux]#

----------------------------------------------------------------------------

Thanks for your help

I found a solution that works for the Aspire 3810T and, I hope, for others, the merit of an anonymous expert. Please find it at CentOS Issue ID 004246, URL

http://bugs.centos.org/view.php?id=4246

It writes a brightness level directly to a register of the pci VGA device.

I see this bug was closed. Was another solution already posted, or was it an error? One continues to find more complaints over several Linux distros and Acer computer models.

Best regards to all
fernando mansito

Changed in gnome-power:
importance: Unknown → Medium
Changed in gnome-power:
status: New → Expired
Changed in gnome-power-manager (Fedora):
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.