Push VIGRA changes to the right place

Bug #685877 reported by Yuv
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Enblend
High
Christoph Spiel
Hugin
High
Unassigned
enblend (Fedora)
New
Undecided
Unassigned
enblend-enfuse (Debian)
Fix Released
Unknown
hugin (Debian)
Fix Released
Unknown

Bug Description

Enblend embeds a modified version of the VIGRA 1.4 library. Can we push the necessary changes to VIGRA's upstream and use the system version rather than an embedded copy?

Details: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=542258

rew (r-e-wolff)
Changed in enblend:
status: New → Triaged
Revision history for this message
Bruno Postle (brunopostle) wrote :

This also affects Hugin, which contains a modified copy of vigra-1.5

Note that the fedora policy is getting stricter on included libraries, this bug could result in both Hugin and Enblend being dropped at some point: http://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries

Yuv (yuv)
Changed in enblend:
importance: Medium → High
Changed in hugin:
importance: Undecided → High
Changed in enblend:
status: Triaged → Confirmed
Changed in hugin:
status: New → Confirmed
Changed in hugin (Debian):
status: Unknown → Confirmed
Changed in enblend-enfuse (Debian):
status: Unknown → Confirmed
tags: added: bundled foreign library
Revision history for this message
Andreas Metzler (k-launchpad-downhill-at-eu-org) wrote :

VIGRA 1.8.0 was released today. It contains the patches from hugin which were forwarded upstream <http://comments.gmane.org/gmane.comp.video.vigra/42>.

Revision history for this message
Christoph Spiel (cspiel) wrote :

Fixed in rev57a56d454739, though fix curtails functionality:
no alpha masks in output images.

Changed in enblend:
status: Confirmed → In Progress
assignee: nobody → Christoph Spiel (cspiel)
Revision history for this message
Bruno Postle (brunopostle) wrote :

Confirmed, I can now build an enblend snapshot against the standard fedora vigra-1.8.0 package without problems. Thanks.

Regarding the lack of alpha masks in output, is this something that needs a patch pushing to vigra upstream? Being able to feed the output from enblend (or enfuse) as input for more blending is a valid use case.

Revision history for this message
Christoph Spiel (cspiel) wrote :

Export-with-alpha just does not _compile_ anymore with the new Vigra-library.
No trivial fix in sight. Patch highly welcome.

Revision history for this message
Christoph Spiel (cspiel) wrote :

We now have a patch that re-installs all prior functionality
with respect to loading and saving images with alpha-channels.
However, the copyright of the new (it is in fact a complete
rewrite) file "impexalpha.hxx" must be sorted out before we can
add it to the repository.

Revision history for this message
Yuv (yuv) wrote : Re: [Bug 685877] Re: Push VIGRA changes to the right place

On 12-09-03 07:51 AM, Christoph Spiel wrote:
> We now have a patch that re-installs all prior functionality
> with respect to loading and saving images with alpha-channels.
> However, the copyright of the new (it is in fact a complete
> rewrite) file "impexalpha.hxx" must be sorted out before we can
> add it to the repository.

Thank you. Do I assume correctly that you rewrote the code?

What copyright issues need sorting out other than adding your name to
the credits where credit is due, e.g.
<http://hci.iwr.uni-heidelberg.de/vigra/doc/vigra/CreditsChangelog.html>
or line 3 of impexlpha.hxx itself?

Is the author of the rewrite OK with publishing the file under the
current Vigra license (MIT X11 license)?

Yuv

Revision history for this message
Pablo d'Angelo (pablo.dangelo) wrote :

Hi all,

if the impexalpha code still contains any of my old one, I hereby relicense it under MIT X11 license.

ciao
Pablo

Revision history for this message
Christoph Spiel (cspiel) wrote :

Yuval -

    The copyright issue boils down to the
question whether the new file "impexalpha.hxx" is a
"substantial portion" of the old Vigra code
"impex.hxx" (The quote comes from Vigra's MIT
license.) We are sorting out this one.

On another side we still have problems with the
Graph Cut algorithm when linked against new
Vigra. Maybe, Mikołaj can report more.

Revision history for this message
Yuv (yuv) wrote :

Christoph -
On 12-09-09 03:48 AM, Christoph Spiel wrote:
> The copyright issue boils down to the
> question whether the new file "impexalpha.hxx" is a
> "substantial portion" of the old Vigra code
> "impex.hxx" (The quote comes from Vigra's MIT
> license.) We are sorting out this one.

Why is "substantial portion" an issue? Do you intend to publish the
file under a different license, and if so which one?

How are you going about sorting this out?

> On another side we still have problems with the
> Graph Cut algorithm when linked against new
> Vigra. Maybe, Mikołaj can report more.

Are these technical problems or licensing problems?

Yuv

Revision history for this message
Christoph Spiel (cspiel) wrote :

The copyright problems were ironed out.

The new file "impexalpha.hxx" will be part of the Enblend
project under the same license as all other sources
namely GPL Version 2.

Revision history for this message
Christoph Spiel (cspiel) wrote :

Problems should be fixed in rev 29ec0c175c5a -- fingers crossed.

Changed in enblend:
status: In Progress → Fix Committed
Changed in enblend-enfuse (Debian):
status: Confirmed → Fix Released
tmodes (tmodes)
Changed in enblend:
status: Fix Committed → Fix Released
Revision history for this message
tmodes (tmodes) wrote :

Implemented in changeset cce900e8cc32c54f332a245d78140d5e3831e27a
Hugin requires now vigra 1.9 or later.
We still need out own vigra_ext/impexalpha.hxx because of a bug in vigras impexalpha.hxx which prevents saving of exr files with alpha channel.

Changed in hugin:
status: Confirmed → Fix Committed
tmodes (tmodes)
Changed in hugin:
milestone: none → 2015.0beta1
status: Fix Committed → Fix Released
Changed in hugin (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.