Fedora

Beryl crash with Feisty AMD64 after return from console

Reported by Applegeek on 2007-04-16
6
Affects Status Importance Assigned to Milestone
Beryl
New
Undecided
Unassigned
beryl-core (Fedora)
Invalid
Undecided
Unassigned
beryl-core (Ubuntu)
Medium
Unassigned

Bug Description

Feisty AMD64 running on a Gigabyte M61PM-S2 Mobo AMD 4200 X2 Cpu. 1 Gig ram, nVidia 7100 dsiplay card.

Installed Feisty Beta AMD64. All fine
Installed nVidia 9755 drivers. All fine.
Installed Beryl Composite, Beryl-Manager, Emerald-Themes via Synaptic. Restart X. All fine. Windows wobble, cube spins, everything inside the GUI is fine.

Issue a Ctr-Alt-F2 to jump to a console. All fine.

Issue a Ctrl-Alt-F7 to get back to the GUI. CRASH. Black window. Cursor is alive but nothing. If I issue Ctrl-Alt-F2 then cursor freezes and that's it: Reset button time.

Same here... 32-Bit Feisty. Sometimes (often) I'm able to go back to TTYx and "killall beryl", then everything works again (everything but beryl^^). But I think this is a Beryl bug...

Philluminati (prt-faber) wrote :

I'd like to report exactly the same problem. I switch to a tty but I can't go back to the GUI successfully after about 5 minutes. The screen is black with the exception of a working mouse. Control + Alt + Backspace doesn't respond and there is nothing I can do but reboot. All features are working before the crash.

I'm using:

AMD64 4000+
nVidia 6200 Graphics card (with nVidia binary drivers installed ok)
Fedora Core 6 (No Ubuntu install)
Gnome 2.16.3
Beryl-core 0.2.0

Thanks

Phill
-----------------------------------------------------------------------

This is a dump I got from typing "beryl" at the command line:

**************************************************************
* Beryl system compatiblity check *
**************************************************************

Detected xserver : NVIDIA

Checking Display :0.0 ...

Checking for XComposite extension : passed (v0.3)
Checking for XDamage extension : passed
Checking for RandR extension : passed
Checking for XSync extension : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig : passed
Checking for GLX_EXT_texture_from_pixmap : passed
Checking for non power of two texture support : passed
Checking maximum texture size : passed (4096x4096)

Relaunching beryl with __GL_YIELD="NOTHING"
**************************************************************
* Beryl system compatiblity check *
**************************************************************

Detected xserver : NVIDIA

Checking Display :0.0 ...

Checking for XComposite extension : passed (v0.3)
Checking for XDamage extension : passed
Checking for RandR extension : passed
Checking for XSync extension : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig : passed
Checking for GLX_EXT_texture_from_pixmap : passed
Checking for non power of two texture support : passed
Checking maximum texture size : passed (4096x4096)

Reloading options

Philluminati (prt-faber) wrote :

FYI guys, I think this has also been reported on the bug tracker for beryl itself, although there are no bug fixes yet.

http://bugs.beryl-project.org/ticket/1783

The user also has an AMD64 with a nVidia graphics card and uses a third distribution, Debian. It also looks like Gnome may not be a factor in this problem since the user is using Xfce instead.

Philluminati (prt-faber) wrote :

This problem also happens when you quit full screen games (Unreal Tournament 2004) as well

but I have a WORKAROUND.

Start Beryl manager and right click the icon for it in the system tray (top right corner or where ever it is) and go:

Advanced Beryl Options > Rendering Platform > Force AIGLX (intead of nVidia).

That fixes my issues. I don't know about anyone else.

Philluminati

Beryl is replaced by Compiz Fusion, so has been removed from Gutsy.

  status invalid
  subscribe

Changed in beryl-core:
status: Confirmed → Invalid
Changed in beryl-core:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers