wrong access rights on NFS mount

Bug #75729 reported by Timo Aaltonen on 2006-12-14
4
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
Fedora
Fix Released
Critical
linux-source-2.6.19 (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: linux-source-2.6.19

Beginning from 2.6.19 there are problems with NFS-mounts. The permissions from the first mount is passed to the others, so for example if the first one is with ro-permissions, all rw-mounts after that from the same server are read-only as well. This is filed against Fedora/RHEL as well. I'll link them here.

I've tried edgy, feisty and now the shiny new 2.6.20-1.1 on feisty. They all behave the same. Dapper works fine.

Timo Aaltonen (tjaalton) wrote :

Oh, Redhat has 2.6.18, but I think the culprit are the FS-Cache patches that have been merged in 2.6.19 (?) and which RH most likely has in their 2.6.18 (since they were made by a RH employee).

Timo Aaltonen (tjaalton) wrote :

from nfsv4-mailing list I found some postings by David Howells about FS-Cache, and this patch in particular sounds worrisome:

[PATCH 18/30] NFS: Share NFS superblocks per-protocol per-server per-FSID
http://linux-nfs.org/pipermail/nfsv4/2006-July/004730.html

Timo Aaltonen (tjaalton) wrote :

two more bugs.. seems that I can't link them directly to this bug since there already is one.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=209964
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=217793

Timo Aaltonen (tjaalton) on 2006-12-14
description: updated
Ben Collins (ben-collins) wrote :

Is this fixed in 2.6.20?

Changed in linux-source-2.6.20:
status: Unconfirmed → Needs Info
Timo Aaltonen (tjaalton) wrote :

no, I tested that as well as I said. Anyway, Trond replied and said that this is a feature, not a bug... :

http://linux-nfs.org/pipermail/nfsv4/2006-December/005485.html

so, I don't like the current behavior but if it won't be fixed upstream then this can be closed and make sure that nfs-utils has good documentation of this and other "features" of the linux nfs implementation >:-/

Timo Aaltonen (tjaalton) wrote :

oh wait, maybe I misread the reply.

Timo Aaltonen (tjaalton) wrote :

yep, my followup to the thread should hopefully clarify that this is indeed a different situation from the one that Trond points out. So the bug is real, and I'll wait for replies.

Ben Collins (ben-collins) wrote :

Moved on to 2.6.20 so 2.6.19 will go away.

Changed in linux-source-2.6.19:
status: Unconfirmed → Rejected
Changed in linux-source-2.6.20:
importance: Undecided → Medium
status: Needs Info → Confirmed
Timo Aaltonen (tjaalton) wrote :

the relevant kernel bugzilla entry:

http://bugzilla.kernel.org/show_bug.cgi?id=7612

Ben Collins (ben-collins) wrote :

According to the explanation on the upstream bug report, this is a logic change in the way the kernel handles multiple mounts of the same remote nfs filesystem.

Not a bug.

Changed in linux-source-2.6.20:
status: Confirmed → Fix Released
Changed in linux:
status: Unknown → Rejected
Changed in linux:
status: Invalid → Fix Released
Changed in linux:
importance: Unknown → Medium
Changed in fedora:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.