provide ipython 0.11 compatibility

Reported by Julian Taylor on 2011-08-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Exaile
Medium
Brian Parma
exaile (Ubuntu)
Undecided
Unassigned

Bug Description

IPython 0.11 has been released last week [0,1]. It is currently
available in debian experimental.

In order to upgrade IPython in unstable your package needs to be updated
to deal with the new api and configuration system.
Some hints for migrating applications are available here:
http://wiki.ipython.org/0.11-Migration

exaile seems to use the same ipython code as accerciser and rabbitvcs .
You might want to coordinate fixing this issue with their
maintainers/upstreams.

The documentation for the new version can be found here:
http://ipython.org/ipython-doc/rel-0.11/index.html

[0] http://mail.scipy.org/pipermail/ipython-dev/2011-July/008041.html
[1] http://ipython.org/ipython-doc/rel-0.11/whatsnew/version0.11.html

Johannes Sasongko (sjohannes) wrote :

Thanks for the heads-up. As a note to whoever wants to work on this, we generally view the IPython console plugin as a developer's tool, so we're not worried about backwards compatibility.

Changed in exaile:
importance: Undecided → Medium
status: New → Confirmed

Looks like this was fixed in 3927.

Mathias Brodala (mathbr) wrote :

Fixed with r3927.

Changed in exaile:
assignee: nobody → Brian Parma (bj0)
status: Confirmed → Fix Committed
Changed in exaile:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers