reimporting deleted playlist crashes exail

Reported by stm on 2010-08-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Exaile
Medium
Johannes Sasongko

Bug Description

When I delete a custom playlist and immediately open an exported version of it, exaile crashes.

Steps to reproduce:
1. Create custom playlist
2. Add some titles to it
3. Export it (as xspf)
4. Delete it
5. Open xspf playlist
6. CRASH

Exaile 0.3.1.1 from ubuntu 10.04.

Related branches

stm (spam1208) wrote :
Mathias Brodala (mathbr) wrote :

Please also check the current stable 0.3.2 release.

Changed in exaile:
status: New → Incomplete
stm (spam1208) wrote :

Same thing.

Mathias Brodala (mathbr) on 2010-08-26
Changed in exaile:
importance: Undecided → Medium
milestone: none → 0.3.2.1
status: Incomplete → Confirmed
fidencio (fidencio) on 2011-02-02
Changed in exaile:
assignee: nobody → fidencio (fidencio)
fidencio (fidencio) wrote :

Okay. I think that the bug was solved.
Please, can someone check the patches?

(I'm attaching the first one on this message and the second on the next message)

fidencio (fidencio) wrote :

And the second ...

Johannes Sasongko (sjohannes) wrote :

It turns out this was a symptom of a bigger problem. Background: custom playlists are stored in the panel tree model (column 2), as well as a playlist-to-iter cache (playlist_nodes). These two need to be always in sync.

The problem is simply that deleted playlists were not deleted from the playlist_nodes cache.

The thing about opening playlist files was only a coincidence; it happens to trigger code that requires playlist_nodes to be up-to-date. (How can opening a playlist file trigger something in the panel UI code? No idea.)

While fixing this, I found another bug: update_playlist_node modifies playlist_nodes, but not the playlist object in the tree model. I've fixed that as well.

Fix committed to 0.3.2 and trunk.

Changed in exaile:
assignee: fidencio (fidencio) → Johannes Sasongko (sjohannes)
status: Confirmed → Fix Committed
Aren Olson (reacocard) on 2011-02-13
Changed in exaile:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments