notifyOSD shows formatting: eg &

Reported by Matthew Waters on 2010-07-04
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Exaile
Low
Unassigned

Bug Description

Found on both Exaile 0.3.2.0 (installed from source) and revision no 3571.
Both installations are running Ubuntu 10.04 that are completely updated.

The expected behaviour is that when the OSD is displayed, the information such as the title, artist and album do not contain any formatting such as &

The actual behaviour is that when the OSD is diplayed, the information contains an "&" where there should be a "&"

The problem seems to occur when one calls, cgi.excape() on the text. Without that function, the ampersand (the ampersand is the only one that doesn't work that cgi.escape() affects. see here: http://wiki.python.org/moin/EscapingHtml) is printed correctly. This is also supported by the attached test which displays all the characters that cgi.escape() should change in both character format and HTML format.

The problem seems to occur when one calls, cgi.excape() on the text. Without that function, the ampersand (the ampersand is the only one that doesn't work that cgi.escape() affects. see here: http://wiki.python.org/moin/EscapingHtml) is printed correctly. This is also supported by the attached test which displays all the characters that cgi.escape() should change in both character format and HTML format.

tags: added: plugin
Mathias Brodala (mathbr) wrote :

What notification server are you using?

Changed in exaile:
status: New → Incomplete

Notification Server:

Name: notify-osd
Vendor: Canonical Ltd
Version: 1.0
Spec Version: 1.1
Capabilities:
 body
 body-markup
 icon-static
 image/svg+xml
 x-canonical-private-synchronous
 x-canonical-append
 x-canonical-private-icon-only
 x-canonical-truncation
 private-synchronous
 append
 private-icon-only
 truncation

Changed in exaile:
assignee: nobody → Steve Dodier (sidi)
importance: Undecided → Low
milestone: none → 0.3.3
status: Incomplete → Confirmed
Steve Dodier-Lazaro (sidi) wrote :

It took me some time due to me having to fix another bug that what introduced when the covers and icons manager were changed. Patch attached and available on mupuf.org as usual.

I hope that removing cgi.escape will not raise any issue. I do not remember why I put it in a first time but I think there was a reason...

Changed in exaile:
status: Confirmed → In Progress
Changed in exaile:
milestone: 0.3.3.0 → 0.3.3.1
Mathias Brodala (mathbr) wrote :

The plugin does not show this issue with the latest trunk.

Changed in exaile:
assignee: Steve Dodier-Lazaro (sidi) → nobody
milestone: 0.3.3.1 → 0.3.3.0
status: In Progress → Fix Committed
Changed in exaile:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments