Adding files from cli to exaile playlist is once again broken

Bug #601235 reported by zebul666 on 2010-07-02
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Exaile
Fix Released
Critical
Unassigned
exaile (Ubuntu)
Undecided
Unassigned

Bug Description

when I add a file to exaile playlist from a terminal, it fails:

$ exaile 12-TheMorningFog.mp3
** Message: pygobject_register_sinkfunc is deprecated (GtkWindow)
** Message: pygobject_register_sinkfunc is deprecated (GtkInvisible)
** Message: pygobject_register_sinkfunc is deprecated (GtkObject)
Traceback (most recent call last):
  File "/usr/lib/exaile/exaile.py", line 52, in <module>
    main()
  File "/usr/lib/exaile/exaile.py", line 49, in main
    exaile = main.Exaile()
  File "/usr/lib/exaile/xl/main.py", line 83, in __init__
    exit = xldbus.check_exit(self.options, self.args)
  File "/usr/lib/exaile/xl/xldbus.py", line 78, in check_exit
    iface.Enqueue(args)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/exaile/xl/xldbus.py", line 453, in Enqueue
    tracks = trax.sort_tracks(['album', column], tracks, descending)
  File "/usr/lib/exaile/xl/trax/util.py", line 90, in sort_tracks
    return sorted(iter, key=keyfunc, reverse=reverse)
  File "/usr/lib/exaile/xl/trax/util.py", line 89, in <lambda>
    artist_compilations=artist_compilations) for field in fields]
TypeError: 'bool' object is not callable

It began to happen after my update to 0.3.2. I sn't this supposed to be a bug-fix release ?
Couldn't you test the addition from the command line a bit before releasing. it's been 3 bugs (at least) since 0.3.1 that involve the cli ...

Related branches

zebul666 (zebul666) on 2010-07-02
description: updated
Aren Olson (reacocard) wrote :

Ugh, dunno how we missed this one.

> I sn't this supposed to be a bug-fix release ?
No, the version format is 0.3.x.y. If a release only changes y, its bugfix, if it changes x, its a normal feature release.

Changed in exaile:
importance: Undecided → Critical
milestone: none → 0.3.2.1
status: New → Confirmed
Aren Olson (reacocard) wrote :

fixed 0.3.2.x/3435

Changed in exaile:
status: Confirmed → Fix Committed
zebul666 (zebul666) wrote :

for the record, the fix is in commit 3436 now (??!!)

Pavlos G. (pavlos-g-gmx) wrote :

please delete this...
accidentally added it...

Changed in exaile (Ubuntu):
status: New → Invalid
eric.p (eric-adieubillou) wrote :

I have the same problem with exaile 0.3.2.0: TypeError: 'bool' object is not callable
with ubuntu lucid 64bits, maverick 64bits, natty 64bits, livecd, archlinux 32bits and maverick 32bits

it's ok wityh a old version of exaile

Aren Olson (reacocard) on 2011-02-13
Changed in exaile:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers