TypeError: argument must be a GstElement

Reported by lisu on 2009-09-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Exaile
High
Aren Olson

Bug Description

when runing exaile 0.3.01 after build and install I got this:

$ exaile
INFO : Loading Exaile 0.3.0.1...
INFO : Loading settings...
AttributeError: 'module' object has no attribute 'Element'
INFO : Setting up deferred idle manager function...
INFO : Loading plugins...
INFO : Loading collection...
WARNING : Could not enable auto sink, attempting to autoselect.
Traceback (most recent call last):
  File "/usr/share/exaile/lib/exaile.py", line 56, in <module>
    main()
  File "/usr/share/exaile/lib/exaile.py", line 53, in main
    exaile = main.Exaile()
  File "/usr/share/exaile/lib/xl/main.py", line 90, in __init__
    self.__init()
  File "/usr/share/exaile/lib/xl/main.py", line 155, in __init
    self.player = player.get_player()()
  File "/usr/share/exaile/lib/xl/player/engine_normal.py", line 40, in __init__
    pre_elems=[pipe.ProviderBin("stream_element")])
  File "/usr/share/exaile/lib/xl/player/_base.py", line 48, in __init__
    self.mainbin = pipe.MainBin(pre_elems=pre_elems)
  File "/usr/share/exaile/lib/xl/player/pipe.py", line 63, in __init__
    self.add(*self._elements)
TypeError: argument must be a GstElement

Aren Olson (reacocard) wrote :

This appears to happen because there is no replaygain elements on the system, so we dont get a valid gst.Element for the plugin. We need to catch and handle that case gracefully.

Changed in exaile:
importance: Undecided → High
milestone: none → 0.3.1
status: New → Confirmed
Aren Olson (reacocard) wrote :

should be fixed as of trunk/2697

Changed in exaile:
assignee: nobody → Aren Olson (reacocard)
status: Confirmed → Fix Committed
Aren Olson (reacocard) on 2010-03-16
Changed in exaile:
status: Fix Committed → Fix Released
Giovanni Bechis (bigionews) wrote :

I have a similar behaviour with Exaile 0.3.1.2 on OpenBSD:

$ exaile
INFO : Loading Exaile 0.3.1.2...
INFO : Loading settings...
INFO : Setting up deferred idle manager function...
INFO : Loading plugins...
INFO : Loading collection...

(exaile.py:23799): GStreamer-WARNING **: Element rgvolume0 has an ALWAYS template sink, but no pad of the same name
WARNING : Could not create <class 'replaygain.ReplaygainVolume'> element for bin0.
WARNING : Could not enable auto sink, attempting to autoselect.
Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/exaile/exaile.py", line 52, in <module>
    main()
  File "/usr/local/lib/python2.5/site-packages/exaile/exaile.py", line 49, in main
    exaile = main.Exaile()
  File "/usr/local/lib/python2.5/site-packages/exaile/xl/main.py", line 84, in __init__
    self.__init()
  File "/usr/local/lib/python2.5/site-packages/exaile/xl/main.py", line 154, in __init
    self.player = player.get_player()()
  File "/usr/local/lib/python2.5/site-packages/exaile/xl/player/engine_normal.py", line 44, in __init__
    pre_elems=[pipe.ProviderBin("stream_element")])
  File "/usr/local/lib/python2.5/site-packages/exaile/xl/player/_base.py", line 50, in __init__
    self.mainbin = pipe.MainBin(pre_elems=pre_elems)
  File "/usr/local/lib/python2.5/site-packages/exaile/xl/player/pipe.py", line 64, in __init__
    self.add(*self._elements)
TypeError: argument must be a GstElement

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers