Non-XF86 shortcuts when Exaile is focused

Reported by ziarkaen on 2009-08-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Exaile
Wishlist
Mathias Brodala

Bug Description

When exaile has focus, there should be standard-keyboard shortcuts for core functionality. Specifically, Play/Pause should be mapped to [spacebar] as is convention in the majority of music apps. This would help those w/o mulitmedia keyboards and help Exaile better adhere to convention.

Steve Dodier-Lazaro (sidi) wrote :

The keys should be something such as Ctrl+# or Shift+Ctrl+#, but Space is used for typing spaces in the search fields so I recommend against linking shortcuts to it.

Changed in exaile:
importance: Undecided → Wishlist
milestone: none → 0.3.1
status: New → Confirmed
Aren Olson (reacocard) wrote :

perhaps we can only bind space in certain widgets, similarly to how left and right arrows only seek when the playlist has focus.

jay armstrong (jayarmstrong) wrote :

... or ignore Space while searching since you won't generally start a search with a space character.

Aren Olson (reacocard) wrote :

> ... or ignore Space while searching since you won't generally start a search
> with a space character.

It's not just search fields, other widgets (eg. buttons) are also sensitive to space, so we simply can't bind it globally because it would change the semantics of gtk.

And there are quite a few widgets where space has no meaning, which is why I
believe a dedicated shortcut that wouldn't be available half of the time
would be more appropriate.

Aren Olson (reacocard) wrote :

> And there are quite a few widgets where space has no meaning, which
> is why I believe a dedicated shortcut that wouldn't be available half of
> the time would be more appropriate.

Really? Not only is tat wildyly inconsistent ui design, but there really aren't all that many widgets in exaile that are focusable and aren't sensitive to space - the volume control, the collection tree, and the playlist view. Every other main widget in exaile is either sensitive to space, or is not focusable and therefore irrelevant to this argument. Given that we already have one binding that only works when the playlist has focus (left/right for seeking), i think it makes the most sense to implement space for play/pause in a similar manner.

Steve Dodier-Lazaro (sidi) wrote :

This is a typo from me, I of course meant "where space has a meaning". Which means I don't agree to using space since it is already bound by GTK in lists, text entries, menus, tree views, and buttons at least.

Aren Olson (reacocard) on 2010-01-05
Changed in exaile:
milestone: 0.3.1 → 0.3.2
Mathias Brodala (mathbr) wrote :

What’s the status on this one? Since we pretty much pointed out that the Space key won’t be used to prevent confusion, what other exact keys would you like to see mapped to what?

Mathias Brodala (mathbr) wrote :

Space starts, pauses and resumes playback if the playlist is focused. This is as far as we can go without breaking GTK default behavior. Added with r3062.

Changed in exaile:
assignee: nobody → Mathias Brodala (mathbr)
status: Confirmed → Fix Committed
Aren Olson (reacocard) on 2010-07-06
Changed in exaile:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers