Comment 16 for bug 397210

This is probably a packaging issue.

Since we cannot on the target system even having the notification daemon installed, we do not use it by default. In Exaile, we took special care to make sure that it'll run on any system that has gstreamer and gtk+ installed. Gnome is not required.

However, if a distro wants the notify-osd or notify plugins to be enabled by default, it's simply a matter of shipping a default settings file (settings.ini) that has the built in OSD disabled and one of those plugins enabled.

Perhaps the Ubuntu .deb on our website should include this? Unfortunately, this is all we can guarantee, since none of the upstream developers (synic, reacocard, sjohannes) package for any of the distros out there. This is up to them.