Ratings periodically and selectively reset

Bug #147270 reported by revolutio on 2007-09-30
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Exaile
Fix Released
High
Adam Olsen

Bug Description

Running Xubuntu and Exaile has been the most stable music player I've found. I've been running it for about two weeks now with little complication except the following:

A few times I had the suspicion that a rating I had set had been reset to the default 2 stars but I had always dismissed it figuring I had just rated some other song. However, after spending an hour or two updating my ratings (simply setting some at 3 stars instead of 2 and my top favorites at 4) I restarted to discover all the changes had been lost. Oddly a few of the ratings I had assigned a couple days after installing have remained. The ones that remained are a mix of mp3 and m4a as is the rest of my collection. Changes I have made to the artist or song names have been unchanged.

Needless to say I was kind of peeved at this waste of effort, however I was perplexed to find no information on people with similar bugs. Whether this is a legitimate bug or my own fault as a Linux newbie, I'd still be interested in learning the cause and hopefully finding a solution to it.

It seems that very few people actually use ratings in Exaile, so this is
quite possibly a real bug.

revolutio (revolutio) wrote :

Shame, I've found ratings to be really helpful for having a sort of tiered music hierarchy.

Anyway, checked this a few times now and it doesn't seem to reset them whenever I restart or even boot into my Windows XP partition then go back to Xubuntu. While I assume the reset of ratings occurs when I restart, it appears to be something else that instigates it.

revolutio (revolutio) wrote :

Reset again. Same few files are being left alone. I had considered that Xubuntu updates might cause the problem but this time nothing happened apart from my playing Tetris and reading e-books.

Adam Olsen (arolsen) wrote :

I just committed something that may fix it to the trunk and 0.2.11 branches.

Changed in exaile:
assignee: nobody → arolsen
importance: Undecided → High
status: New → In Progress
dezza (dezzadk) wrote :

I can certainly confirm this.. I have set ratings for almost all the songs I came across to make the good ones play more often, but now that I started Exaile the other day, all the ratings where gone? Where are they stored? I would like to watch this file, and copy it for saving purposes.

revolutio (revolutio) wrote :

Been running 2.11 since it came out and no anomalies. I think it was fixed. If this is the case thank you very much for listening to my small voice and keep up the excellent work. I'll do my part to make this player known...

Changed in exaile:
status: In Progress → Fix Released
dezza (dezzadk) wrote :

What? I have 0.2.11 and I just rated a whole album.. I exited Exaile, fired it up again, poof, gone were all my ratings, except for one.. When I open "Highest Rated" it shows alot of songs, no rating.. And didn't even show rating of the only song that successfully was rated from the album..

This certainly isn't fixed!

I started exaile as my normal user on my Linux Workstation, and the albums were scanned and played from a rw mounted share on a Windows XP machine, where all my albums are currently stored.

revolutio (revolutio) wrote :

Scratch that. A significant portion of my songs just reset. Many that were 3 stars were set back to two while some (including some rated 5) showed as having no rating. Certain artists seem to be unaffected while others were completely put at the default 2 stars. Also some albums lost ratings all together.

Adam Olsen (arolsen) on 2007-11-12
Changed in exaile:
status: Fix Released → Confirmed
Adam Olsen (arolsen) wrote :

Please try the latest bzr and let me know if it works better.

Hey there. I've been busy lately and I have first tested the bzr today.

This time none of the playlists will show any songs, although I rescan
library, and check paths and everything.

Only way I can access songs is go to collection and click on them
singlewise.. I also tried to make playlists from collection and try loading
trough playlists after.. Nothing will show in the main window no matter what
I do.

In the time I used the last stable release, I discovered that some files
would hold ratings, others won't I think maybe it has something to do with
the filenames, encodings, or tags? Some of my songs are listed as "Song name
/ Artist / / / / / / / / / / / / /" or something else in collection, like if
they had 10 or more empty ID3-tag spaces.

Regards,
Christoffer.

On Nov 21, 2007 7:58 PM, Adam Olsen <email address hidden> wrote:

> Please try the latest bzr and let me know if it works better.
>
> --
> Ratings periodically and selectively reset
> https://bugs.launchpad.net/bugs/147270
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Best Regards/Venlig Hilsen
Christoffer Aasted (nickname: dezza)

revolutio (revolutio) wrote :

I can't confirm the effectiveness of the new bzr (0.2.12b) for two reasons:
1. The problem is intermittent and since I went 3 weeks before a random portion of ratings got wiped (and the files that did got that weird / / / / / / / / thing), I'm not sure how long before I am certain it is fixed. So unless there is a specific coding issue that is found the fixes can't be verified for a while now.

2. The new bzr doesn't actually show my music. Any of it. The only indications that it exists is the number of songs in the bottom left and the album titles still show up in the left Collections tab. Yeah that kinda needs to get fixed.

Thank you for your continued work.

dezza (dezzadk) wrote :

Sounds really confusing man.

Is your code cluttering up ? Sounds like you're lost here .. I really like
your music player, so I hope you'll find a solution, and find out why the
music disappears from the lists now, remember to save versions after changes
:) So you can track back new errors ..

Regards,
Christoffer.

On Dec 1, 2007 7:49 PM, revolutio <email address hidden> wrote:

> I can't confirm the effectiveness of the new bzr (0.2.12b) for two
> reasons:
> 1. The problem is intermittent and since I went 3 weeks before a random
> portion of ratings got wiped (and the files that did got that weird / / / /
> / / / / thing), I'm not sure how long before I am certain it is fixed. So
> unless there is a specific coding issue that is found the fixes can't be
> verified for a while now.
>
> 2. The new bzr doesn't actually show my music. Any of it. The only
> indications that it exists is the number of songs in the bottom left and
> the album titles still show up in the left Collections tab. Yeah that
> kinda needs to get fixed.
>
> Thank you for your continued work.
>
> --
> Ratings periodically and selectively reset
> https://bugs.launchpad.net/bugs/147270
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Best Regards/Venlig Hilsen
Christoffer Aasted (nickname: dezza)

Dan O'Reilly (oreilldf) wrote :

The music disappearing bug is pretty well documented guys, It's a regression caused by fixing a bug with the Columns for artist, album, title, etc. in the playlist. All you have to do is Go to View->Columns and re-enable them. Also with version control software (like Bazaar) every single change made to any of the code is reversible, so any problems with an update can be rolled back.

davidmoore (davidme) wrote :

I can confirm this bug, so much work spent into sorting music by rating is gone. Very serious. I am running Exaile 0.2.12 Devel. As of Jan 10th/2007

dezza (dezzadk) wrote :

Dan O'Reilly: Well, I tried re-enabling all of those columns .. Nothing worked .. And no matter if we're reinstalling, running devel version, or rescanning .. This bug is hunting us down, and ruining our hours of work of rating music.

Dan O'Reilly (oreilldf) wrote :

My comment was in regards revolutio's comment:
"2. The new bzr doesn't actually show my music. Any of it. The only indications that it exists is the number of songs in the bottom left and the album titles still show up in the left Collections tab. Yeah that kinda needs to get fixed."

and your comment:
"and find out why the
music disappears from the lists now, remember to save versions after changes
:) So you can track back new errors .."

Both of which were talking about music disappearing from the playlist, not the ratings problem.

KDontenville (kevin-keepnet) wrote :

Hi, using 2.11 in Gutsy I get the information tag working fine but the blacklists and ratings still drop out. I think the blacklist issue was resolved in bzr version but it was a choice of Exaile crashing when pulling up info on a track, blacklists being wiped, and/or ratings being lost. Any progress would be great. I love Exaile and will keep using it but some music centred users in my household want XP and Winamp back... How short memories are! ;-)

Adam Olsen (arolsen) wrote :

Is this issue still a problem for people?

Changed in exaile:
status: Confirmed → Incomplete
dezza (dezzadk) wrote :

Yes, just as big a problem as before, the bug makes the ratings useless.

Cody Erben (erben22-launchpad) wrote :

Confirming this is still an issue in 0.2.14devel. Previously, I setup my library, and disabled automatic scanning, and was happy happy ratings land, and never had an issue. Then I rolled over to using Exaile more frequently, and setup automatic scanning to pickup new tunes that might be added into my library folders, and my top rated and other smart playlists using the ratings field stopped.

Just tested to confirm, and indeed the automatic library scan is causing the issue for me (went back to the hardy package, and confirmed it happens there as well):
  - tag 10 tracks with a rating of 5
  - create a smart playlist that selects tracks of rating of at least 5
  - view playlist, 10 expected tracks show up
  - restart exaile, reload smart playlist, confirm 10 expected tracks appear
  - Hop into tools, and choose Rescan collection
  - Wait a minute or two
  - reload smart playlist, and no songs appear
  - Viewing 10 songs in library, the rating field has been reset

For my use, next to genre, track ratings are the next most useful tag I use in my collection of playlists.

Taking a cursory glance at the music.db layout, this issue might be related to rating information being stored in the database fields, but not coming from ID3 tabs. When a track is scanned, perhaps the ID3 info is parsed and updated in the DB, with the rating field being reset to a default value. Next step (python noob here) would be to take a look to see if there is a way to preserve the previous rating setting in the database when a track is rescanned.

Dafydd Crosby (dcrosby) wrote :

I don't use the ratings myself, but has anyone seen this behaviour in the trunk (0.3) ?

utkatubuntu (just-utkarsh) wrote :

I ve lost all my ratings for nothing but just a ubuntu restart and adding a information tag in
 (0.2.14)
not tested 0.3 though any way to fix this?

Steve Dodier-Lazaro (sidi) wrote :

Does anyone who used to have problems with disappearing ratings still have them with Exaile 0.3.0a2 ? (you can use 'bzr branch lp:exaile' to get the latest version).

KDontenville (kevin-keepnet) wrote :

can't tell yet, when I follow the bzr install route I get
bzr: ERROR not a branch: "/home/myuser/".

The deb package listed for Ubuntu reports as ver 2.99 when installed so I cant be sure what I am using!

Steve Dodier-Lazaro (sidi) wrote :

0.2.99.x is 0.3.0 alpha x, we're on Alpha 3 currently. I didn't have any ratings reset problems in the last month, so I think this is fixed. If any of the people above could confirm whether or not it's fixed for them, thanks in advance.

utkatubuntu (just-utkarsh) wrote :

never happened again after Exaile 0.3so i think it's fixed

dezza (dezzadk) wrote :

I switched from Exaile to Amarok just because of this bug, it's been here for AGES and been haunting me on my email (Forgot to unsubscribe)

I am really surprised that you first got around it now.

I also found out that music collections over 100.000 songs should NOT be in a Python player without external DB support.

Steve Dodier-Lazaro (sidi) wrote :

It's been fixed a very very long time ago, apparently, dezza. This bug
indeed never happened with the new database in 0.3.0, as far as I know.

About huge music collections, could you please try Exaile 0.3.0 and propose
clues for improvement of the built-in database ? If you think it requires
external DB support, could you please document what you have in mind so that
developers can have a look at it and decide whether it's feasible and when
this can be implemented ? Thanks in advance.

dezza (dezzadk) wrote :

Hello Steve.

I really liked Exaile but was forced to quit it because of my large music
collection.

I recommend SQLite or MySQL .. MySQL for the high-performance and SQLite for
quick/n/dirty DB.

PostgreSQL is not really suited because it has alot of operations that
doesn't really belong in a music collection and MySQL can do the most
popular fine with InnoDB (like ForeignKey and Transactions) ..

I hope you're going to implement it, the new Amarok2 I didn't like that much
(Still running 1.4.10)

Regards,
dza

On Fri, Jul 24, 2009 at 6:27 PM, Steve Dodier <email address hidden> wrote:

> It's been fixed a very very long time ago, apparently, dezza. This bug
> indeed never happened with the new database in 0.3.0, as far as I know.
>
> About huge music collections, could you please try Exaile 0.3.0 and propose
> clues for improvement of the built-in database ? If you think it requires
> external DB support, could you please document what you have in mind so
> that
> developers can have a look at it and decide whether it's feasible and when
> this can be implemented ? Thanks in advance.
>
> --
> Ratings periodically and selectively reset
> https://bugs.launchpad.net/bugs/147270
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Best Regards/Venlig Hilsen
Christoffer Aasted (nickname: dezza)

Steve Dodier-Lazaro (sidi) wrote :

SQLite was in use in Exaile 0.2.14, with the results we know. In the end the
new database system is lighter and faster. Did you try Exaile 0.3 yet ?

dezza (dezzadk) wrote :

I am currently using my laptop, but I will try to use it when I get back,
np.

On Fri, Jul 24, 2009 at 8:46 PM, Steve Dodier <email address hidden> wrote:

> SQLite was in use in Exaile 0.2.14, with the results we know. In the end
> the
> new database system is lighter and faster. Did you try Exaile 0.3 yet ?
>
> --
> Ratings periodically and selectively reset
> https://bugs.launchpad.net/bugs/147270
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Best Regards/Venlig Hilsen
Christoffer Aasted (nickname: dezza)

Steve Dodier-Lazaro (sidi) wrote :

This bug doesn't happen in the 0.3 series, so i'm closing it. Set it to 'New' if it happens again (normally, all the things that could have caused this are properly implemented in 0.3 so it shouldn't happen).

Changed in exaile:
status: Incomplete → Fix Committed
Aren Olson (reacocard) on 2009-08-24
Changed in exaile:
status: Fix Committed → Fix Released

I can now confirm that this is happening occasionally to me with Exaile 0.3.2.1
A few random songs will loose play count and ratings. I thought I've seen it a few times but this time I'm absolutely sure I listened to this certain song yesterday and rated it.
I've only noticed this after shutting down Exaile and restarting later.

Igel Kuhn (ich-freak) wrote :

Still happening for me with Exaile 0.3.2.2 Python 2.7.2 Linux 3.1.6 (gentoo linux x64)

Rating get cleared every other day. Sometimes some songs' ratings remain, other times all get cleared.

Dr. John (john-roshi) wrote :

I still can't get ratings to persist with Exaile 0.3.2.1 Ubuntu 10.04.

I can rate a song, close the playlist, reopen the playlist, and the ratings appears.
BUT, if I close Exaile and restart it, the playlist opens and there are NO ratings.

Steps to reproduce:
Start Exaile.
Create a custom playlist. Observe no songs are rated.
Rate a song by clicking one or more stars.
Right-click on the playlist tab and chose "save changes to playlist"
Close the tab for the playlist.
Reopen the playlist. Observe the correct star rating.
Quit Exaile.
Start Exaile.
Observe the playlist tab opens correctly, but the song previously rated has no star rating.

Mathias Brodala (mathbr) wrote :

Please re-try with the latest RC2 of 3.3.0.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers