Sort plugins list after populating it

Reported by Mathias Brodala on 2007-09-08
10
Affects Status Importance Assigned to Milestone
Exaile
Low
Johannes Sasongko

Bug Description

The plugins list on the "Installed" and "Available" tabs in the plugin manager should be sorted once more after they have been populated. The reason is that translated plugin titles can vary drastically and require a different sorting order.

Mathias Brodala (mathbr) on 2007-09-08
Changed in exaile:
importance: Undecided → Low
Mathias Brodala (mathbr) wrote :

Since I didn’t seem to make myself clear enough, here’s a screenshot showing the issue:

http://download.noctus.net/gallery/caps/exaile_plugins_available_list_translated.png

As you can see is the plugin list not sorted alphabetically anymore which makes finding plugins quite difficult.

Changed in exaile:
importance: Low → Wishlist
status: New → Confirmed
Mathias Brodala (mathbr) wrote :

This is not a wishlist item but a usability bug.

Changed in exaile:
importance: Wishlist → Low
Adam Olsen (arolsen) wrote :

Fix committed in r1345

Changed in exaile:
assignee: nobody → arolsen
status: Confirmed → Fix Committed
Mathias Brodala (mathbr) wrote :

The plugin list still is not sorted correctly. (No difference in fact.)

Changed in exaile:
status: Fix Committed → New
Adam Olsen (arolsen) wrote :

It works for me - screenshot attached.

Mathias Brodala (mathbr) wrote :

Well of course. You’re using an English locale so you won’t notice a wrong sorting. Try using the German locale and you’ll see what I posted above.

You can get my latest translation from #136610

Adam Olsen (arolsen) on 2007-09-11
Changed in exaile:
status: New → Fix Committed
Mathias Brodala (mathbr) wrote :

Real fix was committed in r1350 now.

Changed in exaile:
status: Fix Committed → Fix Released
Steve Dodier-Lazaro (sidi) wrote :

Broken in 0.3.0

Changed in exaile:
milestone: none → 0.3.0
status: Fix Released → Confirmed
Johannes Sasongko (sjohannes) wrote :

Fixed. The bug was actually visible in English as well, e.g. the mass storage and screensaver pause plugins were sorted by their directory names instead of their human-readable names.

Changed in exaile:
assignee: Adam Olsen (arolsen) → Johannes Sasongko (sjohannes)
status: Confirmed → Fix Committed
Aren Olson (reacocard) on 2009-08-24
Changed in exaile:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers