Tracks from directory added to playlist in random order

Reported by Adam Olsen on 2007-08-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Exaile
Medium
Mathias Brodala

Bug Description

When dragging a directory containing music tracks and dropping it on the playlist, the tracks are added, but in a random order. (But strangely in the same random order every time. And only for one directory each. Every directory has its own random order.)

Dragging and dropping the tracks directly adds them in the correct order.

This ticket was migrated from the old trac: re #654

Mathias Brodala (mathbr) on 2007-09-05
Changed in exaile:
importance: Undecided → Medium

can't reproduce. Could it be that some of the original poster's tracks had empty/inconsistent ID3 tags which made the order appear random?

Mathias Brodala (mathbr) wrote :

No, all tags are fine here. What file manager did you use?

I can confirm this in 0.2.11, using nautilus.

Mathias Brodala (mathbr) wrote :

Seriously, this fix makes me laugh. ;-)

Changed in exaile:
assignee: nobody → mathbr
milestone: none → 0.2.12
status: New → Confirmed
Changed in exaile:
status: Confirmed → Fix Committed
Matthias (m-kaeppler) wrote :

I see this has been fixed in 0.2.12?

I think it has regressed then, because the bug is still there in 0.2.13.

Matthias (m-kaeppler) wrote :

just want to add: I think this bug is rather serious, because you cannot add more than one album at a time to the playlist without screwing up the play order completely (at least sorting is stable: you can first sort by tracknumber across several albums, and then by album, but still, this is super-duper-annoying).

Mathias Brodala (mathbr) wrote :

The patch apparently was commited after 0.2.13 has been released. Just download my patch and apply it manually.

Matthias (m-kaeppler) wrote :

That did not work for me. I even recompiled the file, but the tracks are still added in seemingly random order considering the track number (it seems to sort them by Artist now...)

Satti (satya-461) wrote :

I don't face this bug in 0.2.14. It loads them based on the track number tag if it exists

Changed in exaile:
status: Fix Committed → Fix Released

The same happens to me when dragging albums from the library sidepanel into the playlist although I did care for my files being tagged correctly. I'm using Exaile 0.3.0.1 on Ubuntu 9.04 – I don't know when 3.0.1 was exactly released, so the fix might already be on the way?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers