Access shortcuts for alphabetical grouping

Reported by Adam Olsen on 2007-08-30
2
Affects Status Importance Assigned to Milestone
Exaile
Wishlist
Unassigned

Bug Description

To make full use of the new alphabetical grouping a way to directly jump to a group is needed IMHO. I have two possible implementations in mind:

 1. If the collection pane is focussed, entering a character would jump to the group matching, if any.
 2. Global hotkeys like [Ctrl]+[Shift][$character] could do the same as above.

An advantage of the former would be that it does not clutter the global namespace of possible hotkeys, so those could be used for something else later. Contrary to this would the second implementation not require having to focus the collection pane. This would be rather convenient

This ticket was migrated from the old trac: re #583

Adam Olsen (arolsen) on 2008-04-09
Changed in exaile:
importance: Undecided → Wishlist
status: New → Confirmed
Mathias Brodala (mathbr) wrote :

Due to GTK having an automatic interactive search 1) works perfectly fine. Focus the collection list and start typing.
Global hotkeys won’t be implemented for this since they’d pollute the namespace and take away all options from plugins and the like.

Changed in exaile:
milestone: none → 0.3.2
status: Confirmed → Fix Committed
Aren Olson (reacocard) on 2010-07-06
Changed in exaile:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers