Automatic library scan does not work

Bug #135666 reported by François Févotte on 2007-08-29
4
Affects Status Importance Assigned to Milestone
Exaile
Fix Released
High
Adam Olsen
exaile (Debian)
Fix Released
Unknown

Bug Description

Hello.

This is a transfer from old bug #770 (http://64.251.22.233/trac/ticket/770).
This bug has also been reported by a Debian user as Debian bug #436242 (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=436242).

In Edit->Preferences->Library one can set a time for exaile to rescan the music library for new music added. However, whatever value is set there, the library is never automatically rescanned.

I have been able to steadily reproduce this behaviour.

Thanks,
  François

description: updated
Adam Olsen (arolsen) on 2007-08-29
Changed in exaile:
assignee: nobody → arolsen
importance: Undecided → High
status: New → Confirmed
Changed in exaile:
status: Unknown → Confirmed
Adam Olsen (arolsen) wrote :

Fix committed in r1317

Changed in exaile:
status: Confirmed → Fix Committed
Roman (roman-koller) wrote :

Hi Adam,

Rescanning still doesn't work well.
Actually, the library rescan is done but the list on the GUI is not being refreshed. So, a manual rescan has to done again to get the new songs.

I'm using BZR revision from 2008-01-22 04:34:12 +1000.

Thank you,
Roman

Jordan Reese (jordanmreese) wrote :

Roman, i believe that is an independent bug, because for me, the library does not update reguardless of weather the scan is manual or automatic, exaile has to be restarted for new songs to show up.

reacocard (reacocard) on 2008-10-02
Changed in exaile:
status: Fix Committed → Fix Released
Changed in exaile (Debian):
status: Confirmed → Fix Released
Kip Warner (kip) wrote :

When I go to Edit->Preferences, I do not see a tab or settings area for Library. Using Exaile 0.3.2.2 on Precise (amd64).

Mathias Brodala (mathbr) wrote :

Go to Edit -> Collection.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.