Support Compilation Albums

Bug #135618 reported by reacocard on 2007-08-29
68
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Exaile
Confirmed
Wishlist
Unassigned
reacocard (reacocard) wrote :
Changed in exaile:
status: New → Invalid
Johannes Sasongko (sjohannes) wrote :

(Reopening, because blueprints don't seem to allow discussion.)

Changed in exaile:
importance: Undecided → Wishlist
status: Invalid → Confirmed
Johannes Sasongko (sjohannes) wrote :

My preferred way to fix this is to actually implement "album artist" tag handling; the user then must enter an album artist on every album that they want to mark as compilation. This also solves the problem that some albums actually have a named album artist (e.g. the composer). That way, whether they enter an artist involved in the whole album or simply "Various Artists" is not important for the player.

The problem is that a lot of tag formats don't have a standard field for this. The most thorough list I can find is the one used by PicardQt (see [1]). BMPx seems to stick to this, and my limited research shows that it's likely a superset of what some other players (iTunes, WMP, Amarok) use.

If I remember correctly, Ex Falso has an "albumartist" tag field. I'd be interested to know whether this works with other apps.

[1]http://wiki.musicbrainz.org/PicardQt/TagMapping

reacocard (reacocard) on 2008-03-11
Changed in exaile:
milestone: none → 0.3.0
Timon_and_Pumba (timonterbraak) wrote :

Also note the default sorting in the playlist window. With 0.2 and the current 0.3 status, the playlist is first sorted by Artist.
So when a compilation album is added to the playlist window, the tracks are mixed up. I would prefer to sort the tracks to the track number by default.

David Pack (david.pack) wrote :

I would recommend that we allow the user to select which tag they want to be used for album artist. For example, Exaile could read and write the foobar2000 style (TXXX:Album Artist (I think)), iTunes/WMP/whatever style (TPE2 (usually called Band/Performer)), or some other kind. Allowing only one way would frustrate many people (I use foobar2000 on Windows, so using TPE2 wouldn't work out well for me.)

Of course, we should choose a default that would work for most people (probably TPE2).

Album Artist tag
---------------------
[x] Read and write album artist tag in iTunes/WMP/Amarok format.
[ ] Read and write album artist tag in foobar2000 format.

I really hope that a future version of id3 sorts this mess out.

ZAP (michaelzap) wrote :

This is absolutely key to the usability of the Exaile library for people (like me) with a lot of Various Artists discs, and could be an important factor in getting people (like me) who are jumping ship from Amarok to migrate here. I strongly suggest an intermediate fix before the 0.3.0 release. The fix could be in the form of a plug-in rather than proper integration of this feature.

An alternative work-around would be just to allow for library sorting by any other tag and allow users to determine which tags to use. That way I could group/organize my library by Album Artist -> Artist -> Album -> Tracks but someone else could use a different scheme if desired. I would think this would be easier to develop as a plug-in and also wouldn't affect the ongoing integrated resolution that will hopefully be present in 0.3.0.

Is there a plug-in developer who might be willing and able to develop this now so that we don't need to wait for wishlist items to be addressed in 0.3.0?

reacocard (reacocard) on 2009-07-12
description: updated
mezcla (mezcla) wrote :

Whoa glad to see a blueprint on this. Lack of compilation sorting is what kept me at amarok for so long and I look forward to the feature. As far as how to implement it, I have no preference and would even mark compilations by hand if necessary. I just want my artist browser to be uncluttered.

reacocard (reacocard) wrote :

We've gone as far as implementing this in 0.3.0 as we're going to before release, deferring remainder to 0.3.1.

Changed in exaile:
milestone: 0.3.0 → 0.3.1
Thomas Zander (thomas-e-zander) wrote :

Because I needed a preferences pane for "collection"-related config options in order to work on bug 417146, I have implemented a "collection" pane for preferences.
In this pane, I have also implemented a check box to enable or disable compilation detection heuristics as requested in xl/collection.py, line 555:

# TODO: make this optional, probably in the advanced configuration
# editor
# check for compilations
if not settings.get_option('collection/file_based_compilations', True):
    return

This part should be ready for merge from:
lp:~thomas-e-zander/exaile/artist_strip

Nicholas Shatokhin (robotex) wrote :

I'm sorry, but it still does not work

reacocard (reacocard) wrote :

Thomas, could you please separate out your prefs changes into a patch? I don't want to merge half of a fix for bug 417146 in the process of getting one additional feature. Otherwise, merging the prefs changes will have to wait until your entire branch is ready for merge.

reacocard (reacocard) on 2010-01-05
Changed in exaile:
milestone: 0.3.1 → 0.3.2
reacocard (reacocard) on 2010-06-11
Changed in exaile:
milestone: 0.3.2 → 0.3.x
matejcik (matejcik) wrote :

here is a patch that implements a new way of sorting collections, called "Album Artist" - sorts by album artists where present and artists where missing.

this also fixes the bug where album artists would jump into "Artist" mode, so you get for example "DJ Koogi" in "0-9", because a track from his compilation is by "2 Cities"
and also a related bug, where this specific entry is supposed to contain one track but instead contains the whole album

it simply makes the Collection feature better overall :)

ZAP (michaelzap) wrote :

Excellent! When can we expect this patch to make it into the release?

reacocard (reacocard) wrote :

@ZAP: Just because a patch is submitted does NOT mean it will be accepted. It must be reviewed and (probably) revised first. When there is progress to report, it will be added to this bug. Until then, be patient.

ZAP (michaelzap) wrote :

I can be patient, but I can't hide my excitement that Exaile is finally going to have the main feature I've been missing (since the death of Amarok 1.4).

matejcik (matejcik) wrote :

ping

is there a problem with my patch? something i can do? come up with unit tests perhaps?

Nicholas Shatokhin (robotex) wrote :

OMG, just see how it realized in Clementine Player.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers