evolution crashed with SIGABRT in __libc_message()

Bug #1194005 reported by Arne Meyer on 2013-06-24
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Evolution Indicator
Undecided
Unassigned
evolution-indicator (Ubuntu)
Medium
Unassigned

Bug Description

Description: Ubuntu Saucy Salamander (development branch)
Release: 13.10

evolution:
  Installiert: 3.8.2-1ubuntu2
  Installationskandidat: 3.8.2-1ubuntu2
  Versionstabelle:
 *** 3.8.2-1ubuntu2 0
        500 http://de.archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages
        100 /var/lib/dpkg/status

Evolution should start and show its main window
Evolution crashes right showing its main window while reading the mail folders

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: evolution 3.8.2-1ubuntu2
ProcVersionSignature: Ubuntu 3.9.0-7.15-generic 3.9.7
Uname: Linux 3.9.0-7-generic x86_64
ApportVersion: 2.10.2-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Mon Jun 24 07:47:59 2013
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/evolution
InstallationDate: Installed on 2011-10-06 (626 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427)
MarkForUpload: True
ProcCmdline: evolution
Signal: 6
SourcePackage: evolution
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 e_plugin_lib_enable () from /usr/lib/evolution/3.8/plugins/liborg-freedesktop-evolution-indicator.so
Title: evolution crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to saucy on 2013-06-18 (5 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare

Arne Meyer (am-v) wrote :
information type: Private → Public

StacktraceTop:
 __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0x7ff28ac6b860 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:199
 malloc_printerr (action=3, str=0x7ff28ac6bbd8 "munmap_chunk(): invalid pointer", ptr=<optimized out>) at malloc.c:4902
 update_accounts () at evolution-indicator.c:494
 e_plugin_lib_enable (ep=<optimized out>, enable=<optimized out>) at evolution-indicator.c:621
 plugin_lib_loadmodule (plugin=plugin@entry=0x7ff290070470) at e-plugin-lib.c:84

Changed in evolution (Ubuntu):
importance: Undecided → Medium
summary: - evolution crashed with SIGABRT in raise()
+ evolution crashed with SIGABRT in __libc_message()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution (Ubuntu):
status: New → Confirmed
Henk Huitema (henk-huitema) wrote :

Affects me too, in 13.04, after upgrading.

Fabio Marconi (fabiomarconi) wrote :

still affecting in saucy too

tags: added: raring
Arne Meyer (am-v) wrote :

Last Update from today doesn't help anything in saucy

Fresh install Ubuntu 13.10 and evolution was parctically unusable. I uninstalled evolution-indicator and now it is usable...

affects: evolution (Ubuntu) → evolution-indicator (Ubuntu)
Changed in evolution-indicator (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-indicator - 0.2.20-0ubuntu13

---------------
evolution-indicator (0.2.20-0ubuntu13) trusty; urgency=medium

  * debian/patches/evolution-indicator-eds3.6_v2.patch:
    - use correct GList type, should fix segfault issues,
      thanks Xavier Claessens (lp: #1194005)

  [ Iain Lane ]
  * Build-Depend on evolution 3.10
 -- Sebastien Bacher <email address hidden> Mon, 03 Feb 2014 16:28:00 +0000

Changed in evolution-indicator (Ubuntu):
status: Fix Committed → Fix Released

Still a problem in trusty (version 0.2.20-0ubuntu13).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers