Evolution address book has quit unexpectedly

Bug #562564 reported by Joshua Hoover on 2010-04-13
68
This bug affects 13 people
Affects Status Importance Assigned to Milestone
evolution-couchdb
High
Rodrigo Moya

Bug Description

Running all the latest Lucid updates including evolution-couchdb 0.4.5-0ubuntu1 and Chad's PPA with desktopcouch 0.6.4-0ubuntu1~proposed2~chad0.

Steps to reproduce:

1. Open Applications->Office->Evolution Mail and Calendar
2. Click on "Contacts" in left pane
3. Click on "Ubuntu One" address book
4. Click "New" button to create new contact

Result: Error occurs, "Your contacts for file:///home/jhoover/.evolution/addressbook/local/system will not be available until Evolution is restarted."

Expected result: Window to create new contact appears

Joshua Hoover (joshuahoover) wrote :

Crash file

Changed in evolution-couchdb:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Rodrigo Moya (rodrigo-moya) wrote :

hmm, a crash in gnome-keyring... weird. Do you have the U1 tokens on the keyring, don't you?

Changed in evolution-couchdb:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Rodrigo Moya (rodrigo-moya)
Rodrigo Moya (rodrigo-moya) wrote :

Joshua, can you still replicate this?

Rick Wilke (rick70433a) wrote :

I'm having the same crash, but it occurs when attempting to copy contacts from my personal address book to CouchDB. The first time, 56 contacts copied. The next, after canceling all duplicates, I got to 77. Now it crashes before beginning to copy. I hope I've attached the right file to help with this. Let me know what file you need if this is not the one.

Rodrigo Moya (rodrigo-moya) wrote :

Rick, you mean you're having a crash in gnome-keyring?

On Wed, 2010-05-19 at 08:01 +0000, Rodrigo Moya wrote:
> Rick, you mean you're having a crash in gnome-keyring?
>

Rodrigo -- All I know is I keep getting the attached error messages when I attempt to copy my Personal Address Book to CouchDB Address Book. It happened
the first time after about 55 addresses had copied and the second time after I got to 77 (skipping the duplicates). Now it happens immediately upon attempting to start the copy and no copy steps occur.

This is on a completely new install on a new Netbook computer, I also created a new UbuntuOne account to make sure the existing one with which I had so many synchronization problems a few months ago did not cause future errors.

If you need any files, please advise what you need. If this is a different bug, please advise how to best describe when I report it.

Rick

On Wed, 2010-05-19 at 08:01 +0000, Rodrigo Moya wrote:
> Rick, you mean you're having a crash in gnome-keyring?
>

Rodrigo -- All I know is I keep getting the attached error messages when I attempt to copy my Personal Address Book to CouchDB Address Book. It happened
the first time after about 55 addresses had copied and the second time after I got to 77 (skipping the duplicates). Now it happens immediately upon attempting to start the copy and no copy steps occur.

This is on a completely new install on a new Netbook computer, I also created a new UbuntuOne account to make sure the existing one with which I had so many synchronization problems a few months ago did not cause future errors.

If you need any files, please advise what you need. If this is a different bug, please advise how to best describe when I report it.

Rick

forestcomber (cbrigley) wrote :

I get the same error message when trying to copy all personal contacts from Evolution to Ubuntu One. Using fully updated Lucid.

Error message :

The Evolution address book has quit unexpectedly.

Your contacts for file:///home/garrison/.evolution/addressbook/local/system will not be available until Evolution is restarted.

Same error on a fully updated Lucid and 2 different pc

philinux (philcb) wrote :

I've just started getting this error when just clicking on Ubuntu One contacts. I tried deleting the Ubuntu One contacts and restarting Evoution but then I cant copy any contacts over from Personal.

philinux (philcb) wrote :

Just rebooted and tried to copy all contacts to Ubuntu One address book. 86 contacts produced 86 "Other Error" message panes and The Evolution address book has quit unexpectedly.

Also in /var/log/messages one error 626.282867] evolution-data-[2086]: segfault at 0 ip (null) sp 00007f4bce371778 error 14 in evolution-data-server-2.28[400000+5000]

michal.gregor (michal.gregor) wrote :

I experience this bug in the up-to-date version of Maverick. I can create new contacts but I can neither import contacts, nor copy them from another address book.

Victor Hugo (victorhugo289) wrote :

I have the same problem here, Tomboy notes and the Ubuntu One folder work flawlessly, and my name and e-mail appear on Ubuntu One preferences box.
I noticed Rodrigo mentioned the "Gnome-keyring", I used to see two CouchDB entries in 'Passwords and Encryptions keys', but I recently deleted them along with Ubuntu One entry when trying to create a new Ubuntu one account. But this problem of contacts in Evolution has been there for longer than that.
I first got the "Other Error" message when trying to add a contact, after I removed the CouchDB entries in 'Passwords and Encryptions keys' I got the new error "The Evolution address book has quit unexpectedly", and also that "My URI is incorrect .." and that "the server is unreachable".

Rodrigo Moya (rodrigo-moya) wrote :

There have been no similar reports since Maverick, so assuming this is fixed, please reopen if it still happens for you

Changed in evolution-couchdb:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers