Evince document viewer

Improving navigation in large documents

Reported by Trouilliez vincent on 2005-09-03
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evince
Fix Released
Wishlist
evince (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Feature request :
-----------------

I find myself often consulting large documents/books, with countless
"hyperlinks" in them. Things like : "the function of these bits is detaileld in
table XYZ in page 285", where you want to click on the link to quickly have a
look at the table then resume your reading where you left it 10 seconds earlier.
Basically like the "Back" button does in Web browser. I find this impossible in
evince currently, you have the "previos" page, but it will take you indeed to
the previous page, not the "previously VISITED" page, which is what is needed.
Right now, before clicking on any link, I must look at the page counter before
"jumping", so I can re-enter the page number manually to come back where I left,
a real annoyance (to say the least....) when consulting/browsing big documents.

http://bugzilla.gnome.org/show_bug.cgi?id=169903: http://bugzilla.gnome.org/show_bug.cgi?id=169903

Changed in evince:
status: Unconfirmed → Confirmed
status: Unconfirmed → Confirmed
Changed in evince:
status: Unconfirmed → Confirmed
Changed in evince:
assignee: seb128 → desktop-bugs
Changed in evince:
status: Confirmed → Triaged
Liam O'Reilly (aliam13-2) wrote :

This still has not been addressed and would be a very useful feature that greatly improves usability.

Liam O'Reilly (aliam13-2) wrote :

I just found out this has been addressed. There is a back button available in the toolbar which provides the functionality. However this is not in the menu, thus hard to find. Also a key binding is also not possible.

Russell Sears (sears) wrote :

The toolbar button does not address this bug. It does not manage pages as a stack. I think it is based upon some web-browser user interface work that displayed the title of recently visited pages in a drop down list, based upon when the page was viewed. This is a reasonable way to present a browser history.

However, under evince, the drop down menu often displays page numbers, since pages in pdf files do not have titles. Worse, the list is presented in a mysterious order. Surely, any user interface that requires the user to remember which page or chapter contained a previously clicked link is broken.

Regardless of whether the current evince behavior is "better" than standard web browser interfaces (see upstream bug), gnome should standardize on a single browsing paradigm, and Nautilus provides a reasonable user interface. However, nautilus provides a breadcrumb bar, and it's not clear that a breadcrumb bar would be useful with evince; in practice, it would contain a bunch of page numbers or section headings.

The current situation introduces a non-standard set of navigation primitives, and still (after 4 years) does not support alt-left. Also, using the mouse to navigate backwards in this UI is awkward. In the best case, following a link backwards requires two mouse clicks. However, after you have clicked a few links, you have to search for the link (page number) you want in an apparently randomized list.

There was some debate over the correct semantics for a back button upstream a few years ago. Xpdf only pushes things onto the stack when links are clicked; it does exactly what a web browser does. This seems like the right approach. Also, the debate over web browser back button user interfaces has evolved a bit since this bug was filed. Perhaps the current 'back' toolbar button could be replaced with one that clones firefox's interface.

Changed in evince:
importance: Unknown → Wishlist
Changed in evince:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.