Bootstrap OPAC: Login form tabbing and focus

Bug #1909144 reported by Terran McCanna
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.6
Undecided
Unassigned
3.7
Undecided
Unassigned

Bug Description

In 3.6 Bootstrap OPAC:

After entering the barcode/user name, normal expected behavior would be to tab to the password field, but because of the way the fields are laid out, you need to tab 3 times to get to the password field. A little tweaking of this could improve the usability.

(Note that there are two login forms - one on the page, one in a modal.)

Garry Collum (gcollum)
Changed in evergreen:
status: New → Confirmed
tags: added: bitesize
Revision history for this message
Terran McCanna (tmccanna) wrote :

Also (from Galen):

- When you open it, focus is not set anywhere. Focus ought to be given to the card number field.

Galen Charlton (gmc)
summary: - Bootstrap OPAC: Login form tabbing
+ Bootstrap OPAC: Login form tabbing and focus
Changed in evergreen:
assignee: nobody → Terran McCanna (tmccanna)
Revision history for this message
Terran McCanna (tmccanna) wrote :

My proposed fix is at:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/mccanna/lp1909144_login_tabbing

This adds autofocus to the user name field as well as improving the tab order.

When testing, be sure to test both the login modal (by clicking on My Account on the upper right) as well as the embedded login form at /eg/opac/login

Changed in evergreen:
assignee: Terran McCanna (tmccanna) → nobody
tags: added: pullrequest
Revision history for this message
Elaine Hardy (ehardy) wrote :

Cursor is autofocused to the card number/user name box and one tab moves to the password entry. in both my account and /eg/opac/login

I have tested this code and consent to signing off on it with my name, Elaine Hardy and my email address, <email address hidden>.

Jason Boyer (jboyer)
Changed in evergreen:
assignee: nobody → Jason Boyer (jboyer)
Revision history for this message
Jason Boyer (jboyer) wrote :

YAAYY. Works for me, pushed to master through rel_3_6 because I consider this a usability bug. Thanks Terran and Elaine!

Changed in evergreen:
status: Confirmed → Fix Committed
milestone: none → 3.8-beta
assignee: Jason Boyer (jboyer) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers