Acq PO Search cancel reason column only shows ID

Bug #1906825 reported by Tiffany Little
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned
3.7
Low
Unassigned

Bug Description

3.6+

In the new Purchase Order Search, the column for Cancel Reason only shows the ID of the cancel reason and not the label. It should show the label instead.

summary: - Acq PO Search cancel reason only shows ID
+ Acq PO Search cancel reason column only shows ID
Changed in evergreen:
status: New → Confirmed
Revision history for this message
Tiffany Little (tslittle) wrote :
tags: added: pullrequest
Revision history for this message
Chrisy Schroth (cschroth) wrote :

Tested on https://festivus.evergreencatalog.com/eg/staff

PO number 2 now has 2 canceled items. Both are showing valid reasons, not the ID of the reason.

Revision history for this message
Chrisy Schroth (cschroth) wrote :

I have tested this code and consent to signing off on it with my name, Chrisy Schroth and my email address, <email address hidden>.

tags: added: signedoff
Changed in evergreen:
milestone: none → 3.6.3
Changed in evergreen:
milestone: 3.6.3 → 3.6.4
Jane Sandberg (sandbej)
Changed in evergreen:
importance: Undecided → Low
Revision history for this message
Jane Sandberg (sandbej) wrote :

Works great. Thanks, Tiffany and Chrisy! Pushed to rel_3_6, rel_3_7, and master.

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers