Angular staff catalog should display e-resource links

Bug #1881607 reported by Bill Erickson
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.4
Medium
Unassigned
3.5
Medium
Unassigned
3.7
Medium
Unassigned

Bug Description

Evergreen 3.5 / wishlist

The Angular staff catalog currently does not display e-resource links on the record detail page.

See for example concerto record 208 in the traditional catalog: /eg/staff/cat/catalog/record/208

Revision history for this message
Bill Erickson (berick) wrote :

Branch pushed:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1881607-ang-cat-eresource-links

To test in concerto, navigate to: /eg2/staff/catalog/record/208

Note the links display in the bib summary area along the top (which may require expanding).

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.next
assignee: Bill Erickson (berick) → nobody
Bill Erickson (berick)
Changed in evergreen:
milestone: 3.next → 3.6-beta
Revision history for this message
Rogan Hamby (rogan-hamby) wrote :

I'm getting a merge conflict as of this morning's master, specifically with

Open-ILS/src/eg2/src/app/share/catalog/bib-record.service.ts
Open-ILS/src/eg2/src/app/staff/catalog/record/record.component.ts

So, I'm going to mark this needsrepatch.

tags: added: needsrepatch
removed: pullrequest
Revision history for this message
Bill Erickson (berick) wrote :

Thanks, Rogan. Rebasing...

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :
tags: added: pullrequest
removed: needsrepatch
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
milestone: 3.6-beta → 3.next
Changed in evergreen:
assignee: nobody → Christine Morgan (cmorgan-z)
Revision history for this message
Christine Morgan (cmorgan-z) wrote :

Tested logged in as BR1, using concerto record 208 and a record I created from scratch.

For 856 fields without a $9, links displayed correctly for both a single link and for multiple links.
- Subfield z and 3 both appeared as text with the URL displaying as the link.
- Subfield y displayed as the link with no display of the URL.
- Links display in the order in which they appear in the bibliographic record.

However, links failed to display for 856 fields which contained a subfield 9. I tested with subfield 9's for both CONS and BR1. These should display in alpha order by shortname.

Changed in evergreen:
assignee: Christine Morgan (cmorgan-z) → nobody
Bill Erickson (berick)
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :
Bill Erickson (berick)
Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
assignee: nobody → Christine Morgan (cmorgan-z)
Michele Morgan (mmorgan)
Changed in evergreen:
milestone: 3.next → 3.6-beta2
importance: Wishlist → Medium
Revision history for this message
Christine Morgan (cmorgan-z) wrote :

Thanks Bill! I've retested and see that the located URI's are now displaying. Yay!

But, now that located URI's are displaying, I've come across an issue with the opac.located_uri.act_as_copy global flag. Enabling the global flag appears to have no effect on when the located URI's display.

Changed in evergreen:
assignee: Christine Morgan (cmorgan-z) → nobody
Revision history for this message
Bill Erickson (berick) wrote :

Thanks, Christine.

I'm tweaking the code to leverage the existing logic for handling the setting...

Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :

New rebased branch pushed that leverages evergreen.located_uri() (which checks the opac.located_uri.act_as_copy global flag) . Note there is a SQL update in this branch.

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1881607-ang-cat-eresource-links-v4

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
assignee: nobody → Christine Morgan (cmorgan-z)
Revision history for this message
Christine Morgan (cmorgan-z) wrote :

Thanks Bill! This looks good to me!

I have tested this code and consent to signing off on it with my name,
Christine Morgan and my email address,<email address hidden>.

Changed in evergreen:
assignee: Christine Morgan (cmorgan-z) → nobody
tags: added: signedoff
Galen Charlton (gmc)
Changed in evergreen:
milestone: 3.6-beta2 → 3.6-rc
Galen Charlton (gmc)
Changed in evergreen:
milestone: 3.6-rc → 3.6.1
Michele Morgan (mmorgan)
tags: added: angularcatblocker
Changed in evergreen:
milestone: 3.6.1 → 3.6.2
Michele Morgan (mmorgan)
Changed in evergreen:
status: New → Confirmed
Revision history for this message
Elaine Hardy (ehardy) wrote :

Chris applied this to our test server, It only displays the 856 links if they have a second indicator 0 or 1. It does not display them if they have blank, 2 or 8, all valid indicators. Many 856s have indicator 2

Revision history for this message
Bill Erickson (berick) wrote :

Thanks, Elaine. I copied that logic from the TPAC code... But based on your comments (and https://www.loc.gov/marc/bibliographic/bd856.html), perhaps we shouldn't bother checking the 2nd indicator at all, since none of the supported values equate to "don't show me". Sound sane?

tags: removed: pullrequest signedoff
Revision history for this message
Jeff Davis (jdavis-sitka) wrote :

Please see bug 1230380 for active discussion of how to handle the second indicator. Related resources (ind2=2) should perhaps be handled differently from other 856s.

Revision history for this message
Elaine Hardy (ehardy) wrote :

Bill, I think not checking the 2nd indicator is the sane thing.

Revision history for this message
Elaine Hardy (ehardy) wrote :

Looking over the conversation in bug 1230380, perhaps check the 2nd indicator so that a display constant can be generated?

The constant standards for the 2nd indicator:

blank character No information provided
0 Resource
1 Version of resource
2 Related resource
8 No display constant generated

I think having both 0 and 8 not generate a display constant would be good since "no information provided" wouldn't mean anything out of context to the standards.

Revision history for this message
Bill Erickson (berick) wrote :

Something along these lines (attached pic)? I replaced the generic 'Electronic Resource' label with the mapped relationship label. When the indicator-2 value is not 0, 1, or 2, no relationship label is displayed.

Revision history for this message
Elaine Hardy (ehardy) wrote :

I think that looks good.

Revision history for this message
Bill Erickson (berick) wrote :
tags: added: pullrequest
Revision history for this message
Elaine Hardy (ehardy) wrote :

Tested this today and am only seeing 856s for 2nd indicator 0 and 1 and not seeing a display constant.
 See https://terran-master.gapines.org/eg/opac/record/57?query=Cello%20concertos%20Shostakovich&qtype=keyword&locg=1&detail_record_view=0&expand=marchtml#marchtml

Also attaching screen shot in case Terran has to remove the patch.

Revision history for this message
Bill Erickson (berick) wrote :

Elaine, your screenshot suggests you were testing the patron catalog. My patch is for the staff catalog...

Revision history for this message
Bill Erickson (berick) wrote :
Revision history for this message
Elaine Hardy (ehardy) wrote :

The links need to show up in the patron and staff catalog. Sorry for the confusion -- I was looking at both and missed this was just the staff catalog. Should I do a separate bug report for the patron catalog?

Revision history for this message
Bill Erickson (berick) wrote :

Elaine, I think bug #1230380 covers the patron side. Maybe a comment there?

Revision history for this message
Elaine Hardy (ehardy) wrote :

Thanks -- I have commented on that one and don't see any updates on the patch.

Sorry for the confusion.

This does work as expected then. I see all 4 856s with each indicator and the correct display constant.

Revision history for this message
Elaine Hardy (ehardy) wrote :

Tested on PINES concerto server. Works as expected. Signing off with my name, Elaine Hardy. <email address hidden>.

tags: added: signedoff
Changed in evergreen:
milestone: 3.6.2 → 3.6.3
Changed in evergreen:
milestone: 3.6.3 → 3.6.4
Jane Sandberg (sandbej)
Changed in evergreen:
status: Confirmed → Fix Committed
Revision history for this message
Jane Sandberg (sandbej) wrote :

Thanks, Bill, Elaine, and everyone else who has commented on this. Pushed to rel_3_6, rel_3_7, and master.

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers