TTPAC: Patron can request email notification of a hold, despite no email on file

Bug #979933 reported by Michael Peters on 2012-04-12
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Unassigned

Bug Description

Tested in master, probably present in all versions.

If a user places a hold, they are given the option for email notification, even when there is no valid email on file. We should prevent this, as Evergreen isn't psychic!

JSPac provides a message:

(Patron has no configured email address)
(See My Account for setting your email address)

Maybe TTPAC can do the same?

summary: - Patron can request email notification of a hold, despite no email on
- file
+ TTPAC: Patron can request email notification of a hold, despite no email
+ on file
June Stokoe (jstokoe) wrote :

It is also true that a Staff Client user can select "email" for "Hold Notification Format" when there is no email address on the patron record. There should be an error message when the user attempts to save it.

Galen Charlton (gmc) on 2013-03-29
tags: added: bitesize

It looks like in bf52858f4f5da72bf0ddaec6db8720a53ce99969, Thomas Berezansky made some changes that would automatically disable the input box if there is no email address on the account when a hold is made.

To add further to this, I've made another change that not only disables the input box, but rather than displaying

Email Address:

It will now show the text,

No configured Email address. See "My Account" for setting your Email address.

If there is no email found on the account more in-line with Mike Peters suggestion.

Patch can be found here,

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=commit;h=0f8ccb07e65dc44bf4714d7ddd199d430dbc9abc

Changed in evergreen:
assignee: nobody → Steve Callender (stevecallender)
status: Confirmed → Fix Committed
tags: added: pullrequest
Ben Shum (bshum) wrote :

Marking confirmed instead of fix committed as we're still going to review the code. At first glance looks reasonable to me.

Changed in evergreen:
milestone: none → 2.5.0-beta1
status: Fix Committed → Confirmed
assignee: Steve Callender (stevecallender) → Ben Shum (bshum)
Ben Shum (bshum) wrote :

Works for me, thanks Steve! Pushed to master.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Ben Shum (bshum) → nobody
Dan Wells (dbw2) on 2013-11-11
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers