tpac: Records with a located URI cannot be added to a list

Bug #979038 reported by Kathy Lussier on 2012-04-11
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Evergreen
Low
Jeff Godin

Bug Description

EG 2.2 beta2

I am unable to add located URI records to a list via tpac. When you click on "Add to my list," the page reloads, but the link is not replaced with the corresponding "Remove from my list" link. The title is never added to the list. An example record can be found at:

https://testing.evergreen.lib.in.us/eg/opac/record/18149100?query=adventures%20in%20evergreen;qtype=keyword;locg=4

I also tried this with a transcendent record with an 856 field, but had no trouble adding those to a list.

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Low
Kathy Lussier (klussier) on 2013-08-12
tags: added: bookbag lists
Kathy Lussier (klussier) wrote :

I was not able to replicate this problem in two different 2.3 installations. I haven't had an opportunity to test it in 2.4 or master. It might be good to get additional confirmation that it is indeed fixed before marking this as Won't Fixed since 2.2 is no longer getting bug fixes.

Jeff Godin (jgodin) wrote :

I can confirm this on 2.5.1, and would like to point to some discussion on IRC from April, starting here: http://irc.evergreen-ils.org/evergreen/2014-04-24#i_92263

Jeff Godin (jgodin) on 2014-09-08
Changed in evergreen:
assignee: nobody → Jeff Godin (jgodin)
Andrea Neiman (aneiman) wrote :

Testing this on master and I am able to add located URI records to Temporary List (both authenticated and non) as well as a permanent list while authenticated.

I am not seeing the link change to "Remove from My List" in any of the cases; however, I am also not seeing the link change if I add a normal (has-physical-copies) item to the list either. So perhaps there's a different issue here.

Noting that in this test, the global flag "Located URIs will provide visibility behavior identical to copies" is set to TRUE, if that's relevant.

Andrea Neiman (aneiman) wrote :

So when the global flag is set to FALSE, I cannot add a located URI item to a list. In addition, any located URI titles previously added to a permanent list are no longer visible in the list when the flag is set to FALSE. If I set the flag back to TRUE those titles reappear in my permanent list.

Terran McCanna (tmccanna) wrote :

According to Andrea's testing in 2017, this appears to be working as expected based on the global flags. Marking it Won't Fix.

Changed in evergreen:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers