Allow the JSPac and TPac to display both MFHD records and Serial Control/Alternate records,

Bug #963341 reported by Steve Callender on 2012-03-23
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned

Bug Description

Currently the JSPAC and TPAC require a choice to be made on viewing either MFHD records (serial.record_entry ) or Serial Control records (serial.subscription).

To view the Alternate Serial control records, the setting "OPAC: Use fully compressed serial holdings" needs to be set to "TRUE" but the MFHD records will no longer be displayed.

This is a request to allow the JSPac and the TPac the ability to display both types of serials at the same time.

Changed in evergreen:
assignee: nobody → Mike Rylander (mrylander)
Kathy Lussier (klussier) wrote :

Confirmed. I would love to see the option to use the nicer display from the fully compressed serial holdings while also maintaining the ability to display holdings statements from the MFHD. At this point, I assume we only need to worry about doing this in tpac?

Mike, you've been listed in the "assigned to" column for a while. Are you actively working on this or should we change it back to Unassigned?

Changed in evergreen:
status: New → Confirmed
tags: added: serials
Changed in evergreen:
assignee: Mike Rylander (mrylander) → nobody

Removing Mike from the bug because I am certain he is not working on this.

Dan Wells, can I get you to remind me (and everyone) to what extent the TPAC can currently display combinations of "controlled" and "MFHD-based" serials holdings based on the value of the summary_method column of a serial.subscription row related to the bib record being displayed?

I know we've talked before about it, but I need the refresher I'm afraid. What do we have and what's the gap between that and what we want?

Also, I'd appreciate your opinion on whether the following should just be an addendum to this bug report or is a separate bug. The OU setting 'opac.fully_compressed_serial_holdings' is what makes the OPAC try to render expanded individual holdings in the OPAC's "Issues held" tab. A check for this setting in the TPAC Perl layer prevents even retrieving MFHD summaries when the setting is true, which not only prevents their display (intended, at the time the setting was invented anyway) but prevents the MFHD records from being edited or deleted through the Actions for this Record menu in the staff client.

I'm inclined to think this last issue needs an independent bugfix, but then again I could see it in the context of broader work to show both kinds of holdings better. Thanks a ton for any input.

Mike Rylander (mrylander) wrote :

Here's a branch to address Lebbeous' discovery, where we can't edit or remove MFHD if the setting in question is enabled:

http://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/miker/lp963341-allow-mfhd-edit

tags: added: pullrequest
Changed in evergreen:
assignee: nobody → Christine Burns (christine-burns)
Kathy Lussier (klussier) wrote :

Since there is a change to perl code for this bug fix, I'm adding a needstest tag to this bug.

From http://wiki.evergreen-ils.org/doku.php?id=dev:contributing:qa:

A change to database or Perl code that fixes a bug should be accompanied by a Perl (t or live_t) or pgTAP regression test – or by a statement from the patch author explaining why a test is infeasible without significant refactoring. In the latter case, it is expected that an extra signoff be obtained before the patch is merged.

tags: added: needstest

Tested on http://mlnc1.mvlcstaff.org/

- setting "OPAC: Use fully compressed serial holdings" = "TRUE"

Create New MARC record - Women's Health [DBID 239]

Add Subscription / Receive 12 items
Add MFHD
Issues held displays 2 x compressed (not expandable) holdings statement = DESIRED BEHAVIOUR
- 1 for Serial Control view items
- 1 for manual MFHD statement
Able to edit/delete MFHD records = DESIRED BEHAVIOUR

Concern

Unable to make the holdings statement expandable [I am not able to determine if this is caused by the bug fix or another issue]

- "Serials: Default display grouping for serials distributions presented in the OPAC"
set to enum or chron makes no difference

- Distribution "Display Grouping"
set to enum or chron makes no difference

- Compressibility and Expandability (pattern code wizard)
set to Can compress or Expand

Women's Health [DBID 240] no MFHD statement
- Add subscription - unable to make the holdings statement expandable

Unable to make the holdings statement expandable does NOT seem related to bug fix

Tested on http://mlnc2.mvlcstaff.org/

DBID 243

OPAC: Use fully compressed serial holdings = TRUE
Issues held displays compressed holdings statement (cannot expand)

OPAC: Use fully compressed serial holdings = FALSE
Issues held displays compressed holdings statement (cannot expand)

Changed in evergreen:
assignee: Christine Burns (christine-burns) → nobody

I have tested this code and consent to signing off on it with my email address <email address hidden> and name Christine Burns.

tags: added: signedoff
Mike Rylander (mrylander) wrote :

Kathy, as with bug 963341, this is mod_perl code, and so while it's "perl code" it's also not feasibly testable with an automated test, IMHO.

Kathy Lussier (klussier) on 2015-12-16
tags: removed: needstest
Galen Charlton (gmc) on 2016-03-04
Changed in evergreen:
milestone: none → 2.10-rc
Galen Charlton (gmc) wrote :

I've pushed Mike's patch to master and rel_2_10. Thanks, Mike and Christine!

Changed in evergreen:
importance: Undecided → Medium
status: Confirmed → Fix Committed
Galen Charlton (gmc) wrote :

After 2.10 is released, it might be a good idea to revisit this bug and make a new one that covers the issues with expanding and compressing holdings statements.

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers