Option to disallow use of an org unit as a pickup library for holds

Bug #856688 reported by Bill Erickson on 2011-09-22
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

YAOUS that removes an org unit from consideration as a hold pickup library. It's not quite the same as actor.org_unit.opac_visible nor is it the same as can_have_users. It's a way of saying "this org unit is just like any other, we just happen to /not/ want to deliver items to this location"

This setting only affects the OPAC display and does not otherwise affect the display of the org unit in the OPAC. It also has no affect on hold targeting / capturing.

user/berick/org-not-pickup-lib @ working/Evergreen.git

Evergreen 2.2 / OpenSRF 2.0 / Postgres 9.0.4 / Debian Squeeze

Bill Erickson (berick) wrote :

Edit: "This setting only affects the hold pickup lib org unit dropdown and does not otherwise affect the display or behavior of the org unit in the OPAC."

Thomas Berezansky (tsbere) wrote :

A quick note:

This does not currently merge cleanly do to my previous (now merged) work on making the TPac respect the opac visible flag in and of itself.

Also, why shouldn't this functionality be enabled in the JSPac? Or is the goal at this point "stop adding things there because we plan on deleting it as soon as TPac is ready?"

Bill Erickson (berick) wrote :

Thanks Thomas.

I've merged and force-pushed working/user/berick/org-not-pickup-lib

I'll save the JSPac discussion for IRC

Mike Rylander (mrylander) wrote :

hrm... conflicts on master again.

Changed in evergreen:
assignee: nobody → Bill Erickson (erickson-esilibrary)
Bill Erickson (berick) wrote :

Repaired seed data merge conflict and force-pushed topic branch.

Changed in evergreen:
assignee: Bill Erickson (erickson-esilibrary) → nobody
Thomas Berezansky (tsbere) wrote :

Any thoughts on getting this working for the JSPac too?

It was mentioned in IRC:

http://evergreen-ils.org/irc_logs/evergreen/2011-10/%23evergreen.11-Tue-2011.log

Around 12:20-12:30

Bill Erickson (berick) wrote :

+1 to adding it to jspac; I will look into that soon (unless someone beats me to it). Removing pullrequest tag for now.

tags: removed: pullrequest
Galen Charlton (gmc) wrote :

Opening issue again -- do we still care whether it gets ported to jspac?

Galen Charlton (gmc) on 2012-03-27
Changed in evergreen:
milestone: none → 2.2.0beta1
status: New → In Progress
Bill Erickson (berick) wrote :

Ditto Galen's question.. I would love to get this into 2.2. Are there any systems out there running both jspac and tpac in production, which IIRC is the only case for requiring this in jspac?

Thomas Berezansky (tsbere) wrote :

MVLC will be running a "Test" of TPac where we will have both in use by patrons and staff in the coming months. We are already basically running "both", as will all 2.2 users not exclusively using TPac, due to TPac being the "basic" catalog now as well.

Changed in evergreen:
milestone: 2.2.0beta1 → 2.2.0rc1
Changed in evergreen:
milestone: 2.2.0rc1 → 2.2.0
Bill Erickson (berick) on 2012-06-11
Changed in evergreen:
status: In Progress → New
Changed in evergreen:
milestone: 2.2.0 → 2.2.1
Jason Stephenson (jstephenson) wrote :

I have questions:

1) Was this actually merged for TPAC?
2) If so, was it merged in time for 2.2.0?
3) Is it in 2.3?

I have a comment:

I think it is too late to add something like this to JSPAC. The 2.2 series is closed for new features, and JSPAC is deprecated in 2.3, which typically means no new features.

Changed in evergreen:
milestone: 2.2.1 → none
Kathy Lussier (klussier) wrote :

We have a consortium that would love to see this functionality in tpac. I got two +1's in IRC for not adding it to jspac at this point. Is there any chance we can move forward with this? It looks like the code needs to be rebased again

Changed in evergreen:
status: New → Confirmed
Ben Shum (bshum) on 2013-02-06
Changed in evergreen:
milestone: none → 2.4.0-alpha
Ben Shum (bshum) on 2013-03-03
Changed in evergreen:
milestone: 2.4.0-alpha1 → 2.4.0-beta
Ben Shum (bshum) on 2013-03-17
Changed in evergreen:
milestone: 2.4.0-beta → 2.4.0-rc
Ben Shum (bshum) on 2013-04-22
Changed in evergreen:
milestone: 2.4.0-rc → 2.5.0-alpha
Dan Wells (dbw2) wrote :

Marking as 'Incomplete' and untargeting for now. I'm interested in this feature, though (for TPAC), so hopefully we can get it rolling again.

Changed in evergreen:
milestone: 2.5.0-m1 → none
status: Confirmed → Incomplete
Bill Erickson (berick) wrote :

I've dusted this off and pushed the updated code to working/user/berick/lp856688-org-not-pickup-lib

It's still TPAC only, but since JSPAC is now deprecated, I think that's OK.

Changed in evergreen:
status: Incomplete → Confirmed
milestone: none → 2.5.0-beta1
tags: added: opac pullrequest
Dan Wells (dbw2) on 2013-09-12
tags: added: 2.5-beta-blocker
Changed in evergreen:
assignee: nobody → Lebbeous Fogle-Weekley (lebbeous)

This works as advertised, and I've pushed it with sign-off and upgrade script numbering. Thanks Bill.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Lebbeous Fogle-Weekley (lebbeous) → nobody
Dan Wells (dbw2) on 2013-11-11
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers