Method to retrieve carousel contents

Bug #1951318 reported by Jeff Davis
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
Wishlist
Unassigned

Bug Description

EG 3.7+

There doesn't seem to be an API call to retrieve the list of bib records for a given carousel. This would be handy for sites that want to use Evergreen carousel data externally without screen-scraping, iframes, widgets, etc. (compare bug 1882982), as well as for future carousel-related development within EG.

Revision history for this message
Jeff Davis (jdavis-sitka) wrote :

Working branch user/jeffdavis/lp1951318-retrieve-carousel-items has a work-in-progress implementation of such a method:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jeffdavis/lp1951318-retrieve-carousel-items

No pullrequest yet since this needs testing to ensure it returns data usefully and doesn't break existing carousel display. I won't have more time to devote to this in the immediate future, so if someone else feels like looking at it in the meantime, please feel free. :)

tags: added: opac-carousel
Changed in evergreen:
importance: Undecided → Wishlist
status: New → Confirmed
Revision history for this message
Jeff Davis (jdavis-sitka) wrote :

This seems to work without breaking anything, so I've added a pullrequest.

tags: added: pullrequest
Revision history for this message
Mike Rylander (mrylander) wrote :

A worthy refactoring which I like an approve of. Merged to master for 3.9. Thanks, Jeff!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
Andrea Neiman (aneiman)
no longer affects: evergreen/3.9
no longer affects: evergreen/3.9
Changed in evergreen:
milestone: none → 3.9-beta
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers