Item Status, Circ History List - Add Checkout Workstation and Staff

Bug #1919500 reported by Josh Stompro
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
Wishlist
Unassigned

Bug Description

EG 3.3

Because of the autorenew feature, more and more items have been renewed by the time a problem has come up and staff are looking for clues.

Two items of info that get overwritten on renewal are the checkout workstation and checkout staff member.

We had a situation where staff had checked items out to the wrong account, and the customer came and asked about it after the autorenewal happened. Staff wanted to see who had checked it out originally and at which workstation so they would know who to talk to about it. But that info isn't accessible after a renewal happens.

One possible way to resolve this is to add that info to the Circ History List tab, so staff can look at the staff member and workstation of the original checkout.

branch on the way.
Josh

Revision history for this message
Josh Stompro (u-launchpad-stompro-org) wrote :
tags: added: circulation
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Wishlist
Revision history for this message
Garry Collum (gcollum) wrote :
tags: added: signedoff
Changed in evergreen:
milestone: none → 3.next
Michele Morgan (mmorgan)
Changed in evergreen:
milestone: 3.next → 3.9-beta
Michele Morgan (mmorgan)
Changed in evergreen:
assignee: nobody → Michele Morgan (mmorgan)
Revision history for this message
Michele Morgan (mmorgan) wrote :

The proposed patch adds the workstation name and the checkout staff's id to the Circ History List, but the staff user seeking the information would need to then perform a patron search for that id to find the checkout staff user's info.

I've added a tweak to display the checkout staff's usrname instead of id, and a link to the staff user's record. Branch is here:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/mmorgan/lp1919500_checkout_staff_tweak

user/mmorgan/lp1919500_checkout_staff_tweak

tags: added: pullrequest
removed: signedoff
Changed in evergreen:
assignee: Michele Morgan (mmorgan) → nobody
Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
Revision history for this message
Jason Stephenson (jstephenson) wrote :

Works for me with concerto and produciton data. Pushed to master for the 3.9 release.

Thanks, Josh, Michele, Terran, and Garry!

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Jason Stephenson (jstephenson) → nobody
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers