"Error Retrieving Results" when trying to access secondary admin configuration pages in angular grid

Bug #1919483 reported by Christine Morgan
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Evergreen
High
Unassigned
3.6
High
Unassigned

Bug Description

To reproduce, from Server Admin -> MARC Import Remove Fields -> Import/Overlay field Groups for Removal Configuration, click on one of the "Fields" links. "Error Retrieving Results" displays instead of the configurations associated with that particular Fields group. Clicking on "Clear Filters" displays all configurations for all the groups.

Other Examples:

Local Admin -> Course Reserves List => Course List, click on a Terms Taught link -> Course Term Configuration

Server Admin -> Hard Due Date Changes -> Hard Due Dates Values Configuration, click on a Values link -> Hard Due Date Values Configuration

etc.

I would expect to see only the configurations associated with the chosen group.

This behavior is new with 3.6.2.

Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

Seeing this on 3.7 beta as well.

Server Admin -> Z39.50 Servers -> Z39.50 Attribute Configuration is also affected.

Changed in evergreen:
status: New → Confirmed
Revision history for this message
Jane Sandberg (sandbej) wrote :

I will be working on this on behalf of the BC Libraries Cooperative.

Changed in evergreen:
assignee: nobody → Jane Sandberg (sandbej)
importance: Undecided → High
Jane Sandberg (sandbej)
Changed in evergreen:
assignee: Jane Sandberg (sandbej) → nobody
tags: added: pullrequest
Revision history for this message
Jane Sandberg (sandbej) wrote :

Looks like bug 1846042 was the culprit; the URL-passed filters were representing the filters in a different way than the new grid filter code (single object vs array of objects), but the code was trying to treat them the same.

Here is a branch: user/sandbergja/lp1919483_secondary_admin_filters

Here is a link: https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/sandbergja/lp1919483_secondary_admin_filters

A note for testers: the current pull request for bug 1906058 switches the Course Term Configuration screen away from the auto-generated admin interface. If you test this code somewhere that already has the 1906058 fix applied, it's best to test this 1919483 fix on screens other than the course term one.

Revision history for this message
Christine Burns (christine-burns) wrote :

"I have tested this code and consent to signing off on it with my name, Christine Burns and my email address, <email address hidden>."

Fixed in both these spots = no error appears

Local Admin -> Course Reserves List => Course List, click on a Terms Taught link -> Course Term Configuration

Server Admin -> Hard Due Date Changes -> Hard Due Dates Values Configuration, click on a Values link -> Hard Due Date Values Configuration

tags: added: signedoff
Revision history for this message
Galen Charlton (gmc) wrote :

Pushed to master, rel_3_7, and rel_3_6. Thanks, Jane and Christine!

Changed in evergreen:
milestone: none → 3.7.2
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers