Terms Governing Use and Reproduction Note Displays Twice in Record Details

Bug #1917804 reported by Jennifer Pringle
40
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned
3.5
Undecided
Unassigned
3.6
Undecided
Unassigned

Bug Description

Evergreen 3.5.1 and 3.6

The information entered into the Terms Governing Use and Reproduction Note field (540 in the MARC record) display under General Note and Terms Governing Use and Reproduction Note in the Record details in the OPAC - both the TPAC and Bootstrap. This information should only display under Terms Governing Use and Reproduction Note.

The 540 under the General Note is displaying the information from all subfields including. Under Terms Governing Use and Reproduction Note only subfields a, b, c, d, f, g, q, and u display so extra information that may be confusing to patrons is being included under General Note - like $2 Source of term.

Garry Collum (gcollum)
Changed in evergreen:
status: New → Confirmed
Revision history for this message
Janet Schrader (jschrader) wrote :

I can confirm that the 546 language field also displays twice in the OPAC.
Release 3.2.8 Chrome browser Version 88.0.4324.150 (Official Build) (64-bit)

Another problem is when there are multiple contents fields only one displays in the OPAC.

See attached OPAC display.

Revision history for this message
Jeff Davis (jdavis-sitka) wrote :

The "General Note" field was originally intended to display only the contents of the MARC 500 field. However, it looks like it is actually showing the contents of the General Note display field (config.metabib_field id = 50), which is much more inclusive -- it contains anything matching '//mods33:note[not(@type)]' which apparently includes almost all the notes in the record, not just general notes. Since we already show most or all of those notes under more specific headings, we end up with a bunch of duplicate data.

A quick fix would be to revert to only showing MARC 500 data in the General Note field, as this working branch does:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/jeffdavis/lp1917804-general-note

If we want to go that route, perhaps the General Note display field (i.e. the config.metabib_field entry and associated data) should be removed altogether, since it isn't obviously used anywhere else.

tags: added: cataloging pullrequest
removed: cataloguing
Revision history for this message
Janet Schrader (jschrader) wrote :

Would this also fix LP# 1832785- Awards note field displays twice in record details? Can these bugs be merged?

Revision history for this message
Jeff Davis (jdavis-sitka) wrote :

I haven't looked at the code to confirm, but yes, bug 1832785 is probably the same bug.

Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
Revision history for this message
Janet Schrader (jschrader) wrote :

Jason,
I can confirm that the patch you installed on release 3.5 fixed the duplication of 546 and 586 fields in the OPAC display, these no longer display in the General Note. See screenshots.

Janet

Revision history for this message
Jason Stephenson (jstephenson) wrote :

Thank for testing, Janet! I, too, have verified the fix for the TPAC as well as the bootstrap OPAC (BooPAC?).

I've pushed the fix to master, rel_3_6, and rel_3_5 with a trivial backport.

Thanks, Jeff Davis, for the patch!

Changed in evergreen:
milestone: none → 3.7-beta
assignee: Jason Stephenson (jstephenson) → nobody
status: Confirmed → Fix Committed
tags: added: signedoff
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers