Angular Catalog: Hold status in View Holds is not saved

Bug #1917495 reported by Michele Morgan
24
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.6
Medium
Unassigned

Bug Description

When customizing columns in the angular catalog View Holds interface, if the user chooses the "Status" column (hold status) and saves grid settings, the column will not be remembered.

Looking at the saved workstation setting, the saved "Status" column is represented as:

"name": null

Dan Briem (dbriem)
Changed in evergreen:
assignee: nobody → Dan Briem (dbriem)
Revision history for this message
Dan Briem (dbriem) wrote :
Changed in evergreen:
status: New → Confirmed
tags: added: pullrequest
Changed in evergreen:
assignee: Dan Briem (dbriem) → nobody
Revision history for this message
Michele Morgan (mmorgan) wrote :

Works for me, also tested that the column appears in the traditional catalog. My signoff branch is here:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/mmorgan/lp1917495-hold-status-column-signoff

/user/mmorgan/lp1917495-hold-status-column-signoff

tags: added: signedoff
Changed in evergreen:
milestone: none → 3.6.3
Galen Charlton (gmc)
Changed in evergreen:
importance: Undecided → Medium
Changed in evergreen:
milestone: 3.6.3 → 3.6.4
Revision history for this message
Galen Charlton (gmc) wrote :

Pushed all the way down to rel_3_6. Thanks, Dan and Michele!

Changed in evergreen:
milestone: 3.6.4 → 3.7-beta2
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers