Add NULL printer to Force Printer Context menu

Bug #1891550 reported by Benjamin Kalish
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
Wishlist
Unassigned

Bug Description

Sometimes it is desirable to prevent the printing of a single type print template. Currently you can use a print template containing nothing but an HTML comment to approximate this, but receipt printers will still advance the paper a small amount. The addition of a NULL option to the Force Printer Context Menu in the print template editor would allow folks to completely suppress the printing of that template.

Context:
My library requires Hold Slips to be printed, but hasn't required Transit Slips in some time and recently did away with Hold Transit Slips as well.

Lynn Floyd (lfloyd)
Changed in evergreen:
status: New → Confirmed
importance: Undecided → Wishlist
Revision history for this message
Bill Erickson (berick) wrote :

+1 to this. And while reviewing, it occurred to me the Angular (Server) Print Template UI does not yet support applying a custom print context. Opened bug #1891923 to address that.

Bill Erickson (berick)
Changed in evergreen:
assignee: nobody → Bill Erickson (berick)
Revision history for this message
Bill Erickson (berick) wrote :

Branch pushed:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1891550-ang-print-template-force-context

From the commit:

Adds support to the Angular server template admin page for forcing a print context for a given template.

Adds support to the Angular print service for looking up the context of a print template when specified by name.

Adds support to And and AngJS print settings interfaces for a "No-Print" context, which bypasses printing when used.

Adds a new workstation setting for the Booking Capture server print template context.

--

I have marked bug #1891923 as a duplicate.

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.6-beta
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
milestone: 3.6-beta → 3.next
Revision history for this message
Terran McCanna (tmccanna) wrote :

Works great! I tested on several of the traditional templates and on a new angular template as well.

I ran into a merge conflict with 950.data.seed-values.sql while trying to sign off through git, so I'm signing off here:

I have tested this code and consent to signing off on it with my name, Terran McCanna, and my email address, <email address hidden>.

tags: added: signedoff
Revision history for this message
Bill Erickson (berick) wrote :

Thanks, Terran. Rebased with sign-off added:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1891550-ang-print-template-force-context-v2

Will ping Galen on merging since it's a mix of wishlist and bugfix.

Michele Morgan (mmorgan)
Changed in evergreen:
milestone: 3.next → 3.7-beta
Galen Charlton (gmc)
Changed in evergreen:
assignee: nobody → Galen Charlton (gmc)
Revision history for this message
Galen Charlton (gmc) wrote :

Pushed to master for inclusion in 3.7. Thanks, Bill and Terran!

Changed in evergreen:
assignee: Galen Charlton (gmc) → nobody
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers