Angular catalog: you can mark a record for holdings transfer, but not actually transfer them

Bug #1868354 reported by Jane Sandberg on 2020-03-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Undecided
Unassigned

Bug Description

It looks like the "Transfer (item/call number) to selected target" does not yet exist in the Holdings View of the Angular catalog.

Bill Erickson (berick) on 2020-03-31
Changed in evergreen:
status: New → Confirmed
assignee: nobody → Bill Erickson (berick)
Bill Erickson (berick) wrote :

Branch pushed to add support to the various holdings / items transfer operations:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/berick/lp1868354-ang-cat-holdings-xfer

From the commit:

--

Add support for 3 varieties of items and call number transfer in the Angular staff catalog.

1. Transfer selected items to selected call number.

2. Transfer selected call numbers and attached items to selected bib record.

3. Transfer selected items to selected bib record and org unit ID (owning library) creating new call numbers as needed.

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.5.0
Bill Erickson (berick) wrote :

Targeting for 3.5 since the feature is still considered experimental there.

Changed in evergreen:
assignee: Bill Erickson (berick) → nobody
Changed in evergreen:
assignee: nobody → Chris Sharp (chrissharp123)
Elaine Hardy (ehardy) wrote :

Tested several different transfers:

Call number and attached items from one record to another record, same library
Call number and attached items on same record to a different library
Items from one call number to another existing call number, on the same record, same library
Items from one call number to another existing call number, on the same record, different library
Items from one call number to a newly created, empty, call number, same record, same library.

All worked as expected.

One issue that is also with the current version of EG (3.4.1) remains -- if you have multiple tabs open for different records for transferring, marking the destination record in one tab doesn't update the marked holdings transfer in the other tab. You have to redisplay to see the marked ID, or the cleared mark. However, if you proceed with the transfer without redisplaying, the transfer works as expected.

Elaine Hardy (ehardy) wrote :

I have tested this code and consent to signing off on it with my name, Elaine Hardy and my email address, <email address hidden>.

I don't think the display issue with the marked transfer in an open tab should prevent this from being applied. It is minor but I wanted to mention it here.

Changed in evergreen:
assignee: Chris Sharp (chrissharp123) → nobody
status: Confirmed → Fix Committed
Chris Sharp (chrissharp123) wrote :

Pushed to Master and rel_3_5. Thanks to Bill and Elaine!

Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers