New A/T reactor for GET or POST

Bug #1860703 reported by Andrea Neiman on 2020-01-23
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Evergreen
Wishlist
Unassigned

Bug Description

Creates a new reactor that is able to send an HTTP GET or POST request to a URL specified in the A/T definition.

This work was funded by Ann Arbor District Library.

Branch forthcoming.

Mike Rylander (mrylander) wrote :

Below linked is a branch to implement this:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/miker/lp-1860703-http_action_trigger_reactor

From the commit message:

There is currently no stock mechanism for pushing information out of Evergreen to trigger activities in external systems. Third party discovery systems, among other external systems, would benefit from the ability to be alerted of changes to data within an Evergreen instance.

This commit adds such a capability by supplying a new A/T reactor module that can make HTTP requests that supply data to a third party endpoint.

To support the discovery system use case, this commit also adds a new A/T hook, bre.edit, fired whenever a bibliographic record is modified due to staff interaction.

tags: added: pullrequest
Changed in evergreen:
milestone: none → 3.5-alpha
Mike Rylander (mrylander) wrote :

I've force-pushed a fresh rebase of this branch, along with an additional commit that adds a few new hooks for use by the new reactor.

Troy Leonard (taleon) wrote :

I have tested this code and consent to signing off on it with my name, Troy Leonard, and my email address, <email address hidden>

Andrea Neiman (aneiman) on 2020-06-04
Changed in evergreen:
milestone: 3.5-beta → 3.next
tags: added: signedoff
Galen Charlton (gmc) on 2020-06-18
Changed in evergreen:
status: New → Confirmed
milestone: 3.next → 3.6-beta
Galen Charlton (gmc) on 2020-07-28
tags: added: needsreleasenote
Mike Rylander (mrylander) wrote :

Hi all,

I've pushed a branch with Troy's sign-offs and some shiny new release notes to https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/miker/lp-1860703-http_action_trigger_reactor-signoff

Thanks, Troy!

Galen Charlton (gmc) on 2020-07-28
tags: removed: needsreleasenote
Galen Charlton (gmc) wrote :

Pushed to master for inclusion in 3.6. Thanks, Mike and Troy!

Changed in evergreen:
status: Confirmed → Fix Committed
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers