Angular: Local Admin Circulation Limit Set Port

Bug #1847519 reported by Mike Risher
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evergreen
Fix Released
Wishlist
Unassigned

Bug Description

Evergreen: master

We’ll be porting the Circulation Limit Set UI from DOJO to Angular. This will be a grid interface + FM editor, with additional dropdowns with a list of Linked Circ Modifiers, Linked Copy Locations, and Linked Limit Groups. You can select multiple of each of these be selecting one and hitting “Add,” and you can unlink by hitting “Remove.”

Relevant files from the DOJO UI can be found here:

TT2: Open-ILS/src/templates/conify/global/config/circ_limit_set.tt2

Js: Open-ILS/web/js/ui/default/conify/global/config/circ_limit_set.js

Mike Risher (mrisher)
tags: added: admin-pages
Changed in evergreen:
assignee: nobody → Mike Risher (mrisher)
Revision history for this message
Mike Risher (mrisher) wrote :
Changed in evergreen:
assignee: Mike Risher (mrisher) → nobody
tags: added: pullrequest
Revision history for this message
Mike Risher (mrisher) wrote :

Correction - not yet ready to look at. Please hold off and I'll post another comment when it's good to go.

Changed in evergreen:
assignee: nobody → Mike Risher (mrisher)
tags: removed: pullrequest
Revision history for this message
Mike Risher (mrisher) wrote :
Changed in evergreen:
assignee: Mike Risher (mrisher) → nobody
tags: added: pullrequest
Bill Erickson (berick)
Changed in evergreen:
milestone: none → 3.5-alpha
status: New → Confirmed
importance: Undecided → Wishlist
Revision history for this message
Chris Sharp (chrissharp123) wrote :

Mike,

Unfortunately, I'm seeing an error during ng build --prod:

ERROR in app/staff/admin/local/circ_limit_set/circ_limit_set.module.ts:6:40 - error TS2307: Cannot find module '@eg/share/item-location-select/item-location-select.module'.

6 import {ItemLocationSelectModule} from '@eg/share/item-location-select/item-location-select.module';
                                         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

ERROR in app/staff/admin/local/circ_limit_set/circ_limit_set.module.ts(16,5): Error during template compile of 'CircLimitSetModule'
  Could not resolve @eg/share/item-location-select/item-location-select.module relative to [object Object]..

Looks like this is looking for a module that's not there?

tags: added: needsrepatch
removed: pullrequest
Revision history for this message
Mike Risher (mrisher) wrote :

Hi Chris,

The Circulation Limit Set Port relies on a new component: eg-item-location-select. You can see it back 1 commit in the git log.

Unfortunately, it looks like that component is still a work in progress. The launchpad thread is here:

https://bugs.launchpad.net/evergreen/+bug/1850555

Changed in evergreen:
milestone: 3.5-beta → 3.5.0
Changed in evergreen:
milestone: 3.5.0 → 3.5.1
Changed in evergreen:
milestone: 3.5.1 → 3.6-beta
Changed in evergreen:
milestone: 3.6-beta → 3.next
Revision history for this message
Mike Risher (mrisher) wrote :

This has been rebased to the current master, and instead of ngbTab this now uses ngbNav. I've confirmed that the <eg-item-location-select> component is on master, and that it's working with this module.

It's ready for testing. Here's the branch:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/mrisher/lp1847519-circ-limit-v2

tags: added: pullrequest
removed: needsrepatch
Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

The new Circulation Limit Set interface looks good to me but when I tried to add one to a circulation policy I found that new circ policies won't save at all (with or without circ limit sets). I don't know if it's this fix or a different one causing the problem but I can save circ polices as expected on a different test server.

Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

Tested this fix as the only patch on master and new circulation policies will not save.

Revision history for this message
Jennifer Pringle (jpringle-u) wrote :

Source of the circ policy issue has been found and it wasn't this patch. Everything working as expected now.

I have tested this code and consent to signing off on it with my name, Jennifer Pringle and my email address, <email address hidden>.

tags: added: signedoff
Revision history for this message
Chris Sharp (chrissharp123) wrote :

Pushed to master. Thanks Jennifer, Mike, and everyone who tested/commented.

Changed in evergreen:
assignee: nobody → Chris Sharp (chrissharp123)
status: Confirmed → Fix Committed
assignee: Chris Sharp (chrissharp123) → nobody
milestone: 3.next → 3.7-beta
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers